-   Slackware (
-   -   nm-applet - Slackware 14 (

tommytom 11-29-2012 06:26 AM

nm-applet - Slackware 14

I'm a new Slackware user for 1 month, and it work fine, I'm really happy of it.

But I still have one issue that I cannot fix. It's about nm-applet, I really need it to connect on the wifi network of my school. I tried with wicd, but I think the configuration of the wifi isn't available on it.

Anyway, I want to use NetworkManager with nm-applet. I'm using xfce, and when I execute nm-applet I get this message :


nm-applet: error while loading shared libraries: cannot open shared object file: No such file or directory
So I searched and it's about libgnome library, but there is tooooo much dep for libgnome (on

But my question is nm-applet must be able to lauch on default install, right?
If yes, why I cannot execute it?

I appreciate your help.

Have a nice day.

cwizardone 11-29-2012 09:53 AM

It appears to be looking for ORBit-2, which one would think would be included with the "Kitchen Sink" install of Slackware since the NetworkManager applet for Xfce has been added, but I can't find it in the package list.
You can find it here,

dugan 11-29-2012 10:31 AM

ORBit2 is not in slackware 14. It's available on

mrclisdue 11-29-2012 11:36 AM

nm-applet *should* work out-of-the-box (as in: no extraneous packages.) Did you do a less-than-full install?

(edit: verified working with xfce out-of-box)


tommytom 11-29-2012 11:43 AM

Yes I did full install, as I remember. It's really ennoying.

I tried to install ORBit2 but now, there is the same message on gnutls.

I don't want to reinstall my computer, is there a way to know if my installation is full?

mrclisdue 11-29-2012 12:23 PM

It's difficult to determine where you're "at" in terms of the configuration end of things. I'm curious as to why wicd wouldn't work, etc., and what you've done to get to the point of running nm-applet.

So I'll assume that, as root, you've done this, or similar:


# /etc/rc.d/rc.wicd stop
# chmod -x /etc/rc.dr/rc.wicd
# chmod +x /etc/rc.d/rc.networkmanager
# /etc/rc.d/rc.networkmanager start

and then, as a user:

$ nm-applet &
If this is the case, then we're in the same neighbourhood, and we can proceed....

the results of ifconfig, iwlist, lspci, etc. may help as well.


tommytom 11-29-2012 01:52 PM

Actually, it seems to be a lack of library, because as I said, now I have:


nm-applet: error while loading shared libraries: cannot open shared object file: No such file or directory
Maybe I should reinstall my system, to be sure.

TommyC7 11-29-2012 10:52 PM


# slackpkg file-search ""

Looking for libgnutls in package list. Please wait... DONE

The list below shows the packages that contains "" file.

[ installed ] - gnutls-3.0.23-x86_64-1

You can search specific packages using "slackpkg search package".

It appears you don't have gnutls installed, which is a part of a full installation. Because you do not have, and therefore the gnutls package, you did not do a full install.

tommytom 11-30-2012 05:19 AM

Ok, I just ckecked now, and the package gnutls is already installed. I reinstalled and same issue.

commandlinegamer 11-30-2012 06:04 AM

What does


ldd `which nm-applet`

tommytom 11-30-2012 07:09 AM

Quote: => not found
So right, but slackpkg tell me that it is installed. What can I do ?

Richard Cranium 11-30-2012 10:35 AM

That's very odd you are getting this error, since on my Slackware14 64 bit machine

ldd `which nm-applet` | grep tls
doesn't return anything at all.

Here's the full output. My nm-applet is found in /usr/bin, BTW.

$ ldd `which nm-applet` (0x00007fff445ff000) => /usr/lib64/../lib64/ (0x00007f1c90728000) => /usr/lib64/../lib64/ (0x00007f1c904ff000) => /usr/lib64/../lib64/ (0x00007f1c902d9000) => /usr/lib64/../lib64/ (0x00007f1c8fca8000) => /usr/lib64/../lib64/ (0x00007f1c8f9f5000) => /usr/lib64/../lib64/ (0x00007f1c8f7d3000) => /usr/lib64/../lib64/ (0x00007f1c8f5c7000) => /usr/lib64/../lib64/ (0x00007f1c8f39a000) => /usr/lib64/../lib64/ (0x00007f1c8f099000) => /usr/lib64/../lib64/ (0x00007f1c8ee7a000) => /usr/lib64/../lib64/ (0x00007f1c8ebcb000) => /usr/lib64/../lib64/ (0x00007f1c8e946000) => /usr/lib64/../lib64/ (0x00007f1c8e721000) => /usr/lib64/../lib64/ (0x00007f1c8e517000) => /usr/lib64/../lib64/ (0x00007f1c8e1df000) => /usr/lib64/../lib64/ (0x00007f1c8dfc1000) => /usr/lib64/../lib64/ (0x00007f1c8ddbd000) => /usr/lib64/../lib64/ (0x00007f1c8dbb8000) => /usr/lib64/../lib64/ (0x00007f1c8d96d000) => /lib64/ (0x00007f1c8d642000) => /usr/lib64/../lib64/ (0x00007f1c8d40c000) => /usr/lib64/../lib64/ (0x00007f1c8d180000) => /lib64/ (0x00007f1c8cf6f000) => /usr/lib64/../lib64/ (0x00007f1c8cd46000) => /usr/lib64/../lib64/ (0x00007f1c8cb0e000) => /lib64/ (0x00007f1c8c904000) => /lib64/ (0x00007f1c8c6f7000) => /usr/lib64/../lib64/ (0x00007f1c8c4ef000) => /usr/lib64/../lib64/ (0x00007f1c8c292000) => /lib64/ (0x00007f1c8c08f000) => /usr/lib64/../lib64/ (0x00007f1c8bd56000) => /usr/lib64/../lib64/ (0x00007f1c8bb29000) => /usr/lib64/../lib64/ (0x00007f1c8b8ee000) => /usr/lib64/../lib64/ (0x00007f1c8b6af000) => /usr/lib64/../lib64/ (0x00007f1c8b489000) => /usr/lib64/../lib64/ (0x00007f1c8b286000) => /usr/lib64/../lib64/ (0x00007f1c8b082000) => /usr/lib64/../lib64/ (0x00007f1c8ae44000) => /usr/lib64/../lib64/ (0x00007f1c8ab9b000) => /usr/lib64/../lib64/ (0x00007f1c8a974000) => /usr/lib64/../lib64/ (0x00007f1c8a627000) => /usr/lib64/../lib64/ (0x00007f1c8a412000) => /lib64/ (0x00007f1c8a1f8000) => /usr/lib64/../lib64/ (0x00007f1c89fb3000) => /usr/lib64/../lib64/ (0x00007f1c89d66000) => /usr/lib64/../lib64/ (0x00007f1c89b65000) => /usr/lib64/../lib64/ (0x00007f1c8995c000) => /usr/lib64/../lib64/ (0x00007f1c89759000) => /lib64/ (0x00007f1c89555000) => /usr/lib64/../lib64/ (0x00007f1c89330000) => /usr/lib64/../lib64/ (0x00007f1c89012000) => /lib64/ (0x00007f1c88df6000) => /lib64/ (0x00007f1c88bed000) => /lib64/ (0x00007f1c8882d000) => /usr/lib64/ (0x00007f1c8862a000) => /usr/lib64/ (0x00007f1c8841c000) => /usr/lib64/ (0x00007f1c88214000) => /usr/lib64/ (0x00007f1c88002000) => /usr/lib64/ (0x00007f1c87df8000) => /usr/lib64/ (0x00007f1c87bf6000) => /usr/lib64/ (0x00007f1c879f3000) => /usr/lib64/ (0x00007f1c877ed000)
        /lib64/ (0x00007f1c90930000) => /usr/lib64/../lib64/ (0x00007f1c875d7000) => /usr/lib64/../lib64/ (0x00007f1c87358000) => /usr/lib64/../lib64/ (0x00007f1c87155000)

tommytom 11-30-2012 12:18 PM

Ok, I tried a reinstallation and now I have a seg fault. It's crazy:


** (nm-applet:7877): CRITICAL **: dbus_set_g_error: assertion `gerror == NULL || *gerror == NULL' failed
Segmentation fault

tommytom 12-04-2012 04:48 AM

Ok I reinstall NetworkManager and nm-applet, delete all files, and install again, now it's working.

Thank you guys for your help.

All times are GMT -5. The time now is 09:56 PM.