-   Slackware (
-   -   NIC Installation: Cannot load Tulip module (

jadugarr 07-08-2003 05:26 PM

NIC Installation: Cannot load Tulip module
I just installed Sackware 9, and having problems getting my my LNE100TX nic installed. Autoprobe for this device failed in the install, but browsing around the forums I found that I should be able to install it by loading the tulip module (lsmod doesn't list it or any other modules loaded). However when I tried to load tulip using "modprobe tulip" I got the error:
modprobe: Can't open dependencies file /lib/modules/2.4.18/modules.dep (No such file or directory)

I am a newbie to slack, and this has me confused. Could something have gone wrong in the install? The only thing I did somewhat "abnormal" in the install is to not to install lilo, and instead boot from the bootdisk made during the install (so I wouldn't have to mess w/ lilo if I decided I didn't like slack). Thanks.

jadugarr 07-08-2003 06:09 PM

Oh, and modprobe error comes up every time I run it, not just when trying to load tulip.

Tinkster 07-08-2003 08:23 PM

Well, does the file actually exist?

Also, it strikes me as odd that
Slack 9 should be looking for
/lib/modules/2.4.18, since for
all I know it comes with a 2.4.20


jadugarr 07-09-2003 02:41 PM

I figured out why I was having a bunch of problems. For some reason the bootfloppy i made is 2.4.18 specific, which caused all sorts of problems. I setup lilo, and boot from it now, and the kernel runs as 2.4.20 like it is suppose too, and modules can be loaded now ... including tulip. However eth0 is still not installed when i run "ifconfig".

I "should" be able to get a my LNE100TX installed, as I noticed several other slackers have this NIC. If i don't get it soon though, ill just go get a new NIC that is guarenteed to work, as this is a version 1 that I bought about 5 years ago -- suggestions?


Tinkster 07-09-2003 03:19 PM

Had a look at dmesg yet?


jadugarr 07-09-2003 04:14 PM

I guess i don't need to post my dmesg results not that I have the nic installed. It turns out the nic was installed the whole time, I just had to run netconfig again so that 'ifconfig' could see it. I can now ping myself and my Netgear RP614 router, but I still cannot access/ping internet websites--problem w/ network setting working with the router now.

Tinkster 07-09-2003 05:23 PM

You'll probably need to set the routers
IP as your default gateway ...


jadugarr 07-09-2003 07:00 PM

Actually I had to mess with the DHCP settings and then restart the network. The netgear router doesn't work well with static IP addresses for some reason, but who cares ... I'm online now :).
Thanks for your patience and help.

Tinkster 07-09-2003 07:08 PM

Pleasue mate, and anytime :)


Kauser 07-21-2003 04:10 AM

Rather than start a new thread, this one was similar enough to use. I am running Mandrake 8.1, I have a LAN card that will work under Tulip. The Tarball is in a mounted drive. I read the readme, and where it states: vi makefile *kernal settings

I do not know what to input for those settings. Essentially I do not know how to build the driver, nor what to do with it once it's built. Any assistance would be appreciated, thank you.

All times are GMT -5. The time now is 09:22 PM.