-   Slackware (
-   -   nfs4 support (

[GOD]Anck 05-25-2009 09:22 AM

nfs4 support
Does Slackware 12.2 have any nfs4 support at all? /sbin/mount.nfs4 seems to be missing, and mount -t nfs4 gives an "unknown filesystem type" error..?

onebuck 05-25-2009 11:03 AM


From 'man nfs';


nfs - fstab format and options for the nfs and nfs4 file systems


NFS is an Internet Standard protocol created by Sun Microsystems in
1984. NFS was developed to allow file sharing between systems residing
on a local area network. The Linux NFS client supports three versions
of the NFS protocol: NFS version 2 [RFC1094], NFS version 3 [RFC1813],
and NFS version 4 [RFC3530].
I believe that the support is contained/supported by '/sbin/mount.nfs'. You could try the 'auto' to see if it works. You are certain that it is a nfs4 filesystem?

[GOD]Anck 05-25-2009 12:52 PM

Yes, I'm sure.. I mounted the same filesystem on a Debian box using mount -t nfs4 and /bin/mount showed me:

Code: on /mnt/data type nfs4 (rw,addr=
When I try from my Slackware box with mount -t auto, it tells me:


mount: special device does not exist
When I try with mount -t nfs I get access denied and the server log complains:


May 25 19:31:05 s17 mountd[3869]: refused mount request from for /data (/): not exported
mountd shouldn't even be involved in an nfs4 mount, right? So mount -t nfs probably tried to use v3 instead, and failed.


Looked at my kernel config, it seems the default is:


# CONFIG_NFS_V4 is not set

Kind of strange that the default has v4 server enabled, but not client, but okay.. on the off chance, I recompiled my kernel with CONFIG_NFS_V4=y, and also reinstalled the nfs-utils package, but neither made any difference.

[GOD]Anck 05-25-2009 03:26 PM

Found my answer in the nfs-utils.SlackBuild, nfs4 support is in fact disabled:


# No NFSv4 yet -- it requires additional libraries.
I'll have to build my own then.

[GOD]Anck 05-25-2009 05:33 PM

For reference, and in case nfs4 support doesn't make it into the next Slackware, here's how to add your own, quick and dirty:
  • Download, configure && make && make install libevent and libnfsidmap, find them at citi
  • Grab the nfs-utils slackbuild and sources from your favorite mirror. Edit the slackbuild, s/--enable-nfsv4=no/--enable-nfsv4/g, comment out line 103 (rm -rf $PKG/sbin/*nfs4), build and install the nfs-utils package
  • Recompile your kernel with CONFIG_NFS_V4=y
  • modprobe nfs, this doesn't get autoloaded for some reason
  • mount -t nfs4 your.nfs4.server:/path /mnt/point (if you don't specify -t, mount will try nfsv3 instead)

onebuck 05-25-2009 07:54 PM


I don't use nfs4 at this time but it's good that you found the solution.

Thanks for posting back.

camerabambai 11-04-2011 05:59 PM

Nfs4 works fine on Slackware 13.37
someone know how to set autofs?

hpfeil 11-28-2011 02:54 PM

Tried to mount an NFSv4 export from a HPC server so I could ramp up openmpi on multiple boxen.
mount.nfs: an incorrect mount option was specified
Checking the SlackBuild configure, "--enable-nfsv4=no" is still in Slackware Current (nfs-utils-1.2.3-x86_64-3). This after spending some time trying to figure out why the directory /var/lib/nfs/v4recovery was missing. If I ssh to the cluster, I can mount /home/hpc1, mpirun appears to work, but I'm rewriting the cpu/core inventory to include the cpuid info (the processes could all be running on the 4 cores on that box). Farther down in nfs-utils.SlackBuild:

# No NFSv4 yet, so remove these:
rm -f $PKG/sbin/*nfs4

provides another clue. Which libraries are missing? I'll try to configure and make the source with nfs4 enabled, maybe ldd will say what's missing?
I know the Slackware Team has their plate full, so we need to pitch in and help in such matters. Current file list has 3148 packages to manage.
`bzcat MANIFEST.bz2 | wc -l` is up to 376,576 files, not that anyone installs everything.

camerabambai 11-29-2011 07:59 AM

libnfsidmap is the first needed

camerabambai 11-29-2011 08:08 AM

libgssglue is another one
librpcsecgss another one

camerabambai 11-29-2011 08:24 AM

Try to recompile but

checking for krb5_get_error_message in -lgssapi_krb5... yes
checking for krb5_get_init_creds_opt_set_addressless in -lgssapi_krb5... no
checking for authgss_create_default in -lrpcsecgss... no
configure: error: librpcsecgss not found.
make: *** Nessun obiettivo specificato e nessun makefile trovato. Stop.
make: *** Nessun obiettivo specificato e nessun makefile trovato. Stop.

Of course i had installed librpcsecgss

camerabambai 11-29-2011 12:10 PM

Probably found solution

camerabambai 11-29-2011 12:34 PM

checking for unistd.h... yes
checking for clnt_tli_create in -ltirpc... no
configure: error: libtirpc not found.


camerabambai 12-03-2011 06:20 PM

With tirpc package from and other packages listed
in works fine.

camerabambai 12-03-2011 07:39 PM

Nfs4 works fine :)

All times are GMT -5. The time now is 04:01 AM.