LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-15-2011, 01:30 PM   #1
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 564

Rep: Reputation: Disabled
NFS share mounting problem


I have two computers on my home network, a desktop & a laptop. I use the desktop for a short time every morning & my wife is on & off of it during the rest of the day. I use the laptop for my primary machine & have an NFS share set up on the desktop so that I don't have to duplicate data between the two computers. Both of the machines run -current. Since the recent update to 13.37, my NFS share has been mounted weirdly on the laptop. The folder is shared on the desktop via this line in /etc/exports:
Code:
/mnt/spock      192.168.123.0/24(rw,no_subtree_check,no_root_squash)
The desktop is properly identified in the laptop /etc/hosts:
Code:
192.168.123.8   kirk.enterprise.lan kirk
The share is mounted on the laptop via this line in /etc/fstab:
Code:
kirk:/mnt/spock         /mnt/spock      nfs     noauto,users,rw,hard,intr,rsize=16384,wsize=16384
I have a postconnection script in wicd that mounts the share if the network & desktop are found. I also have a script on the desktop that chowns all directories/files to bill:users & chmods directories to 775 & files to 664. I do not remember now why I set directories to 775, but I had some good reason & it works for us. In the past the share on the laptop had the same owner/group/permissions as were on the desktop. Now the permissions are the same, but the owner group show up as:
Code:
$ ls -l /mnt/spock
total 52
drwxrwxr-x 13 4294967294 4294967294 4096 Dec 28 13:59 data/
drwxrwxr-x  5 4294967294 4294967294 4096 Mar  8 11:50 ebooks/
drwxrwxr-x  2 4294967294 4294967294 4096 Mar 13 14:01 isos/
drwxrwxr-x  2 4294967294 4294967294 4096 Dec 24 16:50 lost+found/
drwxrwxr-x 46 4294967294 4294967294 4096 Mar  3 21:21 music/
drwxrwxr-x 74 4294967294 4294967294 4096 Mar  7 16:40 pictures/
drwxrwxr-x  7 4294967294 4294967294 4096 Feb  5 10:13 sbopkg/
drwxrwxr-x  4 4294967294 4294967294 4096 Feb 25 07:59 slack/
drwxrwxr-x  5 4294967294 4294967294 4096 Dec 24 12:00 tags/
drwxrwxr-x  2 4294967294 4294967294 4096 Mar 13 14:25 transfer/
drwxrwxr-x  9 4294967294 4294967294 4096 Jan 12 14:30 videos/
drwxrwxr-x  4 4294967294 4294967294 4096 Dec 24 12:39 wavs/
drwxrwxr-x 12 4294967294 4294967294 4096 Dec 24 12:39 windows/
Every directory/file on the share has owner & group set to 4294967294. This seems to make no difference to the usability of the share. "cp" copies a file to the share with the above numbers as owner & group. "rsync" does the same, but gives the error:
Code:
rsync: chgrp "/mnt/spock/transfer/home/.file.laJChp" failed: Remote I/O error (121)
I googled the error & found that ErrNo 121 is a Remote I/O error (Duh!). By the way, the owner/group/permissions are correct on the desktop, even for files written from the laptop.
How can I fix this?
Regards,
Bill
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 03-15-2011, 10:21 PM   #2
dwalkes
LQ Newbie
 
Registered: Nov 2008
Posts: 2

Rep: Reputation: 0
Hi Bill,
I think 4294967294 is "nobody" which in my experience means you've copied a file with user/group that is not mapped on the system in question (the laptop if I understood your post). I'd recommend looking at your /etc/passwd and /etc/group file on the desktop to determine the UID/GID value for bill:users (typically the only number on the line with matching user or group name). Compare this to the uid/gid for the same accounts on the laptop. I think this problem can happen if the laptop does not use a uid/gid with the same value.
 
Old 03-21-2011, 06:26 AM   #3
myoung
LQ Newbie
 
Registered: Nov 2010
Posts: 27

Rep: Reputation: 0
Hi,
I am having the same problem but I do have the same uid/gid values on both computers.
They have the same /etc/passwd /etc/shadow and /etc/group files
Both are running slackware-current
I think it broke with "Slackware 13.37 release candidate 2"
 
Old 03-21-2011, 06:41 AM   #4
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 91
This is a side-effect of using NFSv4.
Try setting "vers=3" in the options of your fstab file - that worked for me...
 
2 members found this post helpful.
Old 03-21-2011, 07:19 AM   #5
myoung
LQ Newbie
 
Registered: Nov 2010
Posts: 27

Rep: Reputation: 0
Thank you for "vers=3".
I will use that until NFSv4 learns about users and groups.
I presume NFSv4 will learn about users and groups in the near future!

My googling gave me the idea that idmapd would fix this problem without changing back to NFSv3
but I did not find nice instructions on how to set it up and it seems odd to me that NFSv4
does not know about users and groups.
 
Old 03-21-2011, 08:43 AM   #6
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 91
Yes, NFSv4 does not work with UID or GID - it uses idmapd.
But this does not work in Slackware at the moment...

It's on my "to-do" list, as I use NFS mounts a lot, but for now I am using the "vers=3" option, so that I can do some research without the pressure of a non-working system
 
Old 03-21-2011, 04:11 PM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,559

Rep: Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106
Quote:
Originally Posted by niels.horn View Post
Yes, NFSv4 does not work with UID or GID - it uses idmapd.
But this does not work in Slackware at the moment...

It's on my "to-do" list, as I use NFS mounts a lot, but for now I am using the "vers=3" option, so that I can do some research without the pressure of a non-working system
Slackware's installer hard-codes "vers=3" as an option to the nfs mount since 13.1.

Eric
 
Old 03-21-2011, 04:41 PM   #8
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 91
Well, something is not working then...

This is an example of a mount output when the "vers=3" option is not given:
Code:
niels-sw:/srv/data/ftp_pub/pub on /srv/data/ftp_pub/pub type nfs (rw,rsize=8192,wsize=8192,hard,intr,vers=4,addr=192.168.2.110,clientaddr=192.168.2.1)
It definitely defaults to "vers=4"

This is on a Slackware 13.1 box mounting an NFS directory hosted on a -current box.
The path is "exported" in /etc/exports on the server and mounted automatically from /etc/fstab on the client.

<edit>
Hm, reading your post again, I see you said that the *installer* uses vers=3.
But normal mounts default to vers=4
</edit>

Last edited by niels.horn; 03-21-2011 at 04:56 PM.
 
Old 03-21-2011, 05:45 PM   #9
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 91
I just checked the nfs-utils package and its SlackBuild script, and now have a suggestion for Pat...

Since nfsv4 is not supported yet in Slackware (it is disabled in the configure stage), maybe it would be nice to:

1) configure with the "-enable-mountconfig" option
2) include the standard /etc/nfsmount.conf file
3) set "Defaultvers=3" in this file

I tried this here and it works.

Just an idea...

Last edited by niels.horn; 03-21-2011 at 05:46 PM. Reason: typo...
 
Old 03-22-2011, 05:51 AM   #10
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 91
And fixed with the latest -current update, now 13.37-RC3!
 
Old 03-22-2011, 04:22 PM   #11
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 564

Original Poster
Rep: Reputation: Disabled
Thanks to everyone, particularly Niels & Pat. Today's updates have solved my problem. All is now well, again. Sorry I haven't visited this thread, except to open it & now to mark it solved, but life has been rather hectic around here for the past two weeks, including a wreck that still has my pickup in the shop, so have been hassling insurance cos, rental car cos, etc. More fun.
Regards,
Bill
 
Old 03-25-2011, 10:30 AM   #12
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 546Reputation: 546Reputation: 546Reputation: 546Reputation: 546Reputation: 546
Apparently this problem affects 13.1 too. Yesterday I installed 13.1 on a spare hard drive. NFS refused to connect from that box to a 12.2 system. I had to add nfsvers=3 as a mount option. I had no problem using NFS to connect from the 12.2 system to the 13.1 shares.
 
Old 03-25-2011, 11:00 AM   #13
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,559

Rep: Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106Reputation: 8106
Quote:
Originally Posted by Woodsman View Post
Apparently this problem affects 13.1 too. Yesterday I installed 13.1 on a spare hard drive. NFS refused to connect from that box to a 12.2 system. I had to add nfsvers=3 as a mount option. I had no problem using NFS to connect from the 12.2 system to the 13.1 shares.
Yes, that is why I mentioned 5 posts up that "Slackware's installer hard-codes "vers=3" as an option to the nfs mount since 13.1."

Eric
 
Old 03-25-2011, 11:07 AM   #14
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 546Reputation: 546Reputation: 546Reputation: 546Reputation: 546Reputation: 546
Quote:
Yes, that is why I mentioned 5 posts up that "Slackware's installer hard-codes "vers=3" as an option to the nfs mount since 13.1."
You did, but I did not notice that. When I ran into the problem last night I remembered this thread. I started reading from the end of the thread to find the snippet of text I needed to add as a mount option. So although you mentioned that five days ago I did not scroll back that far.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Problem mounting NFS share theillien Linux - Networking 1 09-19-2010 05:38 PM
NFS share not mounting SUSE-OES Linux - Server 3 03-09-2009 06:13 PM
Problem mounting NFS share at boot amishtechie Linux - Networking 1 03-17-2007 10:23 PM
mounting nfs share jon23d Slackware 4 06-25-2006 03:19 AM
nfs share is not mounting automatically pawlub Linux - General 1 01-03-2004 06:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration