-   Slackware (
-   -   Newly created users can't startx keyboard errors (

damgar 09-22-2010 06:55 PM

Newly created users can't startx keyboard errors
I have 3 accounts setup on this machine. One is root, one is my own, and one is for my kids. My account and root work fine, but today when I tried to log my kids on, startx fails (it also fails from runlevel4). I have tried creating new accounts and they fail as well. I'm not sure when the issue started, but it's been less than a week I believe. The consistent error which I receive is

(EE) Error compiling keymap (server-0)
(EE) XKB: Couldn't compile keymap
XKB: Failed to compile keymap
Keyboard initialization failed. This could be a missing or incorrect setup of xkeyboard-config.

Fatal server error:
Failed to activate core devices.

Please consult the The X.Org Foundation support
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
I have tried reinstalling my xkeyboard-config package.

quanta 09-22-2010 09:46 PM

Have a look at /var/log/Xorg.0.log:

egrep 'WW|EE' /var/log/Xorg.0.log

damgar 09-23-2010 12:56 AM

Thanks for the reply. The above error message is from /var/log/Xorg.0.log. Ultimately I used slackpkg to roll back from current and back again, overwriting config files both times. I guess that's like using a sledge on a flea bite, but the itching stopped all the same. :) Marking as solved.

spoovy 11-18-2010 07:55 AM

Not really solved is it. I seem to have encountered the same problems as well - exactly the same error - but wiping everything isn't too attractive an option for me.

All times are GMT -5. The time now is 01:32 AM.