-   Slackware (
-   -   newbish install problems (

mrFergo 06-30-2003 05:26 AM

newbish install problems
I tried to install Slackware 9.0 booting directly from the CD (my PC doesn't feature a diskdrive). The installation went just fine until I got to the configuration part. When trying to type in a root password, I get an error saying that the program can't be found or something lame like that. From there, I can't continue the configuration.

Any ideas?


hexbit 06-30-2003 12:53 PM

What was the exact error msg? Also, how far into the installation were you able to get - what configuration part?

mrFergo 06-30-2003 03:44 PM

Sorry for being so unspecific. The graphical setup program has a number of steps - you select a target partition, source, what to install etc. Now, the configuration part I'm talking about is the second last step of the setup program; see under the caption "CONFIGURE" here!

The first step of this configuration is to specify the root password. Or, more correctly, I'm asked if I want to specify the root password. If I choose "Ok" I get an error message that "something" can't be found (perhaps a program? I can't remember the exact error message, so I'll have to look that up by running the process again). If I choose "Cancel" on the other hand, I'm told that the configuration is finished (which it clearly isn't) and then exhorted to reboot the system. Now, this isn't supposed to happen, right?

DaOne 06-30-2003 09:13 PM


Now, this isn't supposed to happen, right?
No...this isn't supposed to happen. You should be able to specify a root password when prompted. I seem to remember someone else having the same problem, and it was thought to be a bad iso...or a bad cd.
In summary, I would at least try downloading another iso (perhaps from a different site), burn it to cd, and give it another try. Hopefully this helps, and good luck.

grym 06-30-2003 10:36 PM

root password
try going to another terminal window and set the password before rebooting if it says it's missing an executable at that point install that tgz and try again.

worked for me before

mrFergo 07-02-2003 12:26 PM

Ok, I went through the installation again. This is the error message I get...


chroot: cannot execute /usr/bin/passwd: no such file or directory

grym 07-02-2003 01:53 PM

for that install package: shadow-4.0.3-i386-6.tgz

it is in the /slackware/a/ DIR on your cdrom

then try again to set the password

mrFergo 07-02-2003 07:20 PM

Ok, I'll do that... but shouldn't the setup program do that for me!? I mean if there's something wrong with the ISO or CD, then I might as well get myself a new copy instead.

DaOne 07-02-2003 09:27 PM

I remember someone else having the same issue, and the shadow package was missing from the cd (the cd was burned from a downloaded iso). If this package is missing from your cd, I suggest downloading another never know what other packages are missing and/or corrupt.

On the other hand, did you do a "full" install? Or did you select packages? If you selected your individual packages, is it possible that you inadvertantly unchecked this package? Just a thought...:)

grym 07-02-2003 11:08 PM

should it have been installed?
Slackware does not have automatic package dependencies resolution so even if another package depended on it it wouldn't care it would just do what it's told. This is not bad just different from the hand holding every other distro does.

That being said tho I do think this is one of the packages that is listed as required on a default type install.

Me personally if there was no other issues I'd install the package it takes a few seconds and I've been successful with it before.

All times are GMT -5. The time now is 01:05 AM.