LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-23-2004, 02:29 PM   #1
charlie.babitt
LQ Newbie
 
Registered: May 2004
Posts: 7

Rep: Reputation: 0
newbie with mounting problems


Hi folks...
I'm a newbie and want to mount a fat32, but somehow it only works for root. But all the other users should have the premission to read and write this partition, too.
Here's my current fstab:

/dev/hda8 swap swap defaults 0 0
/dev/hda7 / ext3 defaults 1 1

/dev/hda5 /mnt/hda5 vfat defaults,user 1 0

/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

hda5 is the partition we are talking about.
I added vfat and user.
What's the problem.
The strange thing is, if I unmount /mnt/hda5 as root, I can mount it with /mnt/hda5 as a normal user, and can read and write. But I don't want to unmount it always first as root.
What do I have to change?
 
Old 05-23-2004, 02:47 PM   #2
lacerto
Member
 
Registered: Oct 2003
Location: South London
Distribution: Gentoo.
Posts: 297

Rep: Reputation: 30
what are the permissions on the mount moint? i.e./mnt/xxxx
 
Old 05-24-2004, 05:41 AM   #3
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 5,388

Rep: Reputation: 408Reputation: 408Reputation: 408Reputation: 408Reputation: 408
I am not sure that 'defaults' and 'user' parameter used both for a mount point works well. Maybe the 'defaults' setting override 'user' setting ?
 
Old 05-24-2004, 07:52 AM   #4
ProtoformX
Member
 
Registered: Feb 2004
Location: Canada
Distribution: LFS SVN
Posts: 334

Rep: Reputation: 34
make your user part of the disk group now edit your fstab so it looks like this

Code:
/dev/hda5        /mnt/win32      vfat        gid=6,noauto,user,owner,umask=000    0 0
now log out and log back in and now you can mount your fat32 partiton.

Last edited by ProtoformX; 05-24-2004 at 07:53 AM.
 
Old 05-24-2004, 08:01 AM   #5
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
A slight style difference from the last post. You can use the name of the group instead of the group id. That way, you don't need to lookup the gid of the disk group.
/dev/hda5 /mnt/win32 vfat gid=disk,noauto,user,owner,umask=000 0 0
 
Old 05-24-2004, 08:46 PM   #6
herbc
Member
 
Registered: May 2004
Location: United States
Distribution: Slackware 10.0
Posts: 72

Rep: Reputation: 15
I believe defaults includes mounting at boot-time. If so, hda5 was already mounted.
mount -o remount /dev/hda5 by a user should work in that case, as would umount /dev/hda5.

defaults sets the rw, suid, dev, exec, auto, nouser, and async options. See man mount.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Just another Newbie: Mounting a CD-RW Properly detrix Linux - Newbie 3 10-24-2004 04:15 PM
A very (newbie) question about mounting ahmed_alzahrani Linux - Newbie 5 09-12-2004 06:16 PM
Mounting Samba Shares (Newbie) disinformation Mandriva 3 09-20-2003 08:01 AM
mounting Backpack drive **newbie** pbhj Linux - Hardware 3 12-08-2002 02:23 PM
Newbie Question (mounting drives/partitions) Abremelin Linux - Newbie 11 07-01-2002 10:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration