LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   New kernel, 5.1 / 5.1.2 boot failure strangeness (https://www.linuxquestions.org/questions/slackware-14/new-kernel-5-1-5-1-2-boot-failure-strangeness-4175653980/)

petejc 06-19-2019 04:39 PM

Quote:

Originally Posted by Ilgar (Post 6002042)
I think I stumbled upon a seemingly similar problem. My old Dell Precision M4300 laptop running Slackware64 14.2 fails to boot with 5.1.x, although 5.0.6 was working fine. I tried 5.1.4 and 5.1.7, the first built on a relatively modern computer and the second on the Dell itself. In both cases I get the darkstar prompt. However, before it loads the modules from initrd and right after the initialization of eudev I see a "Bus error" line in the output. It appears again after the initrd module-loading messages. Do you remember if you had that error, too?

Btw, in both cases the builds were made on Slackware64 14.2.

Sorry, did not notice your post untill today. Sorry, did not notice.

duncan_roe 06-19-2019 07:24 PM

Bug 203935 submitted to bugzilla.kernel.org

duncan_roe 06-21-2019 08:05 PM

Bug 203935 is resolved
 
1 Attachment(s)
The problem was only seen on old AMD K8 systems (like my 10YO Athlon) and building with old GCC (e.g. 5.5.0).
I closed the bug after testing the attached fix.
Please try it yourselves.

Ilgar 06-22-2019 07:42 AM

I will test it tomorrow, but that Dell laptop of mine had an Intel CPU, not AMD.

Ilgar 06-23-2019 11:17 AM

Good news everyone! Both duncan_roe's original revert and the new upstream patch worked perfetly well.

@duncan_roe: Thank you so much for all the work you have done on this. I was not expecting this to be solved so quickly!

sebastians 06-24-2019 07:32 AM

Gotta be honest, I'm new with Slackware and I'm experiment with my first Kernel compilation ever.

I had the same exact problem on a ThinkPad T400 and version 5.1.14 of the kernel.

It suddenly stop at login with a "too fast" kind of error and Darkstar as hostname. I could not even login with any user account. I thought it was due to my inexperience, but then I compiled version 4.19.55 in the same identical manner... and it works.

I tried to follow this thread, but still I am not that fluent with kernel related stuff to have a clear idea on how to fix this and can't find nothing on the docs. Actually, I don't really need the latest kernel version "just because", is that I got on Slackware, because I want to learn it (you know, the old saying about slack...).

If some good soul is willing to help, it would be terrific on my journey to dissect and understand the whole GNU/Linux system.

Ilgar 06-24-2019 03:02 PM

Hi there sebastians,

The patch hasn't made it to the release version yet (maybe it will be included in 5.1.15). Assuming that you already know how to compile your own kernel, all you need to do is the following:

- Save the attached patch file in duncan's latest post (post #18) somewhere on your hard drive.

- Then go to /usr/src/linux-5.1.14, or whatever is the directory into which the kernel source is unpacked.

- Do
Code:

patch -p1 < [location of the patch file]
As output, it will list the files that are patched. In this case there is only one.

- Then compile your kernel as usual.

The '-p1' is about the relative depth to be used for directory names when reading the patch files' contents (just take a look at the file and it will be clear). The '<' directs the contents of the patch file into standard input (stdin), which the patch command reads.

sebastians 06-24-2019 08:11 PM

Awesome! Thanks @Ilgar.

duncan_roe 06-25-2019 01:45 AM

The patch is in 5.2-rc6

Ilgar 06-25-2019 04:55 AM

Quote:

Originally Posted by duncan_roe (Post 6008748)
The patch is in 5.2-rc6

It made it to 5.1.15 as well.


All times are GMT -5. The time now is 04:40 PM.