-   Slackware (
-   -   new convert to slackware - problems installing bluefish editor though (

melquiades 07-03-2003 10:12 PM

new convert to slackware - problems installing bluefish editor though
hi all,

finally got myself slackware 9 and installed it without a hitch, the installer was great and so far I'm VERY impressed with everything to do with the distro, the best linux I've ever used by far. kde 3 works a treat as does everything else.

however, I've run it to the same problem I've always had with every other distro - that of installing software myself. stuff installed by the distro works fine but I've never once managed to install extra software - ever!

I'm trying to install bluefish, the html editor (I'm a web designer and would like to switch to linux full time but I need a replacement for textpad, which is what I use under windows) I hand code standards compliant XHTML so really just want a text editor with syntax highlighting and a clip library, which is why I can't use quanta which is installed and working. bluefish seems the answer so I tried installing from the sources. the configure thing seems to have worked but the make command just throws up a huge bunch of errors and then exits. so then I tried installing all the various rpms but none of them worked - package dependencies by the truckload - but surely slackware 9.0 is pretty up to date?

can anyone help an idiot through this because I would love to use linux as my primary OS, hell it's taken over my personal computing needs completely in just 36 hours - now i want it to do my professional needs too!

thanks for reading this rather long post if you've got this far - any and all help gratefully recieved

with warmest thanks in advance,

PS - does anyone know of a good open source CSS editor too? that's the other necessary app I need to do my work but all the ones I find when searching are commercial apps and I would to move to the open source side of the divide :)

Locura 07-03-2003 10:31 PM

If you could post some of the errors that may help. It's probably a dependency that is not installed.

And you don't install RPMs on a Slack box, you need to use rpm2tgz to convert it to a Slackware package and then run installpkg insert-package-name-here.tgz. However, if you don't have the dependencies installed, installing the tgz isn't going to do you any good anyway. So like I said, post some of the errors you are getting.

melquiades 07-04-2003 07:08 AM

Woah! Sweet god I love slackware! ran rpm2tgz under su root then install pkg et viola! I now have blufish! and the install time was like 0 seconds - also it has a built in CSS editor so my other question is also answered
thanks you very very much locura

as quick follow up question, below (bottom of post) is the package dependencies from kpackage when I ran the rpm through it - why are there so many missing dependencies when the packages must be there for the thing to be working now? is this just because it's an rpm and slackware (i now know :) ) uses tgz's?

Also the fonts in bluefish are really small on the menu bar, i.e. the system fonts. Now I've downloaded the bitstream vera fonts and have them working throughout kde, everything is in glorious antialiased vera fonts except mozila and bluefish. now I've read that the mozilla compiled for slack9.0 was missing a xft option or some such so I'll go and get the new rpm for that but why is bluefish fonts so small - surely they are controled by X and the window manager, in which case they should follow the convention/standard that the everything else does - or am I missing something here (not the editor ones I can change those from the prefs -which i have and all my html code is beautifully antialiased :D )

once again thank you very much locura, if you ever need any html help give me a shout :)

gtk2 >= 2.0.6, pcre >= 3.9, , , , , , , , , , , , , , , , , , , ,

melquiades 07-04-2003 01:28 PM

I've been researching these system fonts a bit and from what I can figure bluefish is made using the GTK 2 libraries - right. Now that's the gimp toolkit yeah? so presuming that both apps are using the same toolkit to 'draw' the buttons, menus etc then why does my copy of Gimp have larger menu text etc than bluefish.

I've tried looking through the gtk2 docs in my /usr/docs directory but the only references are to a .gtk2rc-2.0 file. now I have two similar files but they only contain a DTD and the other is colour info - so how am I meant to change the options (like font size) for the gtk controlling bluefish, and why is it a different setup to gimp?

I'm trying to work out the solution to this myself rather than just get people to hold my hand through linux but damn is it difficult to figure these things out if you're not a programmer!

hope someone can help, cheers

Locura 07-04-2003 10:27 PM

The .gtkrc file will set theme properties for GTK+ 1.2 apps. The .gtkrc-2.0 file does the same, only for GTK+ 2.x.

And I am not familiar with kpackage, I tend to avoid KDE when I can. I would venture a guess, though, that the reason you see all those dependency errors is because kpackage seems to be an app to keep track of installed RPM packages, and Slackware does not use RPM for package management. So it's not finding an installed RPM for GTK2, even though you know it's installed.

And while we are on the topic of HTML, I have a funny CSS problem with my browsers, and I'm wondering if other slack users are getting the same thing. When I put my mouse over a link that has "text-decoration: underline" defined as the a.hover behavior, in other words a link that is only underlined when you put the mouse over it, no line appears. the "overline" behavior works fine, but underlines don't appear. This happens both in Mozilla and Mozilla Firebird. Have you had the same problem with Slack 9?

melquiades 07-05-2003 10:13 AM

I tried the following HTML segment in both Mozilla 1.3 and Konqueror 3.1 and worked exactly as expected.

<style type="text/css"><!--
a {text-decoration:none;}
a:hover {
text-decoration: underline;
color: red;
check this link: <a href="">this is a link</a>

in your post you put a.hover - having you got a. or a: in your html? other than that I don't know what it could be - post your bit of HTML if you want and I'll have a look for you.
link to the above HTML in a page to test if you like

on the ongoing GTK font battle I still can't get those bloody fonts bigger - even more annoying is that in gnome all the GTK apps have lovely perfectly sized fonts. In kde all the GTK apps have the same tiny wee piddly fonts - I know it not a great problem but when you stare at a screen for most of the hours of the day you want to be able to see! lol! I've tried making .gtkrc-2.0 files with font lines in them but from what I can find on the net those files just control the themes and the fonts aren't part of the themes, they must be controlled from somewhere though, and it must be KDE/Gnome specific since they're showing them differently - don't supopse anyone knows where they're set from? was thinking about email someone at but I reckon there must be a simple answer to this without having to bother those guys :)

here's a small screenshot to show you what I've got...

Locura 07-05-2003 01:08 PM

You can control the fonts in GTK2 apps by running gnome-font-properties.

And, the CSS code is right, it worked when I was using Mandrake with the same browsers, and it works when I pull the page up on a Windows box. I don't get underlines on ANY site, not just ones I have coded. This problem has only came about since I made the switch to Slack.

melquiades 07-05-2003 02:41 PM

well it seems to be fine on mine - have you got any default stylesheets set in the properties of the browsers? or a setting somewhere set to hide underlines on links - one of the problems of linux that I'm finding is that there's a million settings for everything :)

thanks for the fonts solution - now have ALL my fonts working! woohoo! cheers for all your help locura, much appreciated

Locura 07-05-2003 03:16 PM

In the Options menu for Mozilla Firebird, I do have the "Underline Links" option checked. Plain links that have not been modified with a stylesheet do have underlines and always have, it's just when there is a stylesheet that I have problems. I deleted my ".phoenix" (configuration/profile directory for Mozilla Firebird) directory, and let Mozilla Firebird re-create it, but it didn't fix the problem. Oh well, I am planning on reinstalling Slack soon, to separate the / partition into /, /usr, and /var. I'll see if the problem still exists then.

Edit: WTF, I used the underline tag from this BB and I'm not seeing the underline on the word "do" in the first sentence of this post. I viewed the source for this page and there is an HTML "u" tag around that word. This seems to be something deeper than a CSS problem.

melquiades 07-05-2003 07:17 PM

yeah I've been thinking 'bout a re-install soon as well, only just installed it but I always like to do a handfull of new installs just to get everything feeling right!

Like you say sounds like there's something extra going on if you aren't even seeing standard underlines, maybe our favourite - font settings, or perhaps something with the internals of the browser. If you're gonna reinstall anyway then that'll cure it but it one of those things, you wanna get to the bottom of the problem don't ya :D

Locura 07-05-2003 07:23 PM

Exactly. I actually narrowed down the problem to a very spcecific set of circumstances. This underline problem seems to occur only in CSS-formatted pages, and only in a TABLE tag (which this board uses to display the threads). I checked the Bugzilla and there is nothing in there about that specific set of circumstances, so I'll just have to see if the re-install takes care of it.

melquiades 07-06-2003 09:02 PM

hope it works ok for you - I reinstalled tonight gave myself a nice big fat32 partition to store all my stuff in, shared between the two OS'es everything seems ok but I didn't bother having a seperate /usr & /var partitions - is it really worth it do you think and how big are you planning on making them?

also - how do find mozilla firebird, I was looking at the website today and can't figure out whether to bother d/loading it or not (i'm on dial-up) - apart from the obvious underline stuff do you find it better than mozilla standard?

All times are GMT -5. The time now is 10:54 PM.