LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
 
Search this Thread
Old 07-13-2014, 10:41 AM   #1
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware -current (multilib) with kernel 3.16.2/Arch/Knoppix
Posts: 1,619
Blog Entries: 13

Rep: Reputation: 192Reputation: 192
New acpiphp_ibm error in kernel > 3.13


Not sure if this belongs in this subforum or not, but I usually run a non-slackware, kernel; download from kernel.org, build it according to alien's page with the current config, usually with a few non-standard patches from https://bbs.archlinux.org/viewtopic.php?id=162768&p=1

None of that is necessarily a problem, but I have noticed that when I went from kernel 3.13.2 to 3.15.1 that I got a delay at the boot screen with the penguins, with a boot message:

Code:
[    1.130721] acpiphp_ibm: ibm_acpiphp_init: acpi_walk_namespace failed
The problem persists in kernel 3.15.5. I never did build the 3.14 series, so I'm not sure about those. The error occurs without the kvm-vfio patches, with the code straight from kernel.org and slackware's generic config, accepting the defaults on the new options.

These are my kernel options

Code:
ro pci-stub.ids=1002:6798,1002:aaa0 intel_iommu=pt vga=normal nomodereset
At this point it is only apparently slightly annoying and transiently cosmetic, but it'd be nice to know what's going on in the new kernels

Last edited by mostlyharmless; 07-13-2014 at 10:42 AM.
 
Old 07-13-2014, 12:03 PM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 5,129

Rep: Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409
Hmm... It never hurts to search the answer in old threads
 
Old 07-13-2014, 03:24 PM   #3
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware -current (multilib) with kernel 3.16.2/Arch/Knoppix
Posts: 1,619
Blog Entries: 13

Original Poster
Rep: Reputation: 192Reputation: 192
Yes, I saw that, but it's years old, and this occurred with a recent change in kernel from 3.13.2 to 3.15.1 with no change in the config; unless one of the new options in kernel 3.15 was a new ACPI Config option that I missed. I'll look at the kernel config again to see if I can spot it.
 
Old 07-13-2014, 03:40 PM   #4
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware -current (multilib) with kernel 3.16.2/Arch/Knoppix
Posts: 1,619
Blog Entries: 13

Original Poster
Rep: Reputation: 192Reputation: 192
OK, following your idea, I ran cat .config | grep ACPI on both the old .config and the new one and then ran diff and got

Code:
CONFIG_ACPI_PROCFS=y
---
> # CONFIG_ACPI_PROCFS_POWER is not set
26a27
> # CONFIG_ACPI_REDUCED_HARDWARE_ONLY is not set
43a45
> # CONFIG_ACPI_INT3403_THERMAL is not set
The first option was deprecated and I can only assume for some reason "make oldconfig" changed it without my noticing. Thanks for pointing me in the right direction.
 
Old 07-13-2014, 03:50 PM   #5
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 5,129

Rep: Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409
To add a useless remark (I like to do that at times :-) you could have typed as well "grep ACPI .config" that is slightly faster. But as long as there's no shortage of pipes...
 
Old 07-19-2014, 02:44 PM   #6
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware -current (multilib) with kernel 3.16.2/Arch/Knoppix
Posts: 1,619
Blog Entries: 13

Original Poster
Rep: Reputation: 192Reputation: 192
Hmm, I checked the ACPI settings, recompiled, and the problem persists. No error with 3.13.2; Error with 3.15. Any other ideas?
 
Old 07-19-2014, 03:11 PM   #7
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 137Reputation: 137
Maybe try compiling the kernel without ACPI PCI Hotplug driver
You don't need to hotplug PCI using ACPI, do you ?

Bus options (PCI etc) > Support for PCI hotplug
 
Old 07-19-2014, 08:58 PM   #8
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware -current (multilib) with kernel 3.16.2/Arch/Knoppix
Posts: 1,619
Blog Entries: 13

Original Poster
Rep: Reputation: 192Reputation: 192
I guess, but all of the options were in the previous kernel build, built the same way. I think I'm on kernel compile #4 or #5 at this point with different variations... and then I've got to recompile the NVIDIA driver too. Yes, I'm whining. Still, I think the ACPI code has changed significantly and is failing (or at least stalling) on my hardware for some reason.

Here's grep ACPI .config for kernel 3.15.5

Code:
# Power management and ACPI options
CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_PROCFS_POWER=y
CONFIG_ACPI_EC_DEBUGFS=m
CONFIG_ACPI_AC=m
CONFIG_ACPI_BATTERY=m
CONFIG_ACPI_BUTTON=m
CONFIG_ACPI_VIDEO=m
CONFIG_ACPI_FAN=m
# CONFIG_ACPI_DOCK is not set
CONFIG_ACPI_PROCESSOR=m
CONFIG_ACPI_IPMI=m
CONFIG_ACPI_HOTPLUG_CPU=y
CONFIG_ACPI_PROCESSOR_AGGREGATOR=m
CONFIG_ACPI_THERMAL=m
# CONFIG_ACPI_CUSTOM_DSDT is not set
CONFIG_ACPI_INITRD_TABLE_OVERRIDE=y
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_PCI_SLOT=y
CONFIG_ACPI_CONTAINER=y
CONFIG_ACPI_HOTPLUG_MEMORY=y
CONFIG_ACPI_SBS=m
CONFIG_ACPI_HED=y
# CONFIG_ACPI_CUSTOM_METHOD is not set
CONFIG_ACPI_BGRT=y
# CONFIG_ACPI_REDUCED_HARDWARE_ONLY is not set
CONFIG_ACPI_APEI=y
CONFIG_ACPI_APEI_GHES=y
CONFIG_ACPI_APEI_PCIEAER=y
CONFIG_ACPI_APEI_EINJ=m
CONFIG_ACPI_APEI_ERST_DEBUG=m
# CONFIG_ACPI_EXTLOG is not set
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_ACPI_CPUFREQ_CPB=y
CONFIG_HOTPLUG_PCI_ACPI=y
CONFIG_HOTPLUG_PCI_ACPI_IBM=y
CONFIG_PNPACPI=y
CONFIG_ATA_ACPI=y
CONFIG_PATA_ACPI=y
# ACPI drivers
CONFIG_GPIO_ACPI=y
# ACPI drivers
CONFIG_SENSORS_ACPI_POWER=m
# CONFIG_ACPI_INT3403_THERMAL is not set
CONFIG_MMC_SDHCI_ACPI=m
CONFIG_DMA_ACPI=y
CONFIG_XEN_ACPI_PROCESSOR=m
CONFIG_ACPI_QUICKSTART=m
CONFIG_THINKPAD_ACPI=m
CONFIG_THINKPAD_ACPI_ALSA_SUPPORT=y
# CONFIG_THINKPAD_ACPI_DEBUGFACILITIES is not set
# CONFIG_THINKPAD_ACPI_DEBUG is not set
# CONFIG_THINKPAD_ACPI_UNSAFE_LEDS is not set
CONFIG_THINKPAD_ACPI_VIDEO=y
CONFIG_THINKPAD_ACPI_HOTKEY_POLL=y
CONFIG_ACPI_WMI=m
CONFIG_ACPI_TOSHIBA=m
CONFIG_ACPI_CMPC=m
and here's for 3.13.2

Code:
# Power management and ACPI options
CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_PROCFS=y
CONFIG_ACPI_EC_DEBUGFS=m
CONFIG_ACPI_AC=m
CONFIG_ACPI_BATTERY=m
CONFIG_ACPI_BUTTON=m
CONFIG_ACPI_VIDEO=m
CONFIG_ACPI_FAN=m 
CONFIG_ACPI_DOCK=y
CONFIG_ACPI_PROCESSOR=m
CONFIG_ACPI_IPMI=m
CONFIG_ACPI_HOTPLUG_CPU=y  
CONFIG_ACPI_PROCESSOR_AGGREGATOR=m
CONFIG_ACPI_THERMAL=m
# CONFIG_ACPI_CUSTOM_DSDT is not set
CONFIG_ACPI_INITRD_TABLE_OVERRIDE=y
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_PCI_SLOT=y
CONFIG_ACPI_CONTAINER=y
CONFIG_ACPI_HOTPLUG_MEMORY=y
CONFIG_ACPI_SBS=m
CONFIG_ACPI_HED=y
# CONFIG_ACPI_CUSTOM_METHOD is not set
CONFIG_ACPI_BGRT=y
CONFIG_ACPI_APEI=y   
CONFIG_ACPI_APEI_GHES=y
CONFIG_ACPI_APEI_PCIEAER=y
CONFIG_ACPI_APEI_EINJ=m
CONFIG_ACPI_APEI_ERST_DEBUG=m
# CONFIG_ACPI_EXTLOG is not set
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_ACPI_CPUFREQ_CPB=y
CONFIG_HOTPLUG_PCI_ACPI=y
CONFIG_HOTPLUG_PCI_ACPI_IBM=y
CONFIG_PNPACPI=y
CONFIG_ATA_ACPI=y
CONFIG_PATA_ACPI=y
# ACPI drivers
CONFIG_GPIO_ACPI=y
# ACPI drivers
CONFIG_SENSORS_ACPI_POWER=m
CONFIG_MMC_SDHCI_ACPI=m
CONFIG_DMA_ACPI=y
CONFIG_XEN_ACPI_PROCESSOR=m
CONFIG_ACPI_QUICKSTART=m
CONFIG_THINKPAD_ACPI=m
CONFIG_THINKPAD_ACPI_ALSA_SUPPORT=y
# CONFIG_THINKPAD_ACPI_DEBUGFACILITIES is not set
# CONFIG_THINKPAD_ACPI_DEBUG is not set
# CONFIG_THINKPAD_ACPI_UNSAFE_LEDS is not set
CONFIG_THINKPAD_ACPI_VIDEO=y
CONFIG_THINKPAD_ACPI_HOTKEY_POLL=y
CONFIG_ACPI_WMI=m
CONFIG_ACPI_TOSHIBA=m
CONFIG_ACPI_CMPC=m
and here's diff
Code:
4c4
< CONFIG_ACPI_PROCFS_POWER=y
---
> CONFIG_ACPI_PROCFS=y
11c11
< # CONFIG_ACPI_DOCK is not set
---
> CONFIG_ACPI_DOCK=y
27d26
< # CONFIG_ACPI_REDUCED_HARDWARE_ONLY is not set
45d43
< # CONFIG_ACPI_INT3403_THERMAL is not set
You can see they renamed the deprecated ACPI_PROCFS option. I tried removing the DOCK option on a previous compile; it made no difference.
 
Old 07-19-2014, 10:00 PM   #9
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,789

Rep: Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006
Quote:
ro pci-stub.ids=1002:6798,1002:aaa0 intel_iommu=pt vga=normal nomodereset
I have no experience with this, but my reading suggests that perhaps your kernel parameters should read
Code:
ro pci-stub.ids=1002:6798,1002:aaa0 intel_iommu=on iommu=pt vga=normal nomodereset
 
Old 07-20-2014, 05:39 AM   #10
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 137Reputation: 137
Quote:
Originally Posted by mostlyharmless View Post
I guess, but all of the options were in the previous kernel build, built the same way. I think I'm on kernel compile #4 or #5 at this point with different variations... and then I've got to recompile the NVIDIA driver too. Yes, I'm whining. Still, I think the ACPI code has changed significantly and is failing (or at least stalling) on my hardware for some reason.
What is wrong with my suggestion, do you really need to plug and unplug PCI cards while the system is up and running?
 
1 members found this post helpful.
Old 07-20-2014, 03:25 PM   #11
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware -current (multilib) with kernel 3.16.2/Arch/Knoppix
Posts: 1,619
Blog Entries: 13

Original Poster
Rep: Reputation: 192Reputation: 192
Nothing is wrong with it; it just hasn't changed since kernel 3.13.2's config, so I'm not sure how that can be the issue. As to whether I need to hotplug PCI, well, I do passthrough one of my video cards to a VM, so I'm not sure whether that counts. I can try a recompile.

See http://www.linux-kvm.org/page/How_to...th_VT-d_in_KVM

@allend: IOMMU=pt vs on has to do with passthrough issues; usually either works
 
Old 07-20-2014, 06:53 PM   #12
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware -current (multilib) with kernel 3.16.2/Arch/Knoppix
Posts: 1,619
Blog Entries: 13

Original Poster
Rep: Reputation: 192Reputation: 192
@keefaz OK, removed all PCI hotplug references, recompiled. There's still a delay compared to kernel 3.13.2, but the ugly acpi message is gone, and my passthrough still works, so I guess this is SOLVED, thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Error echo 0 > /proc/sys/kernel/hung _task_timeout_secsin Redhat 5.8 LittleMaster Linux - Server 1 10-18-2012 09:32 AM
upgrading Fedora Core 3 kernel 2.6.9-1.667 to 2.6.26.3 manually+kernel panic error LinuxLovinNoob Linux - Newbie 7 12-17-2008 08:45 PM


All times are GMT -5. The time now is 01:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration