-   Slackware (
-   -   NetworkManager Icon missing after today's update (

lkraemer 03-26-2013 09:58 AM

NetworkManager Icon missing after today's update
After I did an update of Slackware 14 this morning, my Wifi Icon (NetworkManager) went
missing from my top right Menu.

My Wifi is shown by iwconfig as "not associated", and my ESSID has been removed.

And, I can't remember what I need to run/do to get my Wifi working, as I didn't
keep any notes in my install file.

Can someone please refresh my memory, because I'm having a Senior Moment,
and I haven't located the right information yet, or the setup information.

I've tried running "netconfig" and selecting "Networkmanager" as my choice, but my Wifi Icon
is still missing.....



willysr 03-26-2013 10:57 AM

please confirm this first: are you running slackware 14.0 or Current?
there are no NM update to Slackware 14.0

cynwulf 03-26-2013 12:02 PM

Using KDE or something else?

What happens if you open a terminal emulator and do:


$ nm-applet

lkraemer 03-26-2013 04:11 PM

2 Attachment(s)
I'm running Slackware 14, but every week or two I update with the following commands:

slackpkg update
slackpkg install-new
slackpkg upgrade-all

so, I guess I'm really running the current updated version of Slackware 14.

According to the posting by Alien Bob at:

There is a problem with a missing dependency.... l/gdk-pixbuf2 ie.........

I downloaded and extracted the file, and changed the permissions of gdk-pixbuf2.SlackBuild to 755,
and then compiled with ./gdk-pixbuf2.SlackBuild, and after it was finished I did an install as root with
the command installpkg gdk-pixbuf2-2.26.1-i486-2.txz............

But, I still couldn't get my Ethernet connection working. I did the following - netconfig & selected

/etc/rc.d/rc.inet1 restart
/etc/rc.d/rc.inet1 eth0_start
dhclient eth0

and finally I could get ping to work. Then I repeated the update with:

slackpkg upgrade-all
After a reboot everything started working again.........

I'm using XFCE Ver 4.10 Desktop.

I still have a problem with my Desktop Menu's where some of the Icons are displayed too LARGE.
A couple of the images are attached. Before the upgrade, everything was normal for all menu's,
so something in the upgrade has changed the look of my Menu's for Crossover by Codeweavers.



volkerdi 03-26-2013 04:19 PM

The dependency was actually on the new gtk+2, not gdk-pixbuf (though the latter is also tied to the former).

At this point there's been enough divergence from 14.0 that I wouldn't suggest trying to run anything from -current on 14.0. The libraries mentioned above are also compiled against the newer glibc (as is everything else since that was updated). And compiling the new NetworkManager/nm-applet on 14.0 isn't going to work, either, since nm-applet requires dconf, which in turn requires the new version of glib.

If you want this stuff, you'll need to bite the bullet and upgrade to -current, otherwise you'll just continue to run into problems.

willysr 03-26-2013 09:19 PM

that's why i asked you in my first reply: do you run 14.0 or -Current, because it seems that mixed both :)

spiritual_fraud 03-26-2013 10:10 PM


Originally Posted by willysr (Post 4919610)
that's why i asked you in my first reply: do you run 14.0 or -Current, because it seems that mixed both :)

I ran into a similar problem a while back when I was "mixing" both 13.37 and -current, I started noticing issues and I had to rsync a whole "-current" tree and upgrade the packages to solve the problem.

All times are GMT -5. The time now is 05:31 AM.