LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-21-2011, 05:08 PM   #1
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,567
Blog Entries: 1

Rep: Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887
NetworkManager Daemon Hangs Computer.


Following from a previous thread where I asked,

Quote:
Quote:
Originally Posted by rg3 View Post
If rc.networkmanager resides in /etc/rc.d, make sure it's executable and launch it from /etc/rc.d/rc.local like:

Code:

/etc/rc.d/rc.networkmanager start

And, I replied:

I've tried that, twice, and both times it hung up the computer; couldn't even log on.
If started in a terminal, as root, and use the applet as user, it works, but not if the daemon is started on boot up.
and received the following two replies:

Quote:
Old Today, 12:01 PM #9
andrewthomas
Senior Member

Registered: May 2010
Distribution: Arch, Gentoo, Slackware
Posts: 1,023

Rep: Reputation: 151Reputation: 151

Quote:
Originally Posted by cwizardone View Post
I've tried that, twice, and both times it hung up the computer; couldn't even log on.
If started in a terminal, as root, and use the applet as user, it works, but not if the daemon is started on boot up.
This works:

/etc/rc.d/rc.local:
Code:

#!/bin/sh
#
# /etc/rc.d/rc.local: Local system initialization script.
#
# Put any local startup commands in here. Also, if you have
# anything that needs to be run at shutdown time you can
# make an /etc/rc.d/rc.local_shutdown script and put those
# commands in there.

# To disable networkmanager, chmod rc.networkmanager to 644
if [ -x /etc/rc.d/rc.networkmanager ]; then
. /etc/rc.d/rc.networkmanager start
fi

/etc/rc.d/rc.local_shutdown:
Code:

#!/bin/sh

# To disable networkmanager shutdown, chmod rc.networkmanager to 644
if [ -x /etc/rc.d/rc.networkmanager ]; then
. /etc/rc.d/rc.networkmanager stop
fi
and,

Quote:
Old Today, 01:05 PM #10
BCarey
Senior Member

Registered: Oct 2005
Distribution: Slackware
Posts: 1,218

Rep: Reputation: 61

Quote:
Originally Posted by cwizardone View Post
I've tried that, twice, and both times it hung up the computer; couldn't even log on.
If started in a terminal, as root, and use the applet as user, it works, but not if the daemon is started on boot up.
This is odd. At what point does it hang? Did you disable wicd?

BTW, if you want help on this you may want to start a new thread as this thread is marked solved.

Brian
Thank you both for your replies.

Andrewthomas,
Yes, I've tried that, but tried again, even once with the extra period you added on the second line, but the
result was the same, the computer hangs.

Brian,
Yes, I disable wcid. The computer boots up and the very last thing it does before presenting the log in prompt is,
"Starting NetworkManager daemon: /usr/sbin/networkmanager"

Sometimes I can't log in at all. Sometimes I can enter the user name, but not the password. Sometimes it will let me enter both the user name and password before it hangs. Once I got all the way to, startx, before it hung.

I have now re-installed wicd.

Last edited by cwizardone; 07-21-2011 at 05:19 PM.
 
Old 07-21-2011, 09:45 PM   #2
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,567

Original Poster
Blog Entries: 1

Rep: Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887
Thanks to the moderator for reinstating this thread.
I've been looking through the posts for the last few weeks and there appears to have been a rash of wicd/networkmanager problems. Must be sunspots.

Last edited by cwizardone; 07-21-2011 at 10:04 PM.
 
Old 07-22-2011, 07:01 AM   #3
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,567

Original Poster
Blog Entries: 1

Rep: Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887
Well, I've tried loading NetworkManager in rc.local before and after VirtualBox, but the result is the same, i.e., the computer hangs.
Then I tried loading it in rc.M, but, again, the result is the same (and, yes, I disabled wicd).
Any ideas?
Thanks.
 
Old 07-22-2011, 09:31 AM   #4
yuuko
Member
 
Registered: May 2011
Distribution: Slackware-current
Posts: 42

Rep: Reputation: 20
Take a look at your /var/log/messages file, and see if there's any error present.
 
Old 07-22-2011, 09:51 AM   #5
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,635

Rep: Reputation: Disabled
Have you checked /var/log/messages?

Brian
 
Old 07-22-2011, 10:24 AM   #6
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,567

Original Poster
Blog Entries: 1

Rep: Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887
Here we go:

Quote:
Jul 22 02:47:09 darkstar NetworkManager[2459]: <info> NetworkManager (version 0.8.4.0) is starting...
Jul 22 02:47:09 darkstar NetworkManager[2459]: <info> Read config file /etc/NetworkManager/NetworkManager.conf
Jul 22 02:47:09 darkstar NetworkManager[2459]: <info> VPN: loaded org.freedesktop.NetworkManager.vpnc
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> VPN: loaded org.freedesktop.NetworkManager.pptp
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> VPN: loaded org.freedesktop.NetworkManager.openvpn
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> VPN: loaded org.freedesktop.NetworkManager.openconnect
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> trying to start the modem manager...
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> monitoring kernel firmware directory '/lib/firmware'.
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> Loaded plugin keyfile: (c) 2007 - 2010 Red Hat, Inc. To report bugs please use the NetworkManager mailing list.
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> found WiFi radio killswitch rfkill0 (at /sys/devices/pci0000:00/0000:00:1e.0/0000:05:02.0/ieee80211/phy0/rfkill0) (driver <unknown>)
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> WiFi enabled by radio killswitch; enabled by state file
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> WWAN enabled by radio killswitch; enabled by state file
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> WiMAX enabled by radio killswitch; enabled by state file
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> Networking is enabled by state file
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (wlan0): driver supports SSID scans (scan_capa 0x01).
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (wlan0): new 802.11 WiFi device (driver: 'rt2800pci' ifindex: 3)
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (wlan0): exported as /org/freedesktop/NetworkManager/Devices/0
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (wlan0): now managed
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (wlan0): device state change: 1 -> 2 (reason 2)
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (wlan0): bringing up device.
Jul 22 02:47:10 darkstar modem-manager: ModemManager (version 0.4) starting...
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin Novatel
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin Gobi
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin SimTech
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin Huawei
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin Ericsson MBM
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin AnyData
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin Generic
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin Option
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin Sierra
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin ZTE
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin Longcheer
Jul 22 02:47:10 darkstar kernel: [ 37.836740] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin Option High-Speed
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin MotoC
Jul 22 02:47:10 darkstar modem-manager: Loaded plugin Nokia
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (wlan0): preparing device.
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (wlan0): deactivating device (reason: 2).
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (eth0): carrier is OFF
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (eth0): new Ethernet device (driver: 'e100' ifindex: 2)
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (eth0): exported as /org/freedesktop/NetworkManager/Devices/1
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (eth0): now managed
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (eth0): device state change: 1 -> 2 (reason 2)
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (eth0): bringing up device.
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (eth0): preparing device.
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (eth0): deactivating device (reason: 2).
Jul 22 02:47:10 darkstar kernel: [ 37.863073] ADDRCONF(NETDEV_UP): eth0: link is not ready
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> Added default wired connection 'Auto eth0' for /sys/devices/pci0000:00/0000:00:1e.0/0000:05:08.0/net/eth0
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> modem-manager is now available
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> Trying to start the supplicant...
Jul 22 02:47:10 darkstar modem-manager: (ttyS0) opening serial device...
Jul 22 02:47:10 darkstar modem-manager: (ttyS1) opening serial device...
Jul 22 02:47:10 darkstar modem-manager: (ttyS2) opening serial device...
Jul 22 02:47:10 darkstar modem-manager: (ttyS3) opening serial device...
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (wlan0): supplicant manager state: down -> idle
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (wlan0): device state change: 2 -> 3 (reason 0)
Jul 22 02:47:10 darkstar NetworkManager[2459]: <info> (wlan0): supplicant interface state: starting -> ready
Jul 22 02:47:22 darkstar modem-manager: (ttyS0) closing serial device...
Jul 22 02:47:52 darkstar modem-manager: (ttyS0) opening serial device...
Jul 22 02:47:52 darkstar modem-manager: (ttyS1) closing serial device...
Jul 22 02:48:22 darkstar modem-manager: (ttyS1) opening serial device...
Jul 22 02:48:22 darkstar modem-manager: (ttyS2) closing serial device...
 
Old 07-22-2011, 03:47 PM   #7
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,635

Rep: Reputation: Disabled
As far as the wlan0 interface goes your messages are basically the same as mine. I don't use modem-manager, though, and the last entries in the log relate to that, not to networkmanager per se. Could you try disabling/removing that? Also, you might compare the log when you run networkmanager manually against the log when you try to start at boot time.

Brian
 
1 members found this post helpful.
Old 07-22-2011, 06:28 PM   #8
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,567

Original Poster
Blog Entries: 1

Rep: Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887
Quote:
Originally Posted by BCarey View Post
As far as the wlan0 interface goes your messages are basically the same as mine. I don't use modem-manager, though, and the last entries in the log relate to that, not to networkmanager per se. Could you try disabling/removing that? Also, you might compare the log when you run networkmanager manually against the log when you try to start at boot time.
Brian
Many Thanks, Brian! Removing (removepkg) modem-manager did the trick. Now let's see how stable NetworkManager is as compared to Wicd.
Thanks, again.

Last edited by cwizardone; 07-22-2011 at 06:34 PM.
 
Old 07-22-2011, 09:42 PM   #9
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,635

Rep: Reputation: Disabled
I'm glad I could help. I just installed networkmanager myself, and so far it is working as well if not better than wicd.

Brian
 
Old 07-22-2011, 09:48 PM   #10
SqdnGuns
Senior Member
 
Registered: Aug 2005
Distribution: Slackware64 Current
Posts: 1,023

Rep: Reputation: 118Reputation: 118
Quote:
Originally Posted by BCarey View Post
I'm glad I could help. I just installed networkmanager myself, and so far it is working as well if not better than wicd.

Brian
Same here, took me a while to figure out why I would lose my internet connection when I logged out of x. Rather than run the daemon from rc.local, I edited rc.M and all is well.
 
Old 07-25-2011, 12:18 AM   #11
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,567

Original Poster
Blog Entries: 1

Rep: Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887Reputation: 1887
Quote:
Originally Posted by cwizardone View Post
Many Thanks, Brian! Removing (removepkg) modem-manager did the trick. Now let's see how stable NetworkManager is as compared to Wicd.
Thanks, again.
Much more stable than wcid!
It hasn't blinked yet as compared to wcid which had become flaky, to say the least, over the last few weeks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
hal daemon stalls and logout shuts down computer hedron Slackware 8 05-27-2010 01:56 AM
System Hangs during boot (starting HAL daemon ) on FC 6 32 bit with pentium D karthik_arnold1 Linux - Hardware 1 04-21-2008 12:05 PM
HAL Daemon Hangs After Disabling Some Services DBQ Fedora 1 10-03-2007 01:35 PM
system hangs after the HAL daemon linux.siva Red Hat 1 06-30-2006 04:02 AM
boot hangs on apm daemon ron40203 Linux - Software 1 01-10-2004 09:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration