LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-03-2016, 10:48 AM   #1
drgibbon
Member
 
Registered: Nov 2014
Distribution: Slackware64 14.2
Posts: 412

Rep: Reputation: 235Reputation: 235Reputation: 235
Networking connects then disconnects with 14.2 (AR9285)


I'm having network problems on my ThinkPad X200. No networking problems on 14.1, but a fresh install of 14.2 sees both ethernet and wireless repeatedly connecting and then dropping out.

The WiFi card is Qualcomm Atheros AR9285, and I'm using NetworkManager with the WiFi settings entered in the XFCE NetworkManager Applet. After connecting over WiFi my dmesg output is;
Quote:
wlan0: authenticated
wlan0: associated
wlan0: deauthenticating from MACADDR by local choice (Reason: 3=DEAUTH_LEAVING)
There's also some stuff from cfg80211 about "world regulatory domain updated / DFS Master region: unset and a bunch of frequencies, and some country mapping stuff from ath.
 
Old 07-03-2016, 12:24 PM   #2
drgibbon
Member
 
Registered: Nov 2014
Distribution: Slackware64 14.2
Posts: 412

Original Poster
Rep: Reputation: 235Reputation: 235Reputation: 235
I can say that this is definitely not a hardware or router issue, since I just booted to an Ubuntu LiveUSB (16.04 LTS, kernel 4.4.0-21-generic) and the WiFi works without problem.
 
Old 07-03-2016, 12:41 PM   #3
mralk3
Senior Member
 
Registered: May 2015
Location: Utah, USA
Distribution: Slackware 14.2 || Slackware-current && CentOS
Posts: 1,236

Rep: Reputation: 600Reputation: 600Reputation: 600Reputation: 600Reputation: 600Reputation: 600
For the regulatory domain stuff, here it talks about how to fix that.

https://wireless.wiki.kernel.org/en/...egulatory/crda
https://www.linuxquestions.org/quest...ng-4175549946/
https://www.linuxquestions.org/quest...gs-4175559295/
 
Old 07-03-2016, 12:54 PM   #4
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.2 Slackware 14.2, Slackware{32,64}-current
Posts: 854
Blog Entries: 9

Rep: Reputation: 320Reputation: 320Reputation: 320Reputation: 320
You may first want to check in /etc/NetworkManager/conf.d/00-dhcp-client.conf
Code:
[main]
# Choose a DHCP client below.  Upstream recommends dhclient, but results may vary.
# dhcpcd is the DHCP client usually used by Slackware:
#dhcp=dhcpcd
# dhclient is the ISC reference DHCP client, part of the dhcp package:
dhcp=dhclient
# This is a simple DHCP client that is built into NetworkManager:
#dhcp=internal
On 3 laptops here with Atheros chipsets, dhcp=dhcpcd does not work (disconnedcts, reconnects), dhcp=dhclient works, dhcp=internal works sometimes. Also, make sure you do not have any left over configuration settings in /etc/rc.d/rc.inet1.conf as these can interfere. Sometimes the error messages from the network utilities can send you down the wrong path.

Last edited by kingbeowulf; 07-03-2016 at 12:55 PM. Reason: spelling
 
2 members found this post helpful.
Old 07-03-2016, 01:15 PM   #5
drgibbon
Member
 
Registered: Nov 2014
Distribution: Slackware64 14.2
Posts: 412

Original Poster
Rep: Reputation: 235Reputation: 235Reputation: 235
Quote:
Originally Posted by mralk3 View Post
For the regulatory domain stuff, here it talks about how to fix that.
Thanks, looks like a lot of info, I'll check it out.

Quote:
Originally Posted by kingbeowulf View Post
You may first want to check in /etc/NetworkManager/conf.d/00-dhcp-client.conf
That did the trick, thanks! I switched to dhcp=dhclient and got a stable connection straight away.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB mouse works on and off (disconnects and re-connects) mike11 Linux - Newbie 6 06-13-2017 12:35 PM
ftdi_sio connects and disconnects forever Lil_fish Linux - Software 0 05-12-2014 11:45 AM
Persistent connects and disconnects baldur2630 Linux - Security 4 12-04-2013 02:34 PM
wlan0 disconnecting when eth0 connects/disconnects Sammael Linux - Wireless Networking 0 08-15-2006 05:39 AM
ppp connects does nothing and disconnects jimdaworm Slackware 11 03-19-2004 01:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration