-   Slackware (
-   -   Network Unreachable? (

biledaemon 10-23-2005 05:44 PM

Network Unreachable?
B4 compiling my kernel, I had my network up and running but ..

I compiled, for the first time (yes it's my first so I am a noob), Slack 10.2 default kernel: 2.4.31. I followed all the instructions by the book and the kernel compile went fine but I can no longer browse (or ping my router for that matter), LAN or the Internet. I recompiled the kernel again making sure that the network part of it had what "I think" it needed, but to no avail.

What did I do wrong in my kernel compile that I somehow disabled my network connection?? I have a router and I can't even ping it. I always get the "Network unreachable".

What should I check for when i do the : make menuconfig in my selections for the network section? ..if that's where I made the booboo.

Any input is ALWAYS greatly appreciated.

gbonvehi 10-23-2005 05:50 PM

Check with ifconfig if your network interface is detected (see if you see eth0).
Use lspci to check which card you've and make sure you compile in your kernel the module to support it.

biledaemon 10-23-2005 05:59 PM

I will do that... as soon as I get out of work. Thanks for the input. :-) I will post again to let you know my results.

Thanks :-)

biledaemon 10-24-2005 02:00 PM

lspci showed this:

01:01.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 08)
01:07.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 06)
01:0a.0 Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller
01:0b.0 VGA compatible controller: Trident Microsystems TGUI 9660/938x/968x (rev d3)

and ifconfig showed no eth0.

After compiling the kernel i selected the first Ethernet controller (Ethernet Pro 100) but that didn't work. So i deselected that one and choose DP8*** series... and that worked!

However, sound would not work with ALSA. Since ALSA is build specific I had to download the source, compile it again and install it. Now I have sound & network.

THanks for your help. Now I need to find out why I can't hear anything on my USB sound Logitech. I have USB sound selected in the kernel and my USB stick works.... Any ideas?

planoru 10-24-2005 03:05 PM

U have to type it like this "ifconfig eth0" or "ifconfig -a"(last one should show U an loopback device too). Also type "netconfig" and set your LAN properly(be sure that is setup properly).
After this use "/etc/rc.d/rc.inet1 restart"
If it's still not working type "route -n". It should show U 3 lines and the last one should have something like gateway(GW) in it.
Hope this helps.

All times are GMT -5. The time now is 09:16 PM.