LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-23-2017, 03:34 PM   #1
bogota
LQ Newbie
 
Registered: May 2017
Posts: 2

Rep: Reputation: Disabled
network manager: wireless autoconnection not working


Hello!
Does anybody knows why in my Slackware64 14.2 network manager does not perform the autoconnection to my preferred wifi network at boot time or on resuming from suspension?
I also have set it manually:
Code:
$ nmcli -f NAME,AUTOCONNECT,AUTOCONNECT-PRIORITY c
NAME                AUTOCONNECT  AUTOCONNECT-PRIORITY
my_ssid             yes          1                   
Wired connection 1  yes          4294966297
Thanks in advance!
 
Old 05-23-2017, 07:32 PM   #2
Gordie
Member
 
Registered: Aug 2007
Location: Nolalu, Ontario, Canada
Posts: 522

Rep: Reputation: 185Reputation: 185
Is this newly set up? Did you enable all users?
 
Old 05-23-2017, 08:08 PM   #3
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 6,075

Rep: Reputation: 3741Reputation: 3741Reputation: 3741Reputation: 3741Reputation: 3741Reputation: 3741Reputation: 3741Reputation: 3741Reputation: 3741Reputation: 3741Reputation: 3741
As Gordie mentioned, you need to enable all users for this to work properly. It could've probably been labelled better, but it is what it is.
 
Old 05-24-2017, 05:22 AM   #4
bogota
LQ Newbie
 
Registered: May 2017
Posts: 2

Original Poster
Rep: Reputation: Disabled
That was the point, thank you!
Well actually I tried to set permissions for all users from the beginning (yes, is newly setup), but this is what the KDE gui makes by cheking the box "All users may connect to this network":
Code:
# cd /etc/NetworkManager/system-connections
# diff my_ssid~ myssid
5c5
< permissions=user:my_user:;
---
> permissions=
7d6
< autoconnect-priority=1
17a17
> auth-alg=shared
21a22
> wep-key-type=1
And after that the connection stop working at all! It get stuck in "Configuring interface" (why that??)
So the solution was to manually modify only the line 5 (see the diff).

Last edited by bogota; 05-24-2017 at 05:32 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Autoconnection, network side ghostinthecode Linux - Networking 1 08-19-2014 10:47 AM
Ubuntu 11.10 Network Manager issues connecting to wireless network after restart depam Linux - Software 2 01-22-2012 08:39 PM
Network manager stop working completly (( not working after reinstalling)) alieblice Linux - Networking 0 10-20-2011 06:52 AM
Wireless network connects and works fine, but doesnt show up on the network manager newbie236 Linux - Newbie 1 07-07-2010 12:47 AM
Debian-Gnome: Network Manager Working Strange with Intel wireless 4965AGN sd|| Linux - Wireless Networking 1 11-05-2009 03:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration