LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-05-2018, 05:11 PM   #16
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 520

Rep: Reputation: 276Reputation: 276Reputation: 276

Quote:
Originally Posted by montagdude View Post
Thanks. I will try this next. I think from reading the docs that I now know how to set up a static IP on wireless using rc.inet1.conf and wpa_supplicant. I will also try a static ARP.
I wanted to help you with the static IP configuration on your Slackware server, but I've noticed that you are using NetworkManager (I never used it) and then I also don't use the Slackware way - actually I'm always substituting /etc/rc.d/rc.inet1 with my own "manual" network initialization script. At least, just for inspiration, I can help you with the Linux way (that will work under Slackware) to get your WiFi device manually connected and configured with either DHCP / Static IP. I switched to iproute2 some time ago and tried to double the commands (commented) with the old (standard) ifconfig / route ones - just for reference.
Here you go:
Code:
/usr/sbin/ip link set wlan0 down
/usr/sbin/ip link set wlan0 up
#/sbin/ifconfig wlan0 down
#/sbin/ifconfig wlan0 up
# optional: /sbin/iwconfig wlan0 essid "ESSID"
#-check if tuned: /sbin/iwconfig wlan0
/usr/sbin/wpa_passphrase ESSID PASSWORD | tee -a /etc/wpa_supplicant.conf
#-check result: cat /etc/wpa_supplicant.conf
/usr/sbin/wpa_supplicant -B -D nl80211 -i wlan0 -c /etc/wpa_supplicant.conf
#-check if connected: /usr/sbin/iw wlan0 link
# --- IP configuration Section ---
# DHCP IP configuration
/sbin/dhclient wlan0
# manual IP configuration
/usr/sbin/ip address add 192.168.88.253/24 dev wlan0
#/sbin/ifconfig wlan0 192.168.88.253 netmask 255.255.255.0
/usr/sbin/ip route add default via 192.168.88.1
# check configuration: 
/usr/sbin/ip address show wlan0
#/sbin/ifconfig wlan0
# -- Disconnect ---
/bin/killall wpa_supplicant
/usr/sbin/ip link set wlan0 down
#/sbin/ifconfig wlan0 down
/usr/sbin/ip route del default via 192.168.88.1

Last edited by abga; 01-05-2018 at 05:20 PM. Reason: typo in the header
 
1 members found this post helpful.
Old 01-05-2018, 05:25 PM   #17
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,212

Rep: Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986Reputation: 2986
If you want to stick with rc.inet1.conf for your wireless, it's pretty straightforward. Just edit your GATEWAY and the wlan0 section (which should be the 4th network section). Obviously replace the GATEWAY, IPADDR, and NETMASK to those of your network.

Code:
GATEWAY="192.168.1.1"

IFNAME[4]="wlan0"
IPADDR[4]="192.168.1.100"
NETMASK[4]="255.255.255.0"
USE_DHCP[4]=""
WLAN_WPA[4]="wpa_supplicant"
If your wpa_supplicant requires a specific driver, you can specify that using WLAN_WPADRIVER[4]="wext" further down in that section.
 
2 members found this post helpful.
Old 01-05-2018, 06:49 PM   #18
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 520

Rep: Reputation: 276Reputation: 276Reputation: 276
Quote:
Originally Posted by montagdude View Post


Here is some output of tcpdump on the server during the time when I was trying to ping it from my laptop.

Code:
root@zmserver:~# tcpdump -lnvi wlan0 arp
tcpdump: listening on wlan0, link-type EN10MB (Ethernet), capture size 262144 bytes
22:36:22.829953 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 192.168.88.253 tell 192.168.88.1, length 28
22:36:22.829983 ARP, Ethernet (len 6), IPv4 (len 4), Reply 192.168.88.253 is-at [removed], length 28
I forgot to mention that maybe you'll find it more useful to dump both ARP and ICMP packets at the same time while investigating your issue. To do that, just run:
Code:
/usr/sbin/tcpdump -lnvi INTERFACE arp or icmp

Last edited by abga; 01-05-2018 at 07:00 PM. Reason: shorter format
 
Old 01-05-2018, 11:58 PM   #19
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,048

Original Poster
Rep: Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777
Quote:
Originally Posted by abga View Post
I wanted to help you with the static IP configuration on your Slackware server, but I've noticed that you are using NetworkManager (I never used it) and then I also don't use the Slackware way - actually I'm always substituting /etc/rc.d/rc.inet1 with my own "manual" network initialization script. At least, just for inspiration, I can help you with the Linux way (that will work under Slackware) to get your WiFi device manually connected and configured with either DHCP / Static IP. I switched to iproute2 some time ago and tried to double the commands (commented) with the old (standard) ifconfig / route ones - just for reference.
Here you go:
Code:
/usr/sbin/ip link set wlan0 down
/usr/sbin/ip link set wlan0 up
#/sbin/ifconfig wlan0 down
#/sbin/ifconfig wlan0 up
# optional: /sbin/iwconfig wlan0 essid "ESSID"
#-check if tuned: /sbin/iwconfig wlan0
/usr/sbin/wpa_passphrase ESSID PASSWORD | tee -a /etc/wpa_supplicant.conf
#-check result: cat /etc/wpa_supplicant.conf
/usr/sbin/wpa_supplicant -B -D nl80211 -i wlan0 -c /etc/wpa_supplicant.conf
#-check if connected: /usr/sbin/iw wlan0 link
# --- IP configuration Section ---
# DHCP IP configuration
/sbin/dhclient wlan0
# manual IP configuration
/usr/sbin/ip address add 192.168.88.253/24 dev wlan0
#/sbin/ifconfig wlan0 192.168.88.253 netmask 255.255.255.0
/usr/sbin/ip route add default via 192.168.88.1
# check configuration: 
/usr/sbin/ip address show wlan0
#/sbin/ifconfig wlan0
# -- Disconnect ---
/bin/killall wpa_supplicant
/usr/sbin/ip link set wlan0 down
#/sbin/ifconfig wlan0 down
/usr/sbin/ip route del default via 192.168.88.1
Thank you so much. This works flawlessly to connect my router with a static IP. It has also solved my ping problems with this machine, though I still don't really understand why it wasn't working before. I have distilled these commands into the following rc script that runs from /etc/rc.d/rc.M in place of /etc/rc.d/rc.inet1:

Code:
#!/bin/sh

function print_usage ()
{
  echo "Usage: rc.inet_mine start|stop|restart"
}

function inet_start ()
{
  /sbin/ip link set wlan0 up
  /usr/sbin/wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf
  #/sbin/dhclient wlan0
  /sbin/ip address add 192.168.88.9/24 dev wlan0
  /sbin/ifconfig wlan0 192.168.88.9 netmask 255.255.255.0
  /sbin/ip route add default via 192.168.88.1
  arp -s 192.168.88.1 xx:xx:xx:xx:xx:xx(bridge MAC address)
}

function inet_stop ()
{
  /bin/killall wpa_supplicant
  /sbin/ip link set wlan0 down
  /sbin/ifconfig wlan0 down
  ip route del default via 192.168.88.1
}

if [ $# -lt 1 ]; then
  print_usage
  exit 1
fi

case $1 in
    start)
        inet_start
        ;;
    stop)
        inet_stop
        ;;
    restart)
        inet_stop
        inet_start
        ;;
    *)
        print_usage
        exit 1
        ;;
esac
The script also sets a static ARP. I will mark this as solved now.

EDIT: Nevermind, I spoke too soon. The ping problems still persist, though this does work to set a static IP.

Last edited by montagdude; 01-06-2018 at 12:14 AM.
 
Old 01-06-2018, 12:00 AM   #20
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,048

Original Poster
Rep: Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777
Quote:
Originally Posted by bassmadrigal View Post
If you want to stick with rc.inet1.conf for your wireless, it's pretty straightforward. Just edit your GATEWAY and the wlan0 section (which should be the 4th network section). Obviously replace the GATEWAY, IPADDR, and NETMASK to those of your network.

Code:
GATEWAY="192.168.1.1"

IFNAME[4]="wlan0"
IPADDR[4]="192.168.1.100"
NETMASK[4]="255.255.255.0"
USE_DHCP[4]=""
WLAN_WPA[4]="wpa_supplicant"
If your wpa_supplicant requires a specific driver, you can specify that using WLAN_WPADRIVER[4]="wext" further down in that section.
I tried this, but for some reason it didn't work. It seemed to be connected from what I could tell by looking at the output of iwconfig and ifconfig, but I couldn't connect to the internet or ping the router. I could probably dig deeper and find out why, but abga's solution is working, and I've already spent too much time on this. Thanks for the advice, though!

Last edited by montagdude; 01-06-2018 at 12:13 AM.
 
Old 01-06-2018, 12:30 AM   #21
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,048

Original Poster
Rep: Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777
Okay, here's something new. I found that when pinging from my laptop or phone with a fresh ARP cache, it does eventually find the server. It sometimes needs 16 or more attempts before finding the destination host. So, for those of you who know more about this than me, what does that indicate?

EDIT: I added a static ARP entry for the server in the router, but that didn't help.

EDIT2: Going back to the MacBook, I think now that it actually does have the same issue, but it doesn't require as many tries to successfully ping it. It takes maybe 4 tries instead of 10-20+. This is looking more and more like an issue with the router, IMO. Hopefully just the router firmware, and maybe if I switch to OpenWRT, that will take care of it. I think that may be my next step, unless someone has some idea how this can be fixed. That may have to wait until after my trip next week, though.

Last edited by montagdude; 01-06-2018 at 01:27 AM.
 
Old 01-06-2018, 01:51 AM   #22
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 520

Rep: Reputation: 276Reputation: 276Reputation: 276
Quote:
Originally Posted by montagdude View Post
Thank you so much. This works flawlessly to connect my router with a static IP. It has also solved my ping problems with this machine, though I still don't really understand why it wasn't working before. I have distilled these commands into the following rc script that runs from /etc/rc.d/rc.M in place of /etc/rc.d/rc.inet1:
I'd like to point out that this IS NOT the way the network configuration should be done under Slackware! The available tools and configuration provided and documented by Slackware should be used instead.

Now that nobody will sue me, back to your issue. The script you created looks OK apart from some duplicates - you either use ip or ifconfig.
Put a hash (or remove it) in front of ifconfig as it does the same thing as the ip command above it:
Code:
  /sbin/ip address add 192.168.88.9/24 dev wlan0
#  /sbin/ifconfig wlan0 192.168.88.9 netmask 255.255.255.0
and
Code:
  /sbin/ip link set wlan0 down
#  /sbin/ifconfig wlan0 down
In the line:
Code:
  arp -s 192.168.88.1 xx:xx:xx:xx:xx:xx(bridge MAC address)
make sure that the MAC is the one the router advertises it over WiFi - check on another client (laptop) with arp -a to be sure you're correct.
 
Old 01-06-2018, 02:07 AM   #23
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 520

Rep: Reputation: 276Reputation: 276Reputation: 276
Quote:
Originally Posted by montagdude View Post
Okay, here's something new. I found that when pinging from my laptop or phone with a fresh ARP cache, it does eventually find the server. It sometimes needs 16 or more attempts before finding the destination host. So, for those of you who know more about this than me, what does that indicate?

EDIT: I added a static ARP entry for the server in the router, but that didn't help.

EDIT2: Going back to the MacBook, I think now that it actually does have the same issue, but it doesn't require as many tries to successfully ping it. It takes maybe 4 tries instead of 10-20+. This is looking more and more like an issue with the router, IMO. Hopefully just the router firmware, and maybe if I switch to OpenWRT, that will take care of it. I think that may be my next step, unless someone has some idea how this can be fixed. That may have to wait until after my trip next week, though.
- How did you add a static ARP entry for the server in the router? Were you finally able to use arp -s IP MAC and execute it? If so, then I start to get out of ideas...
- I've hinted in a previous post to look at the docs for your router and now I've read some myself - check if the ARP Mode is Enabled
https://wiki.mikrotik.com/wiki/Manual:IP/ARP#ARP_Modes
- Your issue is really peculiar, mainly because you said it was working before with the old router and you haven't changed anything on your Slackware system. I might have two more ideas to make it work:
1. Check on your Slackware System if your WiFi interface is not powered down by the motherboard/CPU power management - take the steps from this post:
https://www.linuxquestions.org/quest...1/#post5775413
- or, a more direct approach to check if PowerManagement is enabled:
/sbin/iwconfig wlan0
- and look after the "Power Management:" entry - if it's on, then run
/sbin/iwconfig wlan0 power off

- if that's the case, then amend your newly created script and turn the WiFi PowerManagement off after the interface connection and IP configuration

2. I was about to suggest you a workaround, to ping the router from within your script after the interface connection and IP configuration. In this way you'll force the (lazy?) router to update the ARP table with your Slackware server MAC. But then you stated that you already defined a static entry for the server. Anyways, just test this -> put this line, that will send 1 packet and wait 1 sec for the reply - increase the packet count if you will, in your script after adding the default route & static arp:
Code:
  /sbin/ip route add default via 192.168.88.1
  arp -s 192.168.88.1 xx:xx:xx:xx:xx:xx(bridge MAC address)
# Insert here
/bin/ping -c 1 -w 1 -I wlan0 192.168.88.1 &>/dev/null
...
3. Pour LEDE in your router - OpenWRT is still not patched against the WiFi KRACK attack

Last edited by abga; 01-06-2018 at 02:31 AM. Reason: eth0 = wlan0 - WiFi PM addendum
 
1 members found this post helpful.
Old 01-06-2018, 08:13 AM   #24
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,048

Original Poster
Rep: Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777
Quote:
Originally Posted by abga View Post
- How did you add a static ARP entry for the server in the router? Were you finally able to use arp -s IP MAC and execute it? If so, then I start to get out of
ideas...
Yes, that's what I did.

Quote:
Originally Posted by abga View Post
- I've hinted in a previous post to look at the docs for your router and now I've read some myself - check if the ARP Mode is Enabled
https://wiki.mikrotik.com/wiki/Manual:IP/ARP#ARP_Modes
Yes, ARP=enabled on all the interfaces.

Quote:
Originally Posted by abga View Post
- Your issue is really peculiar, mainly because you said it was working before with the old router and you haven't changed anything on your Slackware system. I might have two more ideas to make it work:
1. Check on your Slackware System if your WiFi interface is not powered down by the motherboard/CPU power management - take the steps from this post:
https://www.linuxquestions.org/quest...1/#post5775413
- or, a more direct approach to check if PowerManagement is enabled:
/sbin/iwconfig wlan0
- and look after the "Power Management:" entry - if it's on, then run
/sbin/iwconfig wlan0 power off

- if that's the case, then amend your newly created script and turn the WiFi PowerManagement off after the interface connection and IP configuration
Okay, there's something. WiFi power management was on. Now that I have turned it off, it seems like it may have fixed the pinging problem... I'm not going to claim success yet though until I give it awhile and many tests. Strange that this didn't seem to matter with the old router, though. (Where's the "tentatively solved" option for this thread?)

Quote:
Originally Posted by abga View Post
2. I was about to suggest you a workaround, to ping the router from within your script after the interface connection and IP configuration. In this way you'll force the (lazy?) router to update the ARP table with your Slackware server MAC. But then you stated that you already defined a static entry for the server. Anyways, just test this -> put this line, that will send 1 packet and wait 1 sec for the reply - increase the packet count if you will, in your script after adding the default route & static arp:
Code:
  /sbin/ip route add default via 192.168.88.1
  arp -s 192.168.88.1 xx:xx:xx:xx:xx:xx(bridge MAC address)
# Insert here
/bin/ping -c 1 -w 1 -I wlan0 192.168.88.1 &>/dev/null
...
3. Pour LEDE in your router - OpenWRT is still not patched against the WiFi KRACK attack
Thanks for the ideas and info. You have been really helpful with this. I'm hoping that this is really solved. We'll see...
 
Old 01-06-2018, 01:31 PM   #25
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,048

Original Poster
Rep: Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777
So, the weird thing about this script is that every time the server reboots, ifconfig reports a new MAC address. It doesn't seem to cause a problem, but nonetheless I ended up just switching back to NetworkManager and making the DHCP lease static like I was doing before. The only difference is that now I turn off WiFi power management in my rc.local script. Everything is working fine now, and the MAC address is back to what it always used to be.

Anyway, thanks everyone for the help. I learned a lot!
 
Old 01-06-2018, 05:21 PM   #26
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 520

Rep: Reputation: 276Reputation: 276Reputation: 276
Quote:
Originally Posted by montagdude View Post
So, the weird thing about this script is that every time the server reboots, ifconfig reports a new MAC address. It doesn't seem to cause a problem, but nonetheless I ended up just switching back to NetworkManager and making the DHCP lease static like I was doing before. The only difference is that now I turn off WiFi power management in my rc.local script. Everything is working fine now, and the MAC address is back to what it always used to be.

Anyway, thanks everyone for the help. I learned a lot!
Glad you made it finally work. I've also learned some stuff from your experience and hopefully also the Slack community.
The script you used was sound but not supported by Slackware. Personally, I'm not using the Slackware stock scripts just because usually my network configuration is more complex, but for your scenario, with only one interface, you should stick with what you "officially" get.
Quote:
So, the weird thing about this script is that every time the server reboots, ifconfig reports a new MAC address.
Now, this is the piece of the puzzle that was missing until now and may explain why you are experiencing your issues. The script you made out of my hints shuts down and starst the interface in the beginning, which isn't really necessary, but good practice. But that process won't change your MAC address, unless the driver has this feature, or NetworkManager was still running and did it itself - NetworkManager has this feature and it might have been enabled!
To resolve this, make sure NetworkManager is stopped and you can also enforce a MAC address for your wlan0 in the script just after bringing the interface up and before the IP Address configuration:
Code:
ip link set wlan0 address 01:01:01:01:01:01
#or (don't use both)
ifconfig wlan0 hw ether 01:01:01:01:01:01
As described, NetworkManager has this MAC randomization feature and if enabled it's apparently causing problems in some scenarios:
https://bugs.launchpad.net/ubuntu/+s...r/+bug/1681513
https://bugs.debian.org/cgi-bin/bugr...cgi?bug=836351
..etc

This MAC address randomization on WiFi was also introduced and enabled by default recently in Apple products too (at least in the mobile ones) just to protect the user's privacy.

Having all this said, if MAC randomization is active on your Slackware system (& your wife's MacBook - Apple product) your router might need some time to flush the old MAC entry from it's ARP table and update it with the new one. (the ping sequence automation presented in a post above will help to force the router to do this update).

On the PowerManagement issue, I was about to suggest to put that line in rc.local, but you did it already Now, you might also want to take a look at the power management daemon form Slackware and ad a blacklist for your WiFi card:
https://unix.stackexchange.com/quest...nt-permanently

Finally, it's also not good practice to run a server connected through WiFi but only on wired network. However, it's in your home and I guess you don't want to have wires all over the place ...
 
Old 01-07-2018, 02:20 AM   #27
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,048

Original Poster
Rep: Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777
Quote:
Originally Posted by abga View Post
Glad you made it finally work. I've also learned some stuff from your experience and hopefully also the Slack community.
The script you used was sound but not supported by Slackware. Personally, I'm not using the Slackware stock scripts just because usually my network configuration is more complex, but for your scenario, with only one interface, you should stick with what you "officially" get.

Now, this is the piece of the puzzle that was missing until now and may explain why you are experiencing your issues. The script you made out of my hints shuts down and starst the interface in the beginning, which isn't really necessary, but good practice. But that process won't change your MAC address, unless the driver has this feature, or NetworkManager was still running and did it itself - NetworkManager has this feature and it might have been enabled!
To resolve this, make sure NetworkManager is stopped and you can also enforce a MAC address for your wlan0 in the script just after bringing the interface up and before the IP Address configuration:
Code:
ip link set wlan0 address 01:01:01:01:01:01
#or (don't use both)
ifconfig wlan0 hw ether 01:01:01:01:01:01
Thanks for the additional tip. I will put it in my script in case I go back to using it at some point.

Quote:
Originally Posted by abga View Post
As described, NetworkManager has this MAC randomization feature and if enabled it's apparently causing problems in some scenarios:
https://bugs.launchpad.net/ubuntu/+s...r/+bug/1681513
https://bugs.debian.org/cgi-bin/bugr...cgi?bug=836351
..etc

This MAC address randomization on WiFi was also introduced and enabled by default recently in Apple products too (at least in the mobile ones) just to protect the user's privacy.
I'm not sure I follow this. The MAC randomization only occurred when NetworkManager was not running (I made sure to stop it first and then make rc.networkmanager non-executable). Now that I am using NetworkManager again, the MAC remains constant. So it doesn't make sense to me that this could somehow be NetworkManager's fault.

Quote:
Originally Posted by abga View Post
Finally, it's also not good practice to run a server connected through WiFi but only on wired network. However, it's in your home and I guess you don't want to have wires all over the place ...
I would just put the server near the router and attach it via ethernet, but one of its jobs is to store footage from my security cameras (also wireless). In the worst case scenario where someone breaks in, even if they have the presence of mind to unplug the router or the cameras, I don't want the server with the footage to also be sitting there in plain sight. (That was actually the main reason I got this new router -- it's supposed to be super reliable.) But one day maybe I will run a wire, or, better yet, run a wire for each of the cameras. But that's a lot more time, effort, money, etc.
 
Old 01-07-2018, 03:34 AM   #28
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 520

Rep: Reputation: 276Reputation: 276Reputation: 276
Quote:
Originally Posted by montagdude View Post
I'm not sure I follow this. The MAC randomization only occurred when NetworkManager was not running (I made sure to stop it first and then make rc.networkmanager non-executable). Now that I am using NetworkManager again, the MAC remains constant. So it doesn't make sense to me that this could somehow be NetworkManager's fault.
I just checked (googled) if there were any changes in the latest kernels / network adapter drivers that might have implemented such a MAC changing algorithm and I found none. The only component in your server (a Standard Slackware Installation) that has this capacity is NetworkManager:
https://blogs.gnome.org/thaller/2016...manager-1-4-0/

The commands you distilled in your script are basic Linux networking configuration commands (utilities) that are not able to produce such an effect like the one observed/described. You can take a look at the original /etc/rc.d/rc.inet1 and you'll learn that it also uses ifconfig statements (ip in -current). I guess you got a little confused by rapidly trying a lot of things and accumulating a lot of information
If you have time, check with dmesg if you have persistent MAC address between reboots - it should stay consistent.

Last edited by abga; 01-07-2018 at 03:49 AM. Reason: ifconfig/ip change in -current
 
Old 08-09-2018, 10:43 PM   #29
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,048

Original Poster
Rep: Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777
This thread is already solved and kind of old, but I just wanted to remark that I just discovered powerline adapters. I got a couple of them and so far they are much faster than WiFi, and hopefully more reliable (that remains to be seen). They're definitely dead simple and cheap compared to running cables all over the house. I used the first set for the router and server, and next I will probably get a few more for my IP cameras. I wish I had known this technology existed when I first set this up.

Just passing this along in case it helps someone else.

Last edited by montagdude; 08-09-2018 at 10:45 PM.
 
Old 08-10-2018, 08:12 AM   #30
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 520

Rep: Reputation: 276Reputation: 276Reputation: 276
These were pretty common some 15 years ago and very insecure too. I didn't propose them to you because I didn't like your wireless setup in the first place, setting up a security system on insecure infrastructure, although WPA2 is still safe to use. Still..
https://hashcat.net/forum/thread-7717.html
Nowadays you get some AES128 encryption on these powerline adapters, but I strongly advise you not to go for the cheapest ones and always check if the manufacturer is maintaining them, that's releasing firmware updates.
https://security.stackexchange.com/q...erently-secure
https://www.bentasker.co.uk/document...lugav-adapters

Last edited by abga; 08-10-2018 at 08:16 AM. Reason: wrong URL
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS/ipv6 issues? New network, only server has internet issues. higgins909 Linux - Server 4 01-02-2017 03:43 PM
Ubuntu server network issues Red Bull Linux - Server 3 12-10-2012 11:31 AM
Slackware Samba Server + Windows Network Permissions Issues gankoji Slackware 5 09-20-2011 05:05 PM
[SOLVED] Network issues - need a temporary graphic display on Ubuntu Server (8.10) emmalg Linux - Server 2 11-23-2010 07:26 AM
LXer: 9 Tips to diagnose remote GNU/Linux server network connectivity issues LXer Syndicated Linux News 0 02-21-2007 05:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration