-   Slackware (
-   -   Network diff > 8.0 & 8.1 (

cereal2k 06-23-2002 07:40 AM

Network diff > 8.0 & 8.1
I've been running 8.0 since release and no problems with getting the network devices up'n running. Both as modules or as built in.

Now i've tried to get the same network cards up in the 2.4.18 kernel in 8.1 without luck.

After install i got up the network via netconfig and the 3c90x module worked. Network up. I ran menuconfig and made the config something like the one i had in 8.0 ( 2.4.17 ) and made the
3c900 "Vortex" module[*] and the same with the RealTek card. (8139)

Then make dep; make bzImage ; make modules ; make modules_install ; make install .

This is just like i have done before with the 8.0 kernelconfig, and it has been working well. Now, when booting the new kernel in 8.1 its not ok. Its not working at all!

Its up and working again if i compile it as [M]odule, but with [M] on the realtek driver, it gets "Can't find the rtl8139 module" at bootup.

I've just installed 8.0 again with 2.4.18, and its working 100% with builtin kernelmodule of the two cards.

What has changed since 8.0 on this front??

Anyone got this problem, or any info??

Thanks for any help!

mRgOBLIN 06-23-2002 10:09 PM

8.1 has the kernel image in /boot/ but by default make install will put your kernel into /

edit /usr/src/linux/Makefile and uncomment the
#export INSTALL_PATH=/boot

line and try make install again.


cereal2k 06-24-2002 05:13 AM

hmm, i dont think this has anything to do with it. The line was allready commented out when i checked it now. The system works, but it seems like it don't like built in modules! Why did it get so picky ?

Thanks for help mRgOBLIN

cereal2k 06-28-2002 05:25 PM

ITS WORING IN 2.4.16 and mabye 2.4.17... WTF is that all about????? 2.4.18 buggy like winme ?

All times are GMT -5. The time now is 06:34 AM.