-   Slackware (
-   -   Network card problem after power outage (

robrecc 06-08-2006 07:02 PM

Network card problem after power outage
Weird problem had a power outage 2 days ago at my house when i came home system was off. Booted it back up reiserfs did its job (wonderful filesystem) but the system was complaining about no network. ifconfig -a showed no eth0. I did a netconfig jsut to make sure that didnt work, tried to bring the card up with ifconfig no luck system complains that eth0 does not exist. I put in a brand new nic and having the same problmes. Everything else works - the sound card on mobo works fine - the adaptec scsi card works no problems - video no problem - just not network - lspci shows the nic there I just cant do anything with it. Slaks is connected to a linksys router and the light shows on the port number as well as on the NIC - i have tried changing net cables but that didnt help - the new nic is compiled into my kernel so thats not it. Any suggestion im stumped

drkstr 06-08-2006 07:09 PM

Did you try putting the new NIC into a different PCI slot? Maybe try taking out the sound card and put it in it's pci slot since you know it works.

Let me know what you find out.


robrecc 06-08-2006 07:11 PM

I forgot to mention the orig nic card was onboard - so i disabled that in the bios and installed a new one in a pci slot and still no luck -

drkstr 06-08-2006 07:25 PM

hmmm. It sounds like you fried something ..but what? I'm all out of ideas sorry. Just try moving it to another pci slot, and make sure your network driver is loaded when you run 'lsmod'. Also check 'dmesg' for any relevant errors.

Sorry I can't be of more help.


robrecc 06-08-2006 07:28 PM

tried another slot no luck - i know its not the mobo or else nothing would work - the module is loaded its the intel pro 10/100 - this is really weird - i cant think of anything

drkstr 06-08-2006 09:42 PM

Yeah, I'm at a loss too. Every time I got an idea, it was like, no wait that wouldn't make because it's not even detecting the device. Did you try and do something like 'ifconfig eth0 up' and then check the 'dmesg' for any error messages?


robrecc 06-08-2006 09:48 PM

Yes I did try that it says eth0 no device - which is so weird - running lspci shows the damm card and I know it works because i pulled it from my other linux box.

robrecc 06-08-2006 09:52 PM

I also tried a usb nic and it worked so all of a sudden my slack server cant seem to configure eth0 . I even tried switching the adaptec scsi pci slot with the nic pci slot and still nothing.

drkstr 06-08-2006 10:00 PM

Weird. I wonder if the power outage somehow corrupted your files system/packages? Maybe try downloading all the packages in the 'n' series and run a 'upgradepkg --reinstall *.tgz' on it.

Let me know how it turns out. You've got me damn curious.


robrecc 06-08-2006 10:10 PM

You know what that is a good idea. I will do that tommorow and let you know thanks for the suggestion

robrecc 06-09-2006 08:14 PM

Well problem solved - it seemed all I had to do was insmod e100 or modprobe e100 i forgot now that solved my problem

drkstr 06-09-2006 09:03 PM

Glad you got it working!

Strange that 'netconfig' did not load it automatically for you. What kind of network card do you have? I will have to remember that if anyone else has the same problem, I will know the answer ;)


robrecc 06-10-2006 10:02 PM

I have the intel pro +100- funny thing is I have had this card for 3 years and every linux install has loaded the card automatically all the time. I even had this card in the linux server last year , what im still confused over is why this time i had to load the module.

evilDagmar 06-11-2006 12:12 AM

Actually, there's a number of onboard NICs that get into a weird state when a machine loses power unexpectedly. In this condition, they'll simply refuse to work (I suspect it's got something to do with WOL support and when they'll take power from the ethernet bus). The solution is even weirder... You power off normally, disconnect the ethernet cable, then throw the switch on your power supply (if it has one) to off, and then unplug the machine from the wall for a moment. Plug it back in, flip it on, and the NIC will work again.

Remember this the next time you have a power failure. I've seen it happen on via-rhine boards, boards with realtek chipsets, as well as intel chipsets. (Which is why at first I thought it was a firmware/BIOS problem, and now I begin to think it's something to do with WOL support.)

All times are GMT -5. The time now is 04:34 PM.