-   Slackware (
-   -   Need to chroot to install lilo on a USB installed Slackware (

lkraemer 10-01-2012 05:09 PM

Need to chroot to install lilo on a USB installed Slackware
I've Partitioned & Formatted a 32G CENTON USB Flash Drive with Gparted with Debian.
I also made it Bootable and Created a Mount Point of /media/CENTON with
a Label of CENTON.

I then installed Slackware32 Ver 14 on /dev/sdb1 from the Booted Slackware DVD.

But, when Lilo was installed to the MBR it corrupted my /dev/sda1 Debian 6.0
(Squeeze) install. I've re-installed Grub2, did a grub-update and now have
Debian booting again.

I need to Boot from the DVD and somehow make the Centon USB Flash Drive Bootable via chroot. But I'm so far unable to get that done.

I need some specific directions on how to get Lilo installed on the /dev/sdx
USB Flash drive, so I can boot directly from the USB Drive to play with Slackware.

Any help would be appreciated. My searches haven't located an easy way to make the USB Drive Boot via lilo.
And Plop along with UBCD won't boot the USB Flash Drive of Slackware.



colinetsegers 10-02-2012 05:13 AM

Hi. Not sure to be helpful with the following.
What you write suggests the problem arises after the installation of Lilo to the MBR.
The computer also booted from the Slackware DVD, and thus the main hard disk was mounted as slave, as well as the Flash drive you're trying to install to. I guess that to avoid the installer to be confused it would be safer to disconnect the main hard disk, leaving thus the Flash drive as only accessible disk to install to. Assuming your machine allows to boot from a Flash drive my idea is to boot from the Slackware DVD and leaving no other choice for the installer than the Flashdrive to install to the new system according the normal procedure. Worth a try.
Also, if Lilo isn't working correctly there's still indeed Grub, and vice versa of course.
I had some systems refusing Grub (why???) and had to install Lilo (Debian 6 Squeeze), but then I had no need for double booting. With PCLinuxOS the problem was the other way round by refusing Lilo... Anyway, good luck. Paul

bokr 10-02-2012 07:24 AM

man lilo
It looks like the -A and -M options both
let you specify a master device.

(make sure, but e.g. /dev/sdb for the usb stick
in your case??)

Paulo2 10-02-2012 08:35 AM

Is /dev/sdb1 your usb flash drive with Slackware installed?
I can't remember right now but when you boot from
Slackware dvd, you can enter some parameters.
Read the message, yout can boot like this (in 13.37 version)

<kernel name> /dev/sdb1
it will boot the Slackware installed in that partition, /dev/sdb1 will be /

Once in Slackware you can edit lilo.conf and record a new lilo

lilo -C /etc/lilo.conf -b /dev/sdb1
option -C is which lilo.conf to use and -b is where lilo will be recorded.
Be sure that /dev/sdb1 is the flash drive and not your hard drive :D
To make this work you must change the bios to boot usb flash drive first.

I hope this will help :)

lkraemer 10-02-2012 01:20 PM

colinesegers, bokr, Paulo2:
Thanks for your response. I've tried everything except removing the Hard Drive. It doesn't work.

I've removed my Debian 6.0 Drive, and installed on a new Hard drive, but now I can't get my Wifi
working. It's loading the ath9K driver, but I can't get Slackware to detect my Wifi Card, and there are
no AP's listed. So, once again I give up. I just don't understand why I have this much trouble trying

Debian finds my Laptop's Wifi Hardware just fine:

root@debian:/home/larry# lshw -C network
description: Wireless interface
product: AR9285 Wireless Network Adapter (PCI-Express)
vendor: Atheros Communications Inc.


Paulo2 10-02-2012 04:19 PM

About wireless config, it's a new topic :D
but you can try 'iwconfig' as root to see if
Slackware has found the wireless interface.

About Debin/Slackware install, you can install both
in the same hard drive, don't you?
Hard drives are very large nowadays, making three
partitions, one for Debian, one for Slackware and
one swap that can be shared by both.
Slackware can be installed in a small partition (maybe 10GB),
and you can mount other partitions to access or write files.

To boot one or another you can choose lilo or grub, both will
find and boot Debian and Slackware.

colinetsegers 10-02-2012 04:20 PM


Originally Posted by lkraemer (Post 4795240)
colinesegers, bokr, Paulo2:
Thanks for your response. I've tried everything except removing the Hard Drive. It doesn't work.

Sorry to read the problem is not solved. Let things rest and maybe someone will come up with something. I tried Slackware also without success, but I know after having tried many different Linux distributions that one needs the right distrubution with the right hardware and the right user, and with Linux there are many variants.


Originally Posted by lkraemer (Post 4795240)
I just don't understand why I have this much trouble trying

Trying is the only way to know for sure if a distribution fits your needs, isn't it? And it's the best way to learn. Best wishes, Paul

padeen 10-04-2012 01:13 AM

Assuming you have booted with /dev/sda1 and also mounted your USB stick as /dev/sdb1 on /media/CENTON, you also need to mount the /dev and the /proc filesystems on /media/CENTON with

mount --bind /dev /media/CENTON/dev
mount --bind /proc /media/CENTON/proc

then chroot to /media/CENTON and run lilo.

Just check beforehand to make sure that you have an initrd image on /media/CENTON/boot (assuming 14.0 uses initrd as 13.37 did) before rebooting. (You probably do have one if this is a new installation on /media/CENTON.) Also, as Paulo2 mentions, you might need to change the BIOS to ensure the USB stick boots first.

See my notes here:

Re wireless, probably best to open a new post, but 14.0 introduces a new way of handling wifi scripts which I'm not familiar with as I haven't installed 14.0 yet. The old way is to follow Alien_Bob's method of using wpa_supplicant. There is a lot, almost too much, information here:

In general, Slackware doesn't hold your hand. You're expected to be reasonably experienced and know how to use and edit config files and scripts. Those of us who want to avoid unnecessary cruft and gimmicks (without picking on anything in particular, viz. Ubuntu, Unity) like it because we can have a lean, tight machine with the *nix ethos. If you prefer or need GUI wizards, you may be better off with a different distro.

vigi 10-04-2012 05:32 PM

multi booting
The easiest approach to multibooting is to install each os to a separate partition including the default boot loader (lilo), then use your main system as the boot manager and chainload each system with the debian grub2. This way each system is completely separate and you leave yout mbr in tact, so do not risk messing up your main os. Less confusing and faster than running from flash drives and dvds. Stick with slackware!!

All times are GMT -5. The time now is 11:21 PM.