-   Slackware (
-   -   Need help with xdm (

manwichmakesameal 03-09-2013 06:38 PM

Need help with xdm
Ok, so I've decided to sort of make one of my RPi's into my desktop a la thin client. So I found a post from AlienBob (here's the link). I set up /etc/X11/xdm/{Xaccess, xdm-config} just how he explains. When I run

X -query myhost :1
I get a login, but when I put in my user and pass, it just acts like it's gonna log me in, then back to the login screen. The very first time I tried it, it worked. I didn't change anything between it working and not either.

maciuszek 03-09-2013 07:58 PM

have a look at your .xsession for the user youre trying to log in with or the general xinit ( ur choice ) .. for when the session is being exec'd play with the clp's: exit-with*, dbus-lauch* .. ive had the same thing happening with i3 n removing stuff fixed it

manwichmakesameal 03-09-2013 09:09 PM

Unfortunately, I don't have any .xsession files except .xsession-errors-*. I deleted those, and the .Xauthority file. The .xinitrc is just a symlink to /etc/X11/xinit/xinitrc.blackbox. There isn't much in that file, but I'll try to shave some stuff out of it.

edit: Well, I'll have to put this problem under solved for now. I tried to log in on the machine locally, and it did the same thing. I have something else going on here.

maciuszek 03-09-2013 10:01 PM

you can always generate them with xwmconfig!
but from my assumption, without any research, i think all that does is change that symlink you mentioned and bases the invoking users .x[session,initrc] on that.

this is how i handled my i3 which was also dieing right away ( it maybe..probably has everything to do with --exit-with-session and the wm not being happy with this ):



# Merge in defaults and keymaps
[ -f $sysresources ] && /usr/bin/xrdb -merge $sysresources
[ -f $sysmodmap ] && /usr/bin/xmodmap $sysmodmap
[ -f $userresources ] && /usr/bin/xrdb -merge $userresources
[ -f $usermodmap ] && /usr/bin/xmodmap $usermodmap

xscreensaver -nosplash &
hsetroot -fill ~/Pictures/ws_Smoothy_grey_1280x1024.jpg &
xcompmgr -cfF &

# Start i3
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
    exec ck-launch-session /usr/bin/i3
    exec /usr/bin/i3

All times are GMT -5. The time now is 08:49 PM.