-   Slackware (
-   -   Need help getting connected to wireles (

TroN-0074 06-24-2012 07:59 PM

Need help getting connected to wireles
I recently switched computer but I kept the hard drive from the previous computer which has Slackware installed in it. The installation boot and everything seems to work except for the wireless.
When I do a iwconfig it replies with a message that there is not wireless extension.

I know the wireless card in the computer is supported, so my question is. Is there a command in SlackWare I can type to detects the hardware in which is running and reconfigure?
If I do a lspci I get

Ethernet controller : Intel Corporation 82540EP Gigabit Ethernet Controller (Mobile) (rev 03)
Ethernet controller: Atheros Communications Inc. Athereos AR5001X+ Wireless Network Adapter (rev 01)

I will appreciate all adices. Thank you.

CTM 06-24-2012 09:05 PM

There's no command that will just do everything for you in Slackware. You have an Atheros AR5001X+, which is supported by the kernel's ath5k module, so make sure that's loaded ("lsmod | grep ath5k", then "modprobe ath5k" if it's not). That should be enough to get it showing up with iwconfig, where you can configure it however you choose.

kingbeowulf 06-24-2012 09:42 PM

A couple of suggestions:
  1. Check the card specs: 802.11abg or n?
  2. run 'lspci -knn' to see numeric IDs and what kernel module is loaded.
  3. Is ath5k or ath9k loaded (ath9k for 802.11n IIRC)? Is ath.ko loading?
  4. make sure you are not accidently loading the USB driver: zd1211rw etc.
  5. custom kernel with Atheros modules disabled? you aslo need cfg80211 and mac80211.

CTM 06-24-2012 09:56 PM


Originally Posted by kingbeowulf (Post 4710927)
Is ath5k or ath9k loaded (ath9k for 802.11n IIRC)?

As far as I can tell it's an a/b/g adapter, so ath5k is the one to go for :)

TroN-0074 06-24-2012 10:20 PM

When I run

# lsmod | grep ath5k
It returns

ath5k                      129116  0
ath                          10985  1  ath5k
mac80211                    178230  1  ath5k
cfg80211                    122062  3  ath5k,ath,mac80211

when I run

# lsmod | grep ath9k
returns nothing.
However I do

# modeprobe ath5k
and I still can't get connected.
Please I will appreciate all advices.

zrdc28 06-24-2012 11:13 PM

You are loading the module, so root at cmd line.

iwconfig wlan0 essid " name"
dhcpcd -d wlan0

You might be ra0 or etc instead of wlan0.
This will connect for you!

kingbeowulf 06-25-2012 12:03 AM

If the driver is loaded then 'iwconfig' as root will show the wlan0 or similar with wireless extensions. If not, then either you have the wifi disabled or the card is broken. Is this a stock slackware installation or did you fiddle with it? I've used and prefer Atheros wifi chipsets and never had an issue with them not firing up.

TroN-0074 06-25-2012 06:01 AM

I can confirm the card is not broken because I have another distro in the drive and the other distro connect right of the bat without modifications.
I think I am still using the Huge kernel, I never got around to change it to a generic. So yeah I think the installation I have is very stock.

I also followed zrdc28 suggestion

iwconfig wlan0 essid " name"
dhcpcd -d wlan0
no luck so I dont really know what to do.

zrdc28 06-26-2012 11:25 AM

Ok lets try it again and see if it works this time, Please let us know if there are any errors!

ifconfig should list interfaces, and look something like this!
lo Link encap:Local Loopback
inet addr: Mask:
wlan0 Link encap:Ethernet HWaddr 00:25:9C:0A:88:D6
[B] inet addr: Bcast: Mask:

iwconfigshould look like this!

lo no wireless extensions.
wlan0 IEEE 802.11abgn ESSID:"roger"
Mode:Managed Frequency:2.462 GHz Access Point: 00:13:10:C9:90:94

iwlist scanshould give a list of all local networks received!
wlan0 Scan completed Cell 01 Address:C0:83:0A:56:CE:71 Channel:9
Frequency:2.452 GHz (Channel Quality=30/70 Signal level=-80
If none of the above work, do a
dhclient ,if no errors then!
iwconfig wlan0 essid name if it errors replace wlan0 with ra0, and be sure to include essid name with yours!
dhcpcd -d wlan0 If everything works go back to the top and, ifconfig,iwconfig,iwlist scan, and you should see results

jostber 06-26-2012 06:16 PM

Can you try to install wicd and check if you can get the card running with this?

TroN-0074 06-27-2012 01:59 PM

I have wicd installed and I had it working before the switch. The installation was fully working on the other laptop so I don't know why it wont work on this other one. They both have the same wireless card.

I will appreciate all advices. Thank you.

kingbeowulf 06-28-2012 01:27 AM

TroN-0074, have you checked /etc/modprobe.d and /etc/rc.d/[rc.local|rc.modprobe] etc to make sure you are not loadind a conflicting module from the prvios computer?

onebuck 06-28-2012 04:59 PM

Member Response

What do you see with 'ifconfig -a'? Which Laptop? Specs?

TroN-0074 06-29-2012 11:28 PM

O.k this is weird and I hate it. When I plug my WG111v3 NETGEAR wireless USB adapter wicd connects instanly. So the settings on wicd are good and functioning.

In this hard drive also have installed OpenSuSE 12.1 and it connects just fine when I boot in it without using a usb adapter.
I also have installed in the same hard drive FreeBSD 8.2 and it connects just fine too no need of netgear

Only in slackware the adapter is needed.

My laptop is a IBM Thinkpad T42 with an Atheros AR5001X+ wireless Network Adapter. I dont know if I should and I dont know how to re install the driver for it.

I am booting with the vmlinuz-huge-2.6.37 kernel. I wonder if I boot with the generic will change anything, however SUSE controls the boot and I havent figure out how to change the kernel choice.

The laptop I was using before had the same type of wireless card, it was also a Thinkpad but the T41 model.

I will appreciate it all advice.

Arcosanti 06-30-2012 06:23 AM

The only thing I can think of is that you might have another module loading that is causing a conflict. Maybe you ought to try compiling a custom kernel and take out all of the unnecessary modules. A side benefit is a leaner kernel as well.

All times are GMT -5. The time now is 03:11 AM.