-   Slackware (
-   -   Need help for installing Realtek 8188CE wifi driver (

banexx 11-22-2011 11:46 AM

Need help for installing Realtek 8188CE wifi driver

I have searched the forum and google but unable to find a solution for my problem.

I have Lenovo Thinkpad Edge laptop (Slackware 13.37) with wifi, but i cant seem to install the wifi network interface correctly.

lspci tells me that the wifi card is a

3:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
I went to realtek and downloaded the Linux driver for RTL8188CE and for kernel 2.6.24+.

After i extracted the file i changed directory to the newly extracted folder and did

make install

with no errors.

According to the readme-file i only needed to reboot my machine for the wifi to work. But i cant seem to make it work. I have tried the WICD application but it cant find the network interface.


ifconfig wlan0 up
tells me that wlan0 is an unknown interface.

Any suggestions?


camorri 11-22-2011 01:28 PM

Fist thing to do is run the command 'lsmod' ( without quotes ) to see if the new kernel module is loaded. If yes, then onto configuration. If not, 'modprobe kernelmodulename'. No errors is success, error messages have to be resolved.

Config. The best advice I can offer for Slack, is to go to this link


This link covers it all for Slackware.

There is a detailed section on Wireless. Right now, even if the correct driver is loaded, the wireless driver will be known as eth1 ( assuming you have a wired eth0 ). For that reason, wicd will not see the adapter. Once you edit the correct files, it will see it.

Hope this helps.

banexx 11-22-2011 01:59 PM

The module wasn't loaded so i tried

modprobe rtl8188ce
and got this error

FATAL: Error inserting rtl8192ce (/lib/modules/ Invalid module format
I did some searching and it seems that others faces this error because of the kernel version.

Any idea?

banexx 11-23-2011 11:36 AM


H_TeXMeX_H 11-23-2011 12:26 PM

Make sure you have the firmware installed.

zrdc28 11-26-2011 07:08 PM

I believe you might be modprobe the wrong name. Try r8188_pci and see if that works for you.

All times are GMT -5. The time now is 08:35 PM.