-   Slackware (
-   -   Need advice on possible upgrade from 11.0 to newer sw version (

H_TeXMeX_H 03-29-2009 04:18 PM

Need advice on possible upgrade from 11.0 to newer sw version
This is kind of a special case, because normally I would know the best course of action. I'll try to get straight to the point:

I need to upgrade a computer with Slackware 11.0 installed to a newer version. Only problem is, this computer is half way around the world. What is the best option ?

I want to install a VOIP program so I can talk to my parents who are half-way around the world. I tried ekiga which used to work (I installed it before I left), but it seems their server is down or something because I can't log in, I tried making a new account, same problem, same problem on different computers mine, my bother's, my parent's all running different versions of ekiga and slackware. It's very odd, maybe I'll ask on their mailing list or something. But, it used to work perfectly just a few months ago, and now it doesn't.

Either way, I've also noticed that skype seems to give much better quality and less connection cut-offs. So I tried that, but the latest version won't work with sw 11.0 (on my parent's computer, across the ocean) because glibc is too old, which means I must upgrade. I can't use an older version of skype because it doesn't support the uvc drivers, which I must use. (I know, it's just a bad situation)

Now (for the last piece of bad news), my parents are not very technologically inclined, but they will follow instructions over the phone. But, I'm thinking that dictating how to upgrade to a new version will be difficult and time consuming.

I don't know what to do, anyone have advice on the easiest, fastest way to solve this problem ?

(I know you might be asking: why did you install slackware on your parent's computer ... because I know it is set and forget, I know nothing can go wrong unlike with other distros, everything will be perfectly stable for years to come ... only problem comes when you are forced to upgrade ... like now)

Thanks beforehand.

EDIT: One thing that has changed since last time ekiga worked is that we changed routers on all computers. I will check the settings to make they aren't interfering with ekiga ...

easuter 03-29-2009 04:37 PM

Don't know about skype, but I remember a user of VectorLinux was able to get Wengophone to run on version 5.8 of the distro, which was SW 11 based, and the problem was the same: outdated libc.

Its a horrible hack, but in your case it just might be the lesser of two evils since the box in question is very far away.

H_TeXMeX_H 03-30-2009 03:39 AM

Yes, but I think the problem is greater than just libstdc++, it's also glibc ... can this be done with glibc ? That would truly be a dirty hack.

Anyway, more info on the problem, I forgot to mention that we have changed routers since I last tried ekiga, maybe I should make sure the right ports and protocols are enabled. Will post back on the status of this.

titopoquito 03-30-2009 03:48 AM

In case you won't get it to work (upgrade or hack) you might consider SimpleMepis Live-CD. It looked rather nice the one time I looked into it, and further more it has skype installed out of the box. So at least for your video meetings this might be a another workaround until you get physical access to your parent's PC.

Didier Spaier 03-30-2009 04:40 AM

Why wouldn't you try to find an helpful Slacker near your parent's location, eager to help them install Slackware 12.2 with Skype on top of it ?

Is there someone eager to add a localize-slacker function to Google Maps around here ? ;)

easuter 03-30-2009 07:16 AM

TeX, how about installing SW11 on a "disposable" partition and running some tests on that to see if it might work. And I do think that it is a problem with libstdc++ because both skype and wengophone are C++/Qt apps.

H_TeXMeX_H 03-30-2009 10:32 AM

Ok, then I'll try using libstdc++ like you said before trying to upgrade somehow.

I looked at my router settings and my firewall settings and it seems SIP is allowed and the right ports are open on both ... but still ekiga fails. Weird. And now ekiga crashed as well.

If I had to upgrade, do you think I could do it via ssh ? It would be complicated, but maybe possible.

Thanks for the input so far.

allend 03-30-2009 11:26 AM


If I had to upgrade, do you think I could do it via ssh ? It would be complicated, but maybe possible.
It is not recommended, but Pat did state in the last release notes that people have reported doing remote updates successfully.

I did this recently upgrading from 12.1 to 12.2 and it can be done (from run level 3), BUT!
Ensure that you change the default run level from 4 to 3 in /etc/inittab at the start.
You need to be very careful about updating configuration files.
If you have third party drivers ( e.g. nVidia graphics drivers ) then they will need to be rebuilt for the new kernel.
If you have been using an initrd, remember that you will need to update this.

Murphy's Law applies. If anything can go wrong. it will! You would be wise to have an alternative communications channel in place when it is time to reboot.

H_TeXMeX_H 04-11-2009 01:39 PM

Thanks to all of you who replied, I finally sorted it out, by doing the nasty hack suggested by easuter. I actually had to copy in 2 different shared library files to get it to work. Hopefully there will be no side-effects of doing this. It works great so far tho. Thanks again :)

In case you want to know I copied in:

Then it worked. I got these from sw 12.2 I believe.

H_TeXMeX_H 04-20-2009 04:47 AM

One more note before I leave this thread to fade: The hack that was implemented does seem to cause some degree of system instability. When starting skype there is a chance of the whole system becoming unresponsive. Skype seems to still work but any input from the user is ignored. So the video and audio are still working but mouse and keyboard seem to be ignored by the whole system. Anyway, that's a possible side-effect of this hack.

All times are GMT -5. The time now is 09:45 AM.