-   Slackware (
-   -   NDISwrapper Installation confusing error, Slackware 12.1 IBM Thinkpad T30 (

wkdude18 06-16-2008 07:38 PM

NDISwrapper Installation confusing error, Slackware 12.1 IBM Thinkpad T30
Hello! I recently installed Slackware 12.1 on my IBM Thinkpad T30 successfully except for one issue; wireless internet. This has been frustrating; the KDE GUI for these settings has done nothing for me. I decided to download the ndiswrapper module (on another computer) and copied it over to my Slackware. I extracted it and when I ran make distclean as in the installations directions. However I get the following:
make distclean
make -C driver clean
make[1]: Entering directory '/home/william/ndiswrapper-1.53/driver
Makefile;34 *** Cannot find kernel version in /usr/src/linux-, is it configured?. Stop.
make[1]: Leaving directory '/home/william/ndiswrapper-1.53/driver'
make: *** [clean] Error 2

however the ndiswrapper website said that the directory it looks for the kernel in is /lib/modules/VERSION/build, but it does not appear so in the prompt. URL:,installation/

What is the problem? Do I need to download a windows driver as well? Do I need to recompile the kernel after install? Do I need to install the kernel source code from the installation DVD/should I?

T3slider 06-16-2008 08:03 PM


Originally Posted by wkdude18
What is the problem? Do I need to download a windows driver as well? Do I need to recompile the kernel after install? Do I need to install the kernel source code from the installation DVD/should I?

You do need the kernel source package installed, since you are trying to build a kernel module. It is located in the k/ series on the install CD/DVD (it is the kernel-source- package). You can install it with `installpkg kernel-source-` as root. The /lib/modules/VERSION/build thing means that /lib/modules/ is a symlink to the kernel sources, which are located at /usr/src/linux- Since you do not have the kernel sources installed, this is a dead symlink.

You do NOT have to rebuild the kernel. You will have to download the Windows driver, but all of the drivers are linked from their site (I think). I have no experience with ndiswrapper, so I can't help you here.

I would recommend using the SlackBuild to compile ndiswrapper from Instructions on how to compile applications (such as ndiswrapper) using SlackBuilds are located on the same site, here.

wkdude18 06-16-2008 08:48 PM

Thank You
Thank you very much for clearly answering my questions. I will apply your advice, feedback to be written soon.

zoran119 06-17-2008 02:28 AM

I think I got ndiswpper from linux packages It is working.

T3slider 06-17-2008 10:47 AM


Originally Posted by zoran119
I think I got ndiswpper from linux packages It is working.

For future reference, I would try to avoid Most of their packages do not contain SlackBuilds, so you really have no idea how it was built -- you're basically using blind faith that the package was built properly. In addition, packages are often built on unclean systems, and have questionable dependencies. There ARE reputable packagers on, but finding them takes experience or advice from others.

I would recommend first (the SlackBuilds work well and some of the Slackware contributors themselves maintain/contribute to the site). Also recommended are Alien Bob's repository and rworkman's repository. They are both major Slackware contributors, and include prebuilt packages and SlackBuilds in their repositories.

If you still can't find a package or SlackBuild, and you don't want to write a SlackBuild yourself, I would recommend, which is a nice, big repository with prebuilt packages and SlackBuilds. I would trust this one less than the others (though much more than, but it's still a great resource, and you shouldn't have any trouble using packages or SlackBuilds from there.

If you *still* can't find a package or SlackBuild, you could consider writing your own SlackBuild or using gnashley's src2pkg to attempt to automatically compile the app and create a package. I've never tried src2pkg but have heard nothing but praise from those who have.

zoran119 06-17-2008 05:53 PM

Thanks for that T3slider.

So order of preference:
2. Alien Bob's repository and rworkman's repository
4. write your own

Still haven't written my own slackbuild, but will give it a shot.

It's things like this you cannot easly find out without the community. Thanks again.

wkdude18 06-18-2008 10:20 AM

sorry but installpkg error
When I type installpkg "".tgz as root, it says Cannot install "".tgz: package does not end in .tgz

I tried doing this again, this time not adding an ending and adding a tar.gz extension (without the .tgz), but it still comes up with the same error.

Is this a problem with the internet connection (using an ethernet cable at the moment) or should I install from the Slackware DVD? Is this an option, or if I needed to install from the DVD would I have to do a fresh reinstall?

wkdude18 06-18-2008 11:18 AM

Sorry Again
Never mind previous question, I installed from DVD just fine. I asked the question too early (before I had a problem).

wkdude18 06-18-2008 12:19 PM

Cisco Aironet 802.11b MPI 350 driver installation no .inf .sys files
Well, I successfully installed ndiswrapper after installing the kernel source packages and I downloaded the driver from the Cisco website, Win-Client-802.11a-b-Ins-Wizard-v18.exe, and unxipped it successfully. The trouble is the only .inf or .sys files which the ndiswrapper website says to look for is a file called CSWLOGON.INF. I tried unzipping, cabextracting, (I could not get unshield to work), all of the others exes that came out of the original exe (AppInst.exe, CAppLder.exe, DrvInst.exe,IWSetup.exe,LEAPCheck.exe, NT4DrvInst.exe, PostUnInstall.exe, SetDbgLevel.exe) for other .sys of .inf files, but nothing was produced from this effort. So after ndiswrapper -i CSWLOGON.INF, I get

couldn't find SourceDisksFiles section - continuing anyway...
installing cswlogon ...

I'm assuming this means that it couldn't find a .sys file, but there were none. So after i do this I type in ndiswrapper -l and get

cswlogon : invalid driver!

Yeah! I'm stuck lost, and I have no clue what to do. Any suggestions? Do I need to install unshield? How is this done properly? Thanks in advance.

wkdude18 06-18-2008 12:36 PM

Never mind again
I found the appropriate .inf file. Please do not heed above post.

wkdude18 06-18-2008 01:11 PM

Unshield error
When I try to use the unshield command (after downloading unshield "google unshield") I get this error.

unshield: error while loading shared libraries: cannot open shared obkect: no such file or directory

Do i need to download or install this file somewhere? Was there something wrong with the installation commands i was using while installing unshield-5.8.1.tar.gz (./configure, (make clean), make, make install) all as root? This is beginning to become very tiresome.

wkdude18 06-19-2008 09:13 AM

Never Mind
Just posting my solution for the archives I guess. I went into debian and searched synaptic's repository for unshield and when I clicked to install the package it said that had a dependency called libunshield0, so I guess I just needed to install a library to go with unshield in Slackware, but since I downloaded the utility in Debian it seems to work fine in Slacware.

Alien Bob 06-19-2008 12:41 PM

For posterity - just get and install a unshield package here:


All times are GMT -5. The time now is 03:28 PM.