-   Slackware (
-   -   n00b: CD-Mounting problem (

Anti-Gates 07-03-2003 12:08 AM

n00b: CD-Mounting problem
I have 2 cd drives on my box. One DVD, and one CDRW. Yesterday the DVD drive was working. I turned the computer off, came back in the morning, and now my CDRW works, but not my DVD drive. (I dont think I can write to my CDRW, but I can read from it). I have searched other forums, and google, and I have not found anything that has helped me with my problem. Anything that might help would be great.

(Im sorry if there are other posts about this here, but the search on this forum wasnt working well when I tried.)

wonderpun 07-03-2003 05:23 AM

Hello and welcome to LQ :) So what would you want to know? How to get your DVD drive back or how to configure your CD-RW so that you could write CD's? Ok, I think both would be great. Hmmm... well can you post your /etc/fstab here? That would be a start. :)

Anti-Gates 07-03-2003 10:58 AM

/dev/hda3 swap swap defaults 0 0
/dev/hda2 / ext3 defaults 1 1
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/scd0 /mnt/cdrw iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

Anti-Gates 07-03-2003 10:58 AM

Also, I cant mount anything as user. How do I change permissions?

acid_kewpie 07-03-2003 11:02 AM

add "user" to that option list, e.g. noauto,owner,ro,user

Anti-Gates 07-03-2003 11:16 AM

OK, thanks...

Anti-Gates 07-03-2003 12:38 PM

Hmmmm now when I mount my cdrw, my DVD drive mounts and it works... But my CDRW wont mount now...

Anti-Gates 07-03-2003 01:07 PM

OK, well now my DVD drive is scd0. I have changed my fstab. It currently looks like:

UW PICO(tm) 4.4 File: /etc/fstab

/dev/hda3 swap swap defaults 0 0
/dev/hda2 / ext3 defaults 1 1
/dev/hda1 /mnt/win ntfs ro,umask=0222 0 0
/dev/cdrom /mnt/cdrw iso9660 noauto,owner,ro,user 0 0
/dev/scd0 /mnt/cdrom iso9660 noauto,owner,ro,user 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

grym 07-03-2003 01:22 PM

Setting up burner and dvd

if you use lilo add a line like
(substitute your cdrw device for hda)
run /sbin/lilo

linked /dev/hdd to /dev/dvd
(once again substitute your dvd dev for hdd)
then add these lines to /etc/fstab

/dev/sr0 /mnt/cdrom iso9660 user,noauto,ro 0 0
/dev/dvd /mnt/dvd iso9660 user,noauto,ro 0 0

if your burner is scsi things are different such as not needing the append line

Anti-Gates 07-03-2003 01:27 PM

my DVD (cdrom) works now. So that is scd0. I am using lilo, I am using the scsi kernel, I have the append line in lilo.

grym 07-03-2003 01:32 PM

is your burner scsi?

Anti-Gates 07-03-2003 02:06 PM

No, it is IDE. It is on the secondary channel, and I believe it is set to slave. (making it /dev/hdd right?)

Locura 07-03-2003 02:18 PM


Originally posted by Anti-Gates
No, it is IDE. It is on the secondary channel, and I believe it is set to slave. (making it /dev/hdd right?)
Yes. Make sure that the append line refers to /dev/hdd. Also, your CD-RW drive should be /dev/scd0. do an ls -l /dev/scd0 and see what device it points to (since it should be a symbolic link) It should be pointing to /dev/hdd since your burner is secondary slave. if not, delete the symbolic link and enter ln -s /dev/hdd /dev/scd0. you'll also want to make sure that /dev/cdrom points to /dev/hdc, and make the necessary changes in your fstab so /dev/cdrom is mounting as /mnt/cdrom or /mnt/dvd or whatever you want, and /dev/scd0 is mounting as /mnt/cdrw or whatever you want as the CD-RW drive.

Anti-Gates 07-03-2003 02:50 PM

root@Basement:/home/Rob# ls -l /dev/scd0
brw-rwxrwx 1 root disk 11, 0 Jul 18 1994 /dev/scd0

Does this mean that /dev/scd0 is actually pointing to /dev/scd0?


Why should my cdrw be scd0? My DVD drive works as scd0.

I really dont want to touch anything in my DVD drive, cause I dont want it to stop working again.

Locura 07-03-2003 02:58 PM

My bad, I said it was a symbolic link and I was mistaken (It's not that way on my own system, I don't know why I thought this). Sorry for the confusion. In that case you would want /dev/cdrw to be a symbolic link to /dev/scd0, not to /dev/hdd. Make sure that the append statement in your lilo.conf is referring to /dev/hdd. And if you make any changes to lilo.conf, remember that they won't take place until you run lilo -v (you'll want the "-v" in case there is a problem, like a syntax error in the lilo.conf).

All times are GMT -5. The time now is 09:42 AM.