-   Slackware (
-   -   mysql_install_db fail (

tamtam 08-02-2010 03:38 PM

mysql_install_db fail
Hi people,

Just done a clean install of Slackware 13.1.

Had trouble starting mysql. Been there before. I went through the usual routine. Created my.cnf. Ran install_db. Failed.

Okay, so following advice given in other posts with the same problem. I uninstalled mysql and reinstalled. Getting the same error...Tables creation fails..


Installing MySQL system tables...
100802 21:29:36 [Warning] '--skip-locking' is deprecated and will be removed in a future release. Please use '--skip-external-locking' instead.
100802 21:29:37 [ERROR] /usr/libexec/mysqld: Can't find file: './mysql/db.frm' (errno: 13)
ERROR: 1017 Can't find file: './mysql/db.frm' (errno: 13)
100802 21:29:37 [ERROR] Aborting

100802 21:29:37 [Note] /usr/libexec/mysqld: Shutdown complete

Installation of system tables failed! Examine the logs in
/var/lib/mysql for more information.

You can try to start the mysqld daemon with:

shell> /usr/libexec/mysqld --skip-grant &

and use the command line tool /usr/bin/mysql
to connect to the mysql database and look at the grant tables:

shell> /usr/bin/mysql -u root mysql
mysql> show tables

Try 'mysqld --help' if you have problems with paths. Using --log
gives you a log in /var/lib/mysql that may be helpful.

Please consult the MySQL manual section
'Problems running mysql_install_db', and the manual section that
describes problems on your OS. Another information source are the
MySQL email archives available at

Please check all of the above before mailing us! And remember, if
you do mail us, you MUST use the /usr/bin/mysqlbug script!
Anyone got any ideas...completely stumped on this one...

Just remembered to read rc.mysqld like I had done on numerous occasions before when installing slack..

# Note that the mysql user must exist in /etc/passwd, and the created files
# will be owned by this dedicated user. This is important, or else mysql
# (which runs as user "mysql") will not be able to write to the database
# later (this can be fixed with 'chown -R mysql.mysql /var/lib/mysql').

EricTRA 08-03-2010 01:08 AM


Since you marked it as solved: Gone from the Zero Reply list.

Kind regards,


All times are GMT -5. The time now is 03:50 PM.