-   Slackware (
-   -   MySQL 4.0.15 giving me fits with recent 9.1 slack upgrade (

absolute0net 06-06-2004 11:52 PM

MySQL 4.0.15 giving me fits with recent 9.1 slack upgrade
Computer: Dell Inspiron 8600
Processor: P4 w/ Centrino Chip
OS: Slack 9.1

Started with slack 9.0 - everything worked fine but the nic card...fine, so I upgraded to Slack 9.1. everything works fine but mysql!!

during my initial install I did the following:

shell> su mysql
shell> mysql_install_db

Now, when I do the [mysql_install_db] --- this is what I get

mysql@localhost:/var/lib$ mysql_install_db
Preparing db table
Preparing host table
Preparing user table
Preparing func table
Preparing tables_priv table
Preparing columns_priv table
Installing all prepared tables
ERROR: 1062 Duplicate entry 'localhost-root' for key 1
ERROR: 1062 Duplicate entry 'localhost-root' for key 1
040607 0:38:02 /usr/libexec/mysqld: Shutdown Complete


and from there, it will not allow me to access mysql..

any ideas?? My head hurts!

wrochal 06-07-2004 12:34 AM

owner on Mysql

Use this comand:

# chown mysql.mysql /var/lib/mysql

the start mysql.


absolute0net 06-07-2004 06:09 AM

root@localhost:/var/lib# chown mysql.mysql /var/lib/mysql
root@localhost:/var/lib# mysql
ERROR 2002: Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)

Azmeen 06-07-2004 06:36 AM

wrochal's post is slightly wrong. You should use chown -R mysql:mysql /var/lib/mysql instead.

absolute0net 06-07-2004 06:50 AM

Thanks for your replies -- I've tried it both ways with no success. Still getting errors.

I even rm -rf /var/lib/mysql, removepkg mysql, swaret --installed mysql (again), su to mysql and tried mysql_install_db.....and got the same exact error as described above.

Azmeen 06-07-2004 09:37 AM

OK, step by step...

For now, I'll assume you have mysql installed.

1) su as root.
2) rm -rf /var/lib/mysql
3) cd /var/lib
4) mkdir mysql
5) chown -R mysql:mysql /var/lib/mysql
6) su mysql
7) mysql_install_db

All done :)

All times are GMT -5. The time now is 01:24 PM.