LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-27-2013, 06:24 PM   #1
EldonCool
Member
 
Registered: Dec 2010
Location: Nevada
Distribution: Slackware
Posts: 86

Rep: Reputation: 0
My mouse cursor disapears


I have a new installation of version 14 slackware on
my dual boot computer, linux/XP.

When I first setup I was running KDE as my desktop
in X Windows. It had no mouse cursor, when going
into X windows with KDE as the windows manager. After
I tried going into X windows logged in as root, the
mouse cursor appeared. After that when I ran X windows
as a regular user, the cursor also worked.

Later I re-installed linux for other reasons, and this
time I was changing windows managers around. Now I
ran X windows with the windows manager xfce. I really
liked this manager, great function and response time,
but when I left the system for a long time and it went
to screen saver, great screen saver by the way, when
I again tried to operate, I had no mouse cursor. I
had lost the mouse cursor somehow.

Is there some way to easily get your mouse cursor
back once it disappears? I actually had this problem
in windows for awhile once my installation got very
old with lots of added stuff and deleted stuff. I
could always get my mouse cursor back by just unplugging
the mouse from the computer and then replugging it.

I can't figure out anyway to get it back after I loose
it while operating with xfce, once the system has set
idle for a long time.
 
Old 05-27-2013, 07:19 PM   #2
Celyr
Member
 
Registered: Mar 2012
Location: Italy
Distribution: Slackware+Debian
Posts: 314

Rep: Reputation: 77
When it disappears try to go to the console and get the output of
Code:
dmesg
to see if anything went wrong with the mouse, then you can try to
Code:
cat /dev/mouse
and move it, to see if the mouse is still working.
You may also have a look to .xsession-errors files, you will find them in your home and also a useful log file can be
Code:
/var/log/Xorg.0.log
Also you can give us some information about the mouse (they are in the logs anyway) like if it's an USB or PS2 mouse.
Without more info I can't help you.
 
Old 05-27-2013, 11:24 PM   #3
EldonCool
Member
 
Registered: Dec 2010
Location: Nevada
Distribution: Slackware
Posts: 86

Original Poster
Rep: Reputation: 0
I will make notes on this and give a try.

As I understand it:

(1) run dmesg on an x terminal & get response.

(2) look at the file /dev/mouse for a clue.

mouse still works when this happens, I can see
that it hovers over certain things and lets me
select them, just no visible cursor.

(3) look at file /var/log/Xorg.0.log

The mouse is a usb mouse, and it has 3
buttons, the middle one is also some sort
of wheel that I rarely use. Use to use
it somewhat like a middle button on a
regular 3 button mouse, but I really
don't know what the wheel is suppose
to do. It will make a display move up
and down on the screen.


I'll make a copy of this to have handy and then see
if I can induce the problem again, maybe tomorrow.

Last edited by EldonCool; 05-27-2013 at 11:27 PM.
 
Old 05-28-2013, 06:15 AM   #4
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,993

Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
This has been a "thing" with Xfce; you log out from Xfce, it takes forever, restart it (with startx) and no cursor (actually, it's there but it's the standard X-Windows "X" cursor, you can hover and do things)? Pain in the butt.

A "fix" is to remove the ~/.cache directory; another "fix" is to remove ~/.cache/sessions:
Code:
shut down Xfce (log out to the console)
rm -r .cache
<or>
rm -r .cache/sessions
startx
Why it happens, I dunno, but it seems to happen if Xfce is running for a long time (like days) it'll sometimes do this, not always, but sometimes. The ~/.cache directory gets rebuilt when you restart Xfce.

Other thing -- you have a 3-button with scroll wheel USB mouse? Microsoft mouse? Take a look at /etc/rc.d/rc.gpm (that's what starts the mouse at boot). It should look like this:
Code:
cat /etc/rc.d/rc.gpm
#!/bin/sh
# Start/stop/restart the GPM mouse server:

if [ "$1" = "stop" ]; then
  echo "Stopping gpm..."
  /usr/sbin/gpm -k
elif [ "$1" = "restart" ]; then
  echo "Restarting gpm..."
  /usr/sbin/gpm -k
  sleep 1
  /usr/sbin/gpm -m /dev/mouse -t imps2
else # assume $1 = start:
  echo "Starting gpm:  /usr/sbin/gpm -m /dev/mouse -t imps2"
  /usr/sbin/gpm -m /dev/mouse -t imps2
fi

# There is another way to run GPM, where it acts as a repeater outputting a
# virtual MouseSystems mouse on /dev/gpmdata.  This is useful for feeding
# gpm's data to X, especially if you've got a busmouse (in that situation X
# and gpm may not coexist without using a repeater).  To try running a GPM
# repeater for X, change the gpm command line to look like this:
# /usr/sbin/gpm -R msc -m /dev/mouse -t imps2
# Then, make sure that the mouse configuration in your XF86Config file refers
# to the repeater device (/dev/gpmdata) and a MouseSystems mouse type.  If you
# edit the file directly, you'll want the lines to look like this (minus the
# comment marks '#' shown here, of course):
#Section "Pointer"
#    Protocol    "MouseSystems"
#    Device      "/dev/gpmdata"
When you installed Slackware you were asked about the mouse and whether to start GPM at boot (the install looks at the connected mouse and suggests what to use). 99 out of 100 it's a Microsoft (or compatible) mouse and IMPS-2 is the right protocol for it. Might want to check that.

Hope this helps some.
 
Old 05-28-2013, 07:58 AM   #5
digger95
Member
 
Registered: Oct 2007
Location: Indiana, PA
Distribution: Slackware 14
Posts: 330

Rep: Reputation: 45
Quote:
Originally Posted by tronayne View Post
This has been a "thing" with Xfce; you log out from Xfce, it takes forever, restart it (with startx) and no cursor (actually, it's there but it's the standard X-Windows "X" cursor, you can hover and do things)? Pain in the butt.
This happened to me about a week ago. Got a big black X instead of the mouse pointer and I could move it around the screen but couldn't do much else with it. As I recall, all of my window controls were missing also. It was a fairly fresh install at the time so I think I just deleted all of the .stuff in my home directory and allowed everything to be rebuilt. It hasn't happened again since but now I know which particular folder to delete next time, so thanks.
 
Old 05-28-2013, 09:34 PM   #6
EldonCool
Member
 
Registered: Dec 2010
Location: Nevada
Distribution: Slackware
Posts: 86

Original Poster
Rep: Reputation: 0
I also get the same thing with the X cursor instead of
the pointer cursor. Once I get firefox up, the black
X cursor becomes a pointer cursor, but on most things
it stays as the big black X. I did not get that originally,
but now it has come to pass. Another problem is that the
focus of a display is not acting right. If I have
several displays open, I should be able to bring
one to the top by clicking on it, thereby making it
the focus of the mouse cursor, and making that the
display of main focus. This does not work either.
Another problem is that I cannot move a display by
dragging it with the mouse. Any display stays at
the top right of my screen.

Right now I am using fluxbox as my windows manager,
and I am not going to keep fussing with xfce. I really
have not had this trouble with my mouse and other
windows managers. If the problem surfaces with
another manager I will pursue it some more, but
not likely to do so at present.

I have used this mouse on this machine for about 8
to 10 years. I've had at least 3 versions of slackware
and a couple of SUSE on this machine and the only
trouble I have with this mouse is with xfce, at
present, so I find it easier to blame xfce than to
keep looking elsewhere.

I am sitting the problem aside unless it surfaces
with other windows managers.

Right now in fluxbox I am not having any of these
problems.

Last edited by EldonCool; 05-28-2013 at 09:35 PM.
 
Old 05-29-2013, 09:34 AM   #7
EldonCool
Member
 
Registered: Dec 2010
Location: Nevada
Distribution: Slackware
Posts: 86

Original Poster
Rep: Reputation: 0
I looked at the xfce site:
http://www.xfce.org/

The latest version is 4.10 which came out Apr of 2012,
and that is the version I have. This is the version
on my machine, so looks like a new version is not
going to help any.

I will try the suggestions by tronayne, sounds like
some very good info. Will probably check the mouse
installation also like recommended, can't hurt anything.
 
Old 05-29-2013, 01:52 PM   #8
EldonCool
Member
 
Registered: Dec 2010
Location: Nevada
Distribution: Slackware
Posts: 86

Original Poster
Rep: Reputation: 0
troynayne,

I tried this scenario:

rm -r .cache/sessions
startx

It worked just as you said. When the desktop
came up, I had the cursor pointer and it
worked. It would drag a window to another
position and it would change the focus,
any time I clicked on another window, that
one became the window of focus. Now lets
see how long it lasts.


Looking at your thoughts on running gpm with the -R
instead of the -m, I see that gpm is ran two different
places depending on the situation, I assume I should
replace this -m option verbage with the -R option in both
places, like this, Right?
Quote:
if [ "$1" = "stop" ]; then
echo "Stopping gpm..."
/usr/sbin/gpm -k
elif [ "$1" = "restart" ]; then
echo "Restarting gpm..."
/usr/sbin/gpm -k
sleep 1
# /usr/sbin/gpm -m /dev/mouse -t imps2
/usr/sbin/gpm -R msc -m /dev/mouse -t imps2
else # assume $1 = start:
echo "Starting gpm: /usr/sbin/gpm -m /dev/mouse -t imps2"
# /usr/sbin/gpm -m /dev/mouse -t imps2
/usr/sbin/gpm -R msc -m /dev/mouse -t imps2
fi
 
Old 05-29-2013, 03:59 PM   #9
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,993

Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
Well, I didn't suggest the -R option, I use the default configuration in
Code:
cat /etc/rc.d/rc.gpm
#!/bin/sh
# Start/stop/restart the GPM mouse server:

if [ "$1" = "stop" ]; then
  echo "Stopping gpm..."
  /usr/sbin/gpm -k
elif [ "$1" = "restart" ]; then
  echo "Restarting gpm..."
  /usr/sbin/gpm -k
  sleep 1
  /usr/sbin/gpm -m /dev/mouse -t imps2
else # assume $1 = start:
  echo "Starting gpm:  /usr/sbin/gpm -m /dev/mouse -t imps2"
  /usr/sbin/gpm -m /dev/mouse -t imps2
fi
WFM.

The optional section at the bottom of /etc/rc.d/rc.gpm is just that, optional. I wouldn't mess with that unless you have a problem with your mouse.

Everything works if you let it!

Hope this helps some.
 
Old 06-02-2013, 02:34 PM   #10
EldonCool
Member
 
Registered: Dec 2010
Location: Nevada
Distribution: Slackware
Posts: 86

Original Poster
Rep: Reputation: 0
I operated for a couple days with xfce, but it has struck
again. This time I lost my entire display, not just the
mouse cursor. After the computer sat idle for a time,
and was in some sort of screen saver mode, with no output
to the monitor, I tried to get back on. The computer
would not respond to any keyboard, or mouse input.

I had to remove power to get any response. I then rebooted
and went back into linux. I did startx again, and instead
of giving a display of stuff, as usual, I had a blank screen
again. Had to remove power again and reboot.

I ran xwmconfig, and selected fluxbox, and got back on.

I don't think I will be using xfce again.
 
Old 06-12-2013, 02:25 AM   #11
Celyr
Member
 
Registered: Mar 2012
Location: Italy
Distribution: Slackware+Debian
Posts: 314

Rep: Reputation: 77
Try to run a memtest
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crazy jumping mouse cursor after fresh install--did I choose the wrong mouse type? Kallaste Slackware 56 07-08-2012 02:38 PM
Hide mouse cursor/change cursor location? mrjamin Linux - Software 4 09-27-2010 10:09 AM
Mouse cursor disapears with some apps like Netbeans, Google maps, Wine bhaloo Linux - Software 4 09-14-2009 06:56 AM
[Mouse cursor] flicking on animated cursor Creak Debian 1 06-10-2005 02:16 AM
Mouse Disapears on X window Murdock1979 Slackware 3 10-14-2003 12:35 AM


All times are GMT -5. The time now is 05:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration