-   Slackware (
-   -   My First problem with Slackware ( after almost one year as Slacker :D ) (

Alexvader 05-14-2010 09:31 AM

My First problem with Slackware ( after almost one year as Slacker :D )
Hi Forum

Here it goes...

I have Slackware64 <current-from-December-2009> installed in my Lappy... so far so good, never gave me any problems till two days ago...

( But I guess this is not a "Slackware problem" but is more of a "*nix problem" )

Has to do with wireless configuration.

I do not use wicd, because I had to use Python 2.5 because some of the applications I use, need Py 2.5

I connect myself to a wireless AP using :

#ifconfig eth1 up
#iwlist eth1 scan
#iwconfig eth1 essid "My_Essid"
#dhclient eth1...

Then it will output some giberish in console...


Internet Systems Consortium DHCP Client V3.1.2p1
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit

Listening on LPF/eth1/00:21:00:9d:98:c0
Sending on  LPF/eth1/00:21:00:9d:98:c0
Sending on  Socket/fallback
DHCPREQUEST on eth1 to port 67
DHCPREQUEST on eth1 to port 67
DHCPDISCOVER on eth1 to port 67 interval 4
receive_packet failed on eth1: Network is down
DHCPDISCOVER on eth1 to port 67 interval 6
DHCPDISCOVER on eth1 to port 67 interval 6
DHCPDISCOVER on eth1 to port 67 interval 14
DHCPDISCOVER on eth1 to port 67 interval 21

And it WOULD connect, outputing the time of the dhcp lease.

This is what I always did, and It worked.

Last few days I tried this "scheme", and it consistently repots that the network is down and stops trying.

What is strange is that when using a Knoppix LiveCD i can connect to the wireless like I always did...

So my WiFi card is OK...

This seems like some configuration file was left dangling around with incorrect info... how can I fix this thing...?

How can I prevent this from happening again...?

My Only problem with Slackware till now... :D



trumpet_tom 05-14-2010 10:43 AM

What wifi card is that then?

Alexvader 05-14-2010 10:49 AM

Hi Trumpet_tom

Thanks for your reply... :)

This is a Broadcom BCM 4312

But i guess there is no problem with the wl.ko module...

Did not upgrade the glibc, or kernel...

Like I told you... my Slackware is stable since 2009/December...

File/Folder permissions are allright... so <user> did not perform anything illegal, and <root> did not mess with any configuration files...

Until recently... ( about two days ago... ) I could connect...

But then again this DCHPNAK did not show up... I guess it is trying to get a lease from an IP that no longer exists... IMHO... but then again ... what do I know...?

Can this be fixed without having to reinstall...? I'm sure it can... only I do not know how... :(



EDIT : And I don't believe this is hardware related... : Using a Knoppix LCD could connect the same way I always did...

#ifconfig eth1 up
#iwconfig eth1 essid "eduroam-guest"
#dhclient eth1

... and no DHCPNAK thing...

Strange this stuff... :(

marrowsuck 05-14-2010 11:03 AM

You could use dhcpcd instead of dhclient.

Alexvader 05-14-2010 11:10 AM


Kudos for you... :D

Just for the sake of enlightenment... what the heck happened to dhclient and its cofiguration files...?

i mean.. it was alright till before yesterday... :(


trumpet_tom 05-14-2010 11:10 AM

I just found this, it seems to solve the problem.

Give it a go!

I'm guessing you don't want to always be trying to connect to this network? Otherwise I'd say just try putting the network details into the /etc/rc.d/rc.inet1.conf, which might work too.

Other than that maybe consider going for a stable release or the most recent slackware current if possible.

EDIT: didn't realise I had been beaten to it!

All times are GMT -5. The time now is 10:54 PM.