-   Slackware (
-   -   My dog ate my WiFi... (

Habitual 10-03-2012 04:07 PM

My dog ate my WiFi...
OK, but seriously...
I have this card:

03:00.0 Network controller: Broadcom Corporation BCM4321 802.11a/b/g/n (rev 01)
It was working after I followed this posts' suggestion(s) by installing these:

ll -1 /var/log/packages/ | egrep "b43|wicd"
-rw-r--r--  1 root root    2612 Oct  3 12:34 b43-firmware-
-rw-r--r--  1 root root    831 Oct  3 12:34 b43-fwcutter-014-i486-1_SBo
-rw-r--r--  1 root root  13813 Oct  3 12:42 wicd-

and then edited /etc/modprobe.d/b43_blacklist.conf and added:

blacklist b43
blacklist b43legacy
blacklist bcma
blacklist ssb

and rebooted. And it was working. I am not sure how I managed to break it after that. I did a couple of reboots after editing the blacklist, but AFAICT, it only worked after the install and the first reboot...

I installed wicd with

slackpkg install wicd
I have read AlienBob's "Configuring your network in Slackware" where it suggests editing /etc/rc.d/rc.inet1.conf which mine has these relative entries which were added by me after it quit working:


(yes, I have a router and I use ACLs for security and the MAC address is in the allow list)

/etc/udev/rules.d/70-persistent-net.rules | grep wlan0 has these details...

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:16:cf:b4:5c:c3", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
I am pretty sure I ran a dhcpcd command somewhere, but I can't remember the exact command and my root history doesn't show it either.

At no time did I ever run

/var/log/messages has numerous entries such as:

Oct  3 13:05:38 My-KungFu kernel: [ 1228.055189] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Oct  3 13:05:42 My-KungFu kernel: [ 1231.643911] ADDRCONF(NETDEV_UP): wlan0: link is not ready

I removed wicd and re-installed and rebooted. "No wireless networks found" says wicd and "no wireless extensions." says iwconfig.

I'm tired of rebooting :(

Thank you all for your time.

Alien Bob 10-03-2012 04:09 PM

If you want to use WICD then please remove all network configuration from /etc/rc.d/rc,inet1.conf - thr two will conflict. Also, you have to tell WICD the name of your wireless interface - it probably does not yet know that it is "wlan0".


Habitual 10-03-2012 04:12 PM

Thanks Bob. :)

Man, you are quick!

Edit0: Thanks Eric!

Edit1: reboot (sigh)?

FeyFre 10-03-2012 04:34 PM


Edit1: reboot (sigh)?
It is enough to down interface and then restart wicd.

Habitual 10-03-2012 04:42 PM

ifconfig or iwconfig doesn't show any wlan0, still.

I bounced /usr/sbin/wicd anyway. same same.

turtleli 10-03-2012 07:59 PM

If wlan0 does not appear in ifconfig/iwconfig it is unlikely to have anything to do with wicd.

It is a bit unclear which driver you are attempting to use. Are you trying to use b43 or wl? I think wl might be the better driver for your wireless card as this says that b43 only partially supports it.

Just in case, did you try to modprobe whatever driver you are using?

Habitual 10-03-2012 08:29 PM


Originally Posted by turtleli (Post 4796510)
If wlan0 does not appear in ifconfig/iwconfig it is unlikely to have anything to do with wicd...

Well that is good news, sorta. :)


Originally Posted by turtleli (Post 4796510)
....did you try to modprobe whatever driver you are using?

I (ab)used a modprobe earlier, and a dhcpd command that I didn't document.

Eric's page says "/sbin/modprobe 3c59x" but I don't have a 3com card, not sure what to actually use in place of it...I will have to re-read some docs tomorrow and try again.

Thank you for your time.


/sbin/modprobe b43
I'm guessing now I should remove "blacklist b43" from /etc/modprobe.d/b43_blacklist.conf
to survice reboot?

Edit: update from another post....
"If you use the b43-firmware and b43-fwcutter packages do not blacklist anything." says ReaperX7 over here...


Edit: mv /etc/modprobe.d/b43_blacklist.conf to .org and rebooted.
All fixed.

All times are GMT -5. The time now is 01:35 AM.