-   Slackware (
-   -   Mumble on Slackware 14 - disturbing noise instead of voice (

elesmod 11-29-2012 11:56 AM

Mumble on Slackware 14 - disturbing noise instead of voice

I've installed Mumble 1.2.3 from I haven't passed any additional parameters, because according to the info, it's only for G15 keyboard and overlay.
Of course before building Mumble, I've installed the listed dependencies:

ls /var/log/packages/


When I try to speak, the other person hears a loud disturbing noise instead of my voice. When he speaks, I hear a different, but equally disturbing sound.

I think it must be some missing codec on my Slackware because:

  My PC            Other PC
Slackware  <-->    Windows    =  disturbing noise
Windows    <-->    Windows    =  ok
Ubuntu    <-->    Windows    =  ok
Slackware  <-->    Ubuntu    =  ok

As shown, 2 Linux machines work fine, but it's as if Windows and Slackware used different codecs or something.

Oh, and I can record sound just fine with arecord.

mudangel 11-29-2012 07:04 PM

I can't help with your problem, but that sounded pretty cool. Good luck!

kingbeowulf 11-30-2012 03:05 AM

elesmod, You shouldn't need anything else but what you listed. Weird that it only happens between slack and win. I use mumble here on my own murmur server and have had a variety of OS log on without issues. Although I haven't yet updated my game server - still on a slackware32 13.37 - that runs the murmur server. what/whose server are you running?

elesmod 11-30-2012 10:23 AM


Originally Posted by kingbeowulf (Post 4840016)
what/whose server are you running?

My own, also on Slackware 13.37 (32-bit).

kingbeowulf 11-30-2012 09:59 PM

What happens when you use 2 Slackware14 clients with mumble? Anything added other than Alsa (pulsaudio, jack, etc)? 32 or 64 bit? Multilib?

Pretty weird issue.

elesmod 12-01-2012 10:03 AM

I'll have to install Slackware 14 on one of my machines, but I'll have time on monday at the earliest.

I've not installed any other sound servers, and my system is pure 64 bit.

I'll get back to this topic on monday.

bw42 12-02-2012 05:54 PM

I had this same problem. Try this, it worked great for me.

elesmod 12-04-2012 12:16 PM

Ok, I did the Slackware64 14.0 + Slackware32 14.0 test and everything worked fine.
I've also tested the other machine (Slackware32 14.0) with Windows and the same horrible sound could be heard.
Now, all those tests were performed on my Murmur server running on Slackware64 13.37.

Next step was to use my freshly installed Slackware32 14.0 and add Murmur to it, so I could test if maybe it's a server issue. It's not. Same thing happened.
So maybe it's Murmur on Slackware that's acting weird? I've installed Murmur on Ubuntu 12.04. No difference.

After concluding all those tests, it seems that it's not a hardware issue (used 2 slackware machines), and the only situation where I get the disturbing noise is when Slackware wants to speak with Windows (both on my Vista and my brother's Windows 7).

Very weird issue.


Originally Posted by bw42 (Post 4841409)
I had this same problem. Try this, it worked great for me.

This solves the problem, thanks bw42.

However, it's only partially solved. When I followed that tutorial, I could be heard on a Windows computer, but I could hear only the metalic/robotic sound. When Mumble on Windows follows the same tutorial, then I can hear the voice.

I use Mumble mainly to communicate with my brother, so it's not a big deal, since I could easily make him change his Mumble configuration, but what about other people? If my gaming guild used Mumble instead of TeamSpeak, I'd have to convince 50+ people to alter their settings.

Besides, why is Ubuntu, with the same Mumble settings, able to speak to Windows and Slackware not? I'm curious why kingbeowulf's setup works just fine. Can it be a firewall on a router issue? But it doesn't block anything in my LAN.

Argh! I have no idea :(

P.S. I've marked it as solved, although it's not fully solved, so if anyone has other ideas...

kingbeowulf 12-05-2012 02:45 AM

elesmod I said: In the past I had no issues, even when people out of my area used it. My murmur Slackware32 13.37 and mumble on 2 slackware64 14.0 multilib machines was fine, as was WinXP and Win7. However TODAY, the robotic voice distortions started when slackware tries to talk to Windows and vice versa. Sure, normally we mostly use Slackware here, so who knows when it started and whether or not it was due some OS updated somewhere. I tried fiddling with the various settings (jitter, bandwith, packets, TCP vs QoS, etc) to no avail. Weird.

Slackware <--> Slackware OK
Windows <--> Windows OK
Slackware <--> Windows NOT OK

I'll poke around and start a new thread if I come up with a solution.

elesmod 12-05-2012 06:14 AM

Ok, thanks for the info. I'll keep an eye out for that topic of yours in the future :)

All times are GMT -5. The time now is 11:20 PM.