-   Slackware (
-   -   Multiple problems getting virtualbox running (

garyg007 11-08-2008 07:47 PM

Multiple problems getting virtualbox running
I first installed the slackbuild for virtualbox.
Then defined a virtual machine and pointed it to the VBox folder that I had for my opensuse 11 system. When I started the guest (win/xp) and attempted to capture the keyboard and mouse, the mouse froze and the keyboard was un-responsive, both in the xp guest window; only way to recover was to use ctl-alt-esc to kill virtualbox. Mouse remained dead; to recover I had to resort to ctl-alt-f1 and reboot from console.

The slackbuild for virualbox is for the "ose" edition, which does not have USB support and my mouse is a USB mouse (I also have a usb printer and a usb dvd drive). Thinking that was the problem, I removed the "ose" packages and installed the generic binary package from the Sun web site; made sure USB was available and activated the mouse. Then when I tried to start the win/xp wirtual machine, the same problem occured.

((I did see the thread that described the change that needed to be made in /etc/rc.d/rc.S, and made the changes)

Any guidance in resolving this problem would be very much appreciated


TL_CLD 11-09-2008 03:44 PM

I'm puzzled by this. I've just recently started using Virtualbox, and so far I've had no problems at all. Slackware 12.1 as host and Slackware 11, 12 and Windows XP as guests.

What puzzles me is the USB mouse thing. I'm using an USB mouse (Logitech Mx510) and it's working without a hitch.

I've used the Virtualbox scripts.

Have you tried installing the guest anew?


garyg007 11-09-2008 04:34 PM

I have sorted out the mouse/keyboard problems; When the xp virtual machine was defined there were two options on the advanced settings tab - under extended features - that were not selected by default (enable io_apic and enable pae/nx); I enabled both of them and things now appear to work.

Another problem that raised its ugly head was microsofts "activate" crap.
Its not worth the trouble for one application - just going to send it (M$) to the software scrap heap.

if I dont stop here this would turn into a "rant"

Anyway, thank you for the response;


All times are GMT -5. The time now is 06:42 PM.