LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-12-2018, 04:36 AM   #1
dafrasaga
LQ Newbie
 
Registered: Jun 2010
Location: Italy
Distribution: Slackware 13.1 32/64 bit
Posts: 15

Rep: Reputation: 0
multi glib


Hi All,
I have Slack 14.2 and because I want install Gimp from git I need to install glib from git (> 2.55).
Can I install it into /usr/local ??
If yes, what do I do?

Cheers
Gabriele
 
Old 01-12-2018, 05:13 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1 on Lenovo Thinkpad W520
Posts: 8,279

Rep: Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052
I would just download the source tree from -current, then build a new package that would replace the previous one
Code:
lftp -c "mirror http://slackware.uk/slackware/slackware64-current/source/l/glib2/"
cd glib2
wget https://github.com/GNOME/glib/archive/2.55.1.tar.gz
rm *.xz # to remove the previous source archive
su
sh glib2.SlakBuild
upgradepkg /path/to/the/new/package
That's assuming there have been no ABI change, which I didn't check.

Last edited by Didier Spaier; 01-12-2018 at 05:17 AM.
 
Old 01-12-2018, 05:24 AM   #3
dafrasaga
LQ Newbie
 
Registered: Jun 2010
Location: Italy
Distribution: Slackware 13.1 32/64 bit
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Didier Spaier View Post
I would just download the source tree from -current, then build a new package that would replace the previous one
Code:
lftp -c "mirror http://slackware.uk/slackware/slackware64-current/source/l/glib2/"
cd glib2
wget https://github.com/GNOME/glib/archive/2.55.1.tar.gz
rm *.xz # to remove the previous source archive
su
sh glib2.SlakBuild
upgradepkg /path/to/the/new/package
That's assuming there have been no ABI change, which I didn't check.
Hi Didier,
firstly thanks for the response but anothere question: Do the executables which depend from old glib would countinue to work?
Apology me for the question but I do not know a lot about compiling

Cheers
 
Old 01-12-2018, 05:31 AM   #4
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1 on Lenovo Thinkpad W520
Posts: 8,279

Rep: Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052
Quote:
Originally Posted by dafrasaga View Post
Do the executables which depend from old glib would countinue to work?
I assume that they will but am not sure.

If something don't go well, just reinstall the previous package.

You may also check if there has been an ABI change in the ChangeLog. Someone else can know and just tell you.

Last edited by Didier Spaier; 01-12-2018 at 05:33 AM.
 
Old 01-12-2018, 06:31 AM   #5
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1 on Lenovo Thinkpad W520
Posts: 8,279

Rep: Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052
I just checked, gimp-master just requires glib >= 2.54.2 which is already in Slackware-current. What made you think that you need >2.55?
 
Old 01-12-2018, 06:45 AM   #6
dafrasaga
LQ Newbie
 
Registered: Jun 2010
Location: Italy
Distribution: Slackware 13.1 32/64 bit
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Didier Spaier View Post
I just checked, gimp-master just requires glib >= 2.54.2 which is already in Slackware-current. What made you think that you need >2.55?
Hi surely it's a my misunderstood because if I search in git the newest release is 2.55.1 and I tought it would be the last release; but perhaps I do not understand git releases and branches
 
Old 01-12-2018, 06:50 AM   #7
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1 on Lenovo Thinkpad W520
Posts: 8,279

Rep: Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052Reputation: 3052
Quote:
Originally Posted by dafrasaga View Post
Hi surely it's a my misunderstood because if I search in git the newest release is 2.55.1 and I thought it would be the last release; but perhaps I do not understand git releases and branches
I downloaded the last gimp zipped archive from git, ran ./autogen.sh from the root of the unzipped source archive and got this (on Slint 64-4.2.1, binary compatible with Slackware64-14.2):
Code:
Error: GIMP configuration failed.

  - Error: missing dependency babl >= 0.1.38
  - Error: missing dependency gegl-0.3 >= 0.3.27
  - Error: missing dependency glib >= 2.54.2
      *** Test for GLIB failed
  - Error: missing dependency gexiv2 >= 0.10.6
  - Error: missing dependency libmypaint >= 1.3.0
  - Error: missing dependency mypaint-brushes-1.0
  - Error: missing dependency lcms2 >= 2.8
Some work ahead if you really want to build gimp from git.
 
Old 01-12-2018, 06:54 AM   #8
dafrasaga
LQ Newbie
 
Registered: Jun 2010
Location: Italy
Distribution: Slackware 13.1 32/64 bit
Posts: 15

Original Poster
Rep: Reputation: 0
Hi Didier,
I already had upgraded the dependencies but not "glib".
The last is glib.
I think to make as you say me: I replace 2.46 with 2.54/2.55 into /usr

Last edited by dafrasaga; 01-12-2018 at 06:55 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
best practice Multihead, multi-screen, multi-display or multi-monitor-Debian 8 lgtrean Linux - Software 1 10-14-2015 09:53 AM
[SOLVED] i installed glib from source on debian but atk configure still see old ver of glib skinney Linux From Scratch 3 05-13-2013 01:18 AM
i installed glib from source on debian but atk configure still see old ver of glib skinney Debian 3 05-12-2013 03:36 PM
[SOLVED] what's the difference between a multi-cpu , multi-core and a multi-thread system ? entz Linux - Hardware 11 12-20-2011 04:49 PM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration