-   Slackware (
-   -   Multi-Boot install, Kernel panic, Lilo problem (

ghostrider.002 05-28-2007 09:33 PM

Multi-Boot install, Kernel panic, Lilo problem
Hell once again
I have 2 problems

I have a Tri-boot setup. hda = Windows, hdb = opensuse, sda = slackware 11
boot loader = Lilo
previously I had just a dual boot with windows and suse, i added a Sata hdd and installed slackware and after i installed it i rebooted and i have the following errors.

1. I rebooted after a fresh install on a sata hdd and it states:
kmod: failed to exec /sbin/modprobe -s -k block-major-8, errno = 2
VFS: Cannot open root device "801" or "08:01
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:01

2. When Lilo menu comes up it only lists 2 boot options:
1. Windows
2. Linux

Now I am going to remove suse but i still have a little more data on it.
Should I just disconnect the Sata (Slack) hdd and boot suse and finish there then remove that drive and reattach the Sata (Slack) hdd and reboot?


thloh85 05-28-2007 09:43 PM

I don't really understand your question 1.
For question 2, you can always add a boot option for your unix(linux).
Just put in the title, root, etc. in your /boot/grub/menu.lst(might be different for you, look for the menu.lst file, its the GRUB bootloader configuration file) and you're ready to go... Google for it if you don't know how...

ghostrider.002 05-28-2007 09:55 PM

I should have the two questions reversed.

For the Lilo problem I thought that I would have 3 entries in the Lilo boot menu, (windows, suse, slack) but it only has 2 entries. And I just wondered why i didnt, normally it would auto detect all OS's. the install detected them but i dont think Lilo did. I was running grub but slack installs lilo. I also installed Lilo in the MBR (option 3 of the installer).

As for the errors, i get then after i select the Linux boot option, I believe it is called verbose mode when everything scrolls up on the screen as Linux is booting. it posted the last 4 lines then it goes into kernel panic and locks up the pc.

H_TeXMeX_H 05-28-2007 09:59 PM

Which kernel are you using ? and which filesystem ?

You'll probably have to edit '/etc/lilo.conf' manually and add opensuse, then run 'lilo'.

You could also use a live CD, as I hear you'll soon get rid of opensuse anyway, no need to bother getting it to boot this way.

ghostrider.002 05-28-2007 10:38 PM

Yes I am getting rid of suse. As a matter of fact I disconnected the suse drive all together.

I have hda = windows
sda = slack

upon rebooting after disconnecting the suse hdd, i still get the 4 errors/panic listed in the first post.

as for the kernel i used test26.s to install with. but if i boot into the slack live cd what command can i use to verify this with?

File system is type ext3, if i remember correctly when i ran cfdisk i choose 83.

Should I just reinstall? I rather not have to if at all possible.

H_TeXMeX_H 05-28-2007 10:49 PM

It might be something wrong in lilo.conf ... I mean:

"hda = Windows, hdb = opensuse, sda = slackware 11"

Maybe the one for slackware says hda instead of sda ?

You could use a live cd, go in there and make sure it is right, then chroot into there and run '/sbin/lilo'.

ghostrider.002 05-28-2007 10:53 PM

ok, I am going to try the live cd route and post back.\


ghostrider.002 05-29-2007 02:01 AM

Fixed. unfortuniatly I did a reinstall and it works. Thanks for the help

All times are GMT -5. The time now is 04:03 PM.