-   Slackware (
-   -   mtp support on slackware64 13.37 (

lpallard 11-04-2012 07:10 PM

mtp support on slackware64 13.37
Hi all! So I have been trying to circumvent Samsumg's roadblocks (or google?) from removing the USB mass storage mode that was SO simple and easy to use, and somehow transfering mp3's from & to my Galaxy S3 has been problematic..

First the way to do it seems to install and use mtpfs on my slack64 13.37 machine. I have found & installed the packages from, but gMTP is not available... I wonder why..

Then searching on Google for a slackbuild script for gMTP returned nothing. Only a person who prepared the packages but for Slack64 14 ( I tried to use the gMTP package but it spits some errors and doesnt start. Not surprising since this package was compiled for Slack64 14.

Finally, using


mtpfs mountpoint
I can see the phone's content in Thunar, but its chaotic at best. It seems the Slackware system (or the phone) dont know how to present the files and I get a listing as if all the files & folders that are on the phone (both the internal RAM & the SD card) were the same media, and everything is empty... Its not usable.

I gave Amarok & Clementine a shot as well, to no avail.

There must be a way to sync mp3 files in Slack??? Where can I find a package (or a slackbuild script) for gMTP running on Slack64 13.37

I'm all listening!!


Mark Pettit 11-05-2012 01:37 AM

Under 14.0, I managed to get this working - but it required downloading the VERY latest versions of libmtp, and using the slackbuild in the 14.0 sources. However, since doing that (and maybe it's just a coincidence), I've noticed a few "funnies" pop up on my machine. BTW - I suspect google did this because of issues with the USB mass storage when accessing your SD card. Any apps using the card at the time must be stopped (ie killed). Personally I think they should have offered it as an option. I got my Galaxy s3 on Friday, and by Sunday evening had CyanogenMod 10 on it - but that too appears not to have the USB mass storage option anymore.

Mark Pettit 11-05-2012 01:39 AM

Oh - almost forgot ! I run sshdroid on my phone. That allows you to use sshfs or sftp to send files wirelessly. This is far easier to setup - especially if your phone is rooted (altho' that's not an absolute requirement).

lpallard 11-05-2012 07:42 AM

Tried sshDroid, I am getting:

bash: sftp://root@ No such file or directory
Any idea why??

Mark Pettit 11-05-2012 11:34 AM

sftp is a command. Try it like this :
sftp root@ and then the password is normally 'admin'.

Personally I prefer using sshfs. So, if you've installed sshfs_fuse, it goes like this:
(assuming you have an empty subdir called /tmp/myphone :

sshfs root@ /tmp/myphone
(then enter the password).

After this you simply navigate to /tmp/myphone and you'll be in the root of the phone device.

And, related to my earlier post, I have definitely discovered that simply installing the latest version of libmtp from the official adjusted slackbuild is a BAD idea. It was definitely the cause of USB mount, printing and bluetooth problems (possibly more too). Once I went back to the official slackbuild from the DVD, all came back right (after a reboot).

ponce 11-05-2012 01:13 PM

hoping that can be useful, for these kind of tasks I find airdroid very handy.

escaflown 11-05-2012 08:52 PM


Originally Posted by ponce (Post 4822772)
hoping that can be useful, for these kind of tasks I find airdroid very handy.

Thanks Ponce! That's indeed a great app.

smoooth103 11-05-2012 09:54 PM

I also tried to use gMTP with a little success but then realized it's just as easy to use a free wifi transfer program. gMTP had problems finding my galaxy s3 device but I think if I'd troubleshot a a little more it would have worked. It's so much easier to just use a wifi file transfer program.

All times are GMT -5. The time now is 11:03 PM.