LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-02-2011, 11:58 AM   #1
beder
Member
 
Registered: Apr 2011
Posts: 82

Rep: Reputation: 28
mplayer shows question marks for some characters on subtitle, works fine on xine


Hi,

I've been using mplayer to play videos with subtitles, and some characters appear as a question mark, but some others work.
The character "" for example, is a question mark, but the character "" appears just fine.
If I play the same file and same subtitle using xine, all characters appear correctly.

Some relevant information
Encoding of the subtitle file:
Code:
felipe@felipe:~/series/HTBAG$ file How.To.Be.a.Gentleman.S01E01.HDTV.XviD-LOL.srt
How.To.Be.a.Gentleman.S01E01.HDTV.XviD-LOL.srt: ISO-8859 text, with CRLF line terminators
A command I already tried to load mplayer, but with same result:
Code:
mplayer How.To.Be.a.Gentleman.S01E01.HDTV.XviD-LOL.avi -subfont-encoding iso-8859-1
Using gmplayer also brings the same issue.

Slackware 13.37 under KDE 4.7.1, but I also tried running on the console without X

Thank you in advance, Felipe Weber.

Last edited by beder; 10-02-2011 at 12:00 PM.
 
Old 10-02-2011, 12:03 PM   #2
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 7,567

Rep: Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914Reputation: 2914
Try putting following in ~/.mplayer/config:

Code:
ass=true
embeddedfonts=true
 
Old 10-02-2011, 12:19 PM   #3
beder
Member
 
Registered: Apr 2011
Posts: 82

Original Poster
Rep: Reputation: 28
Quote:
Originally Posted by dugan View Post
Try putting following in ~/.mplayer/config:

Code:
ass=true
embeddedfonts=true
Thank you for your response

I should have mentioned on my first post that I also tried using -ass without success. It does make a difference on the font size and color (it's prettier), but some characters still are a question mark

Anyhow I added those parameters to ~/.mplayer/config , still the same results

I have a wild guess that it might have something to do with the font that mplayer is using, but I was unable to load a custom font... I tired copying wendings from my windows/Fonts and load it with -subfont (just to check if it would work, after trying to load other fonts) but this seems to be ignored

Thanks, Felipe Weber.

Last edited by beder; 10-02-2011 at 12:22 PM.
 
Old 10-03-2011, 11:10 AM   #4
alekow
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 138

Rep: Reputation: 19
Maybe you should try some windoze charaset? For eastern european fonts i use cp1250. Don't know which is the best for you.
 
Old 10-04-2011, 06:25 PM   #5
beder
Member
 
Registered: Apr 2011
Posts: 82

Original Poster
Rep: Reputation: 28
Solved by using -subcp latin1

Thank you all
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[g]xine distorts video; mplayer works fine quiescere Slackware 2 03-30-2008 03:11 PM
mplayer subtitle question... sinanakdas Linux - Software 4 05-07-2007 04:38 PM
Kaffeine segfaults but xine works fine... daihard Linux - Software 1 11-07-2006 09:41 AM
In Kubuntu I have compiled MPlayer and it works fine, MPlayer Plug-in is not working kickass331 Linux - Newbie 10 08-11-2006 09:12 PM
Mplayer subtitle question tangle Linux - Software 4 07-28-2005 09:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration