LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-17-2005, 05:26 PM   #1
mustangfanatic01
Member
 
Registered: Jul 2005
Location: California
Distribution: Slackware 11.0, Fedora Core 5
Posts: 80

Rep: Reputation: 15
mplayer installed, but doesn't open


It's a library issue. I've run across it before but got it working. This time I can't seem to fix it.

ermcgrat@Slackware:~$ gmplayer
gmplayer: error while loading shared libraries: libdv.so.4: cannot open shared object file: No such file or directory

I went to sourceforge and got libdv-0.104 but after installing that I am left with the same error. Oh and I used installpkg to install Mplayer. I know this is probably a very easy fix, can anyone help?

Also on a side note, I installed xmms but it will not play streaming music from say Digitally Imported, while xine does; any ideas on that?

Much thanks in advance.

I've just come from Fedora Core 4 which I really liked, but I must say Slackware 10.2 has been very painless thus far.
 
Old 11-17-2005, 05:45 PM   #2
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,325

Rep: Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757
You'd better install first the mplayer codecs package from mplayer site,
then compile and install mplayer from source, the compilation is
prefered method as it will optimize mplayer for your hardware and
it will add correctly codecs support (the codecs have to be installed first)
 
Old 11-17-2005, 06:16 PM   #3
mustangfanatic01
Member
 
Registered: Jul 2005
Location: California
Distribution: Slackware 11.0, Fedora Core 5
Posts: 80

Original Poster
Rep: Reputation: 15
I installed the codecs first, went successfully too.
 
Old 11-17-2005, 06:20 PM   #4
Dankles
Member
 
Registered: May 2004
Location: /dev/null
Distribution: Slackware
Posts: 245

Rep: Reputation: 31
Quote:
Originally posted by keefaz
You'd better install first the mplayer codecs package from mplayer site,
then compile and install mplayer from source, the compilation is
prefered method as it will optimize mplayer for your hardware and
it will add correctly codecs support (the codecs have to be installed first)
I agree, but one thing you might want to do when you compile from source is to do this:
download a utility called checkinstall http://asic-linux.com.mx/~izto/checkinstall/
# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var (Slackware seems to like this setup)
# make
# checkinstall (this will build a slackware package for you rather than installing it)
installpkg package.tgz

this is what i do with 90% of my packages
I hate having to make my own build scripts.

Last edited by Dankles; 11-17-2005 at 06:29 PM.
 
Old 11-17-2005, 06:40 PM   #5
mustangfanatic01
Member
 
Registered: Jul 2005
Location: California
Distribution: Slackware 11.0, Fedora Core 5
Posts: 80

Original Poster
Rep: Reputation: 15
I'm going to try Dankle's method next I guess, but I think I'm getting closer. I decided to start over again. First, I obtained the ALL codecs package from Mplayer's site and extracted the contents to /usr/local/lib/codecs/ as specified in the README. Next I recompiled Mplayer. Now when I execute "gmplayer" I get

gmplayer: error while loading shared libraries: libtheora.so.0: cannot open shared object file: No such file or directory

Similar error, different number. I don't understand what I'm doing wrong.

To dankle's post : Unknown parameter: --sysconfdir=/etc

Silly Mplayer just doesn't want to work :X

Last edited by mustangfanatic01; 11-17-2005 at 06:46 PM.
 
Old 11-17-2005, 07:17 PM   #6
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,325

Rep: Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757
Maybe you have now 2 gmplayer, could you check ?

/usr/bin/gmplayer
/usr/local/bin/gmplayer

(if you have both, try both, one of them must work)

Out of this idea, I can't see why it links mplayer with libtheora or libdv, mine
is not linked with those libs...
 
Old 11-17-2005, 07:58 PM   #7
mustangfanatic01
Member
 
Registered: Jul 2005
Location: California
Distribution: Slackware 11.0, Fedora Core 5
Posts: 80

Original Poster
Rep: Reputation: 15
ermcgrat@Slackware:~$ /usr/bin/gmplayer
/usr/bin/gmplayer: error while loading shared libraries: libtheora.so.0: cannot open shared object file: No such file or directory
ermcgrat@Slackware:~$ /usr/local/bin/gmplayer
-bash: /usr/local/bin/gmplayer: No such file or directory
ermcgrat@Slackware:~$


Guess I only have 1.
 
Old 11-17-2005, 08:14 PM   #8
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,325

Rep: Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757
Do you have libtheora and libdv in your machine ?

What are the outputs with
Code:
locate libtheora.so
locate libdv.so
 
Old 11-17-2005, 08:58 PM   #9
mustangfanatic01
Member
 
Registered: Jul 2005
Location: California
Distribution: Slackware 11.0, Fedora Core 5
Posts: 80

Original Poster
Rep: Reputation: 15
ermcgrat@Slackware:~$ locate libdv.so
ermcgrat@Slackware:~$ locate libtheora.so
ermcgrat@Slackware:~$

I guess I installed libdv wrong then or what? I found the source and compiled it as I found some other forum explaining.
 
Old 11-17-2005, 09:40 PM   #10
cynical
LQ Newbie
 
Registered: Nov 2005
Posts: 10

Rep: Reputation: 0
Quote:
Originally posted by mustangfanatic01
ermcgrat@Slackware:~$ locate libdv.so
ermcgrat@Slackware:~$ locate libtheora.so
ermcgrat@Slackware:~$

I guess I installed libdv wrong then or what? I found the source and compiled it as I found some other forum explaining.
Keep in mind that the locate command depends on updatedb having been run since the new files were placed on the filesystem.

As root, run updatedb, leave it alone until the prompt appears then try the locate commands.

IIRC, in the later releases of slackware, Patrick seemed to have forgotten to make the locate.db file, or didn't put it in the crontab.

Try ls /usr/local/lib/libdv.* and ls /usr/local/lib/libtheora.* and see what you get. If those ls commands come up blank, I would guess the make install placed them in a different directory or they are not installed.

You did remember to run ldconfig after installing the new libs, right?
 
Old 11-17-2005, 11:37 PM   #11
mustangfanatic01
Member
 
Registered: Jul 2005
Location: California
Distribution: Slackware 11.0, Fedora Core 5
Posts: 80

Original Poster
Rep: Reputation: 15
I have never seen ldconfig before honestly. Now it seems those 2 libraries are in place and now I get the following error:

root@Slackware:/home/ermcgrat# gmplayer
gmplayer: error while loading shared libraries: libdivxdecore.so.0: cannot open shared object file: No such file or directory
root@Slackware:/home/ermcgrat#

Divx related, so does this mean I somehow didn't install the codecs properly before the compile of mplayer? If any of you kind people could walk me through the process to make sure I didn't do something stupid it would be greatly appreciated.
 
Old 11-17-2005, 11:45 PM   #12
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 52
If you got the package from linuxpackages.net check the package's description there, sometimes it tells you the dependencies, and mostly, the dependencies needed are on linuxpackages.net too.
 
Old 11-18-2005, 12:05 AM   #13
mustangfanatic01
Member
 
Registered: Jul 2005
Location: California
Distribution: Slackware 11.0, Fedora Core 5
Posts: 80

Original Poster
Rep: Reputation: 15
Well I started over from scratch but this time I placed the files in a different directory and specified the directory in the ./configure. Now MPlayer works but there is no gmplayer. Ah well, one step at a time I guess. So if anyone else has this problem; specifically state the location of the codecs, despite the readme telling you what the default is.
 
Old 11-18-2005, 01:46 AM   #14
Fluxx
Member
 
Registered: Aug 2005
Location: Bavaria, Germany
Distribution: Slackware (Current)
Posts: 225

Rep: Reputation: 30
MPlayer-1.0pre7 searches the codecs in

1. /usr/local/lib/codecs and otherwise in
2. /usr/lib/win32

Both work when you compile MPlayer.

If you use 2. gxine, xine and totem will find the codecs at once without changing the configfiles.

To have gmplayer you should enable

Code:
./configure --enable-gui
while compiling MPlayer. Other useful options are

Code:
./configure --disable-debug --disable-runtime-cpudetection --language=your_language
For your language you choose the letters out of your locale (for English en, for German de and so on).

With these options (g)mplayer should work/run very fast and with little CPU usage.

Fluxx.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
installed open office from linuxpackages.net, don't know how to open it salviadud Slackware 7 04-15-2005 10:28 AM
mplayer installed but problems bloodfulldesire Linux - Newbie 2 02-09-2005 09:43 PM
Can't open up mplayer JunZ Mandriva 17 06-05-2004 12:27 PM
Mplayer Installed.. now for running it.. sxa Linux - Software 16 12-30-2003 10:56 PM
mplayer open gl cyrille Linux - General 9 05-28-2002 05:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration