LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-02-2017, 12:50 AM   #1
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,044

Rep: Reputation: 150Reputation: 150
mozilla-firefox package name and content mismatch


The mozilla-firefox esr packages actually contain non-esr versions. I guess they, e.g. firefox-52.0.2 and firefox-52.0.2esr, are essentially the same software but only with different version strings, so everything works ok except when installing xpi files that check the version, where the xpi files for non-esr versions must be installed even though the slackware package is named mozilla-firefox esr.

So, could the mozilla-firefox esr packages be renamed to non-esr to avoid potential confusion?
 
Old 04-03-2017, 04:16 AM   #2
Keruskerfuerst
Senior Member
 
Registered: Oct 2005
Location: Horgau, Germany
Distribution: Kubuntu 18.04, Manjaro, Win 10
Posts: 2,192

Rep: Reputation: 164Reputation: 164
The esr and non-esr versions are different.
 
Old 04-03-2017, 06:25 AM   #3
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,044

Original Poster
Rep: Reputation: 150Reputation: 150
Quote:
Originally Posted by Keruskerfuerst View Post
The esr and non-esr versions are different.
O really? Didn't know that.

Anyway, it's confusing that I had no problem when using a firefox 52.0.1esr compiled by myself. Only when using slackware's official firefox esr packages (also before, not only 52.0.2), the xpi language packs for esr from mozilla don't work. Using the xpi file for the corresponding non-esr version works, e.g. using the official language pack for firefox-52.0.2 on slackware's firefox-52.0.2esr works.
 
Old 05-28-2017, 12:15 PM   #4
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,044

Original Poster
Rep: Reputation: 150Reputation: 150
For the latest firefox (esr 52.1.2) package for slackware64-14.2, still the xpi language pack for non-esr must be used. If the xpi language pack for 52.1.2esr is installed, the user interface stays in en_US.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Mozilla Firefox Web Browser to Be Available as a Snap Package for Ubuntu 16.04 LXer Syndicated Linux News 0 04-21-2016 09:53 PM
Firefox dynamic content problems, and how to uninstall Firefox in Ubuntu rose_bud4201 Linux - Software 1 11-05-2007 10:38 PM
LXer: Mozilla Thunderbird to Find New Home as Mozilla Foundation Focuses on Mozilla Firefox LXer Syndicated Linux News 0 07-27-2007 09:16 AM
LXer: Mozilla Corporation Signs Mozilla Firefox Distribution Deal with RealNetworks LXer Syndicated Linux News 0 08-03-2006 03:21 PM
Mozilla/Firefox streaming content problems. lcbest Linux - Software 2 11-14-2005 08:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration