-   Slackware (
-   -   Mozilla Firefox and Flash Player issues (

w1k0 03-04-2011 12:46 PM

Mozilla Firefox and Flash Player issues
1 Attachment(s)
In that thread: YouTube videos are playing in black and white piratesmack, gezley and andrew.46 reported the problem concerning YouTube videos as well as described the solution. Unfortunately that solution doesn’t work for me.

I use Slackware 13.1 on ThinkPad X60s. Recently I updated Mozilla Firefox to 3.6.14 as well as Flash Player to 10.2_d151 version. I updated Firefox using slackpkg and Flash using packages provided by

Since that upgrade Firefox displays YouTube videos in red and yellow with oversized magenta shadows. I tried the solution suggested by gezley: I found some videos on the other sites and I tried to switch off “Enable hardware acceleration” option in Flash Player’s “Settings...” context menu. Unfortunately in my case I can see small window including that option but the window doesn’t respond to mouse clicks. “Enable hardware acceleration” option, a few tabs and “Close” button are all dead.

The same problem with YouTube videos appears in Opera so it isn't Firefox issue.

I switched off NoScript, Flashblock and Adblock Plus add-ons. Despite of that on most sites Flash Player’s “Settings...” context menu is unavailable. When it’s available Flash Player’s setting window is dead so I can’t switch off “Enable hardware acceleration” option.

Every help will be appreciated.


This is sample YouTube video screenshot displayed by Opera:

Attachment 6321

The whole movie is here:


The above problem is solved partially in sixth post.

The below problem is solved partially in seventh post.


I just observed a new interesting effect. When I opened that picture my graphic card covered all the screen with vertical brown lines: exactly 96 lines covering browser window and surrounding space including some dockable applications. Additionally it colored blue bold text on site into brown and reversed black text into white. Switching to another virtual console and coming back restored original colors.

To find the above picture on the main site is enough to find “APS” string and to click in “Muestras: 12 MP” frame below the middle thumbnail in the top row.

w1k0 03-04-2011 06:38 PM

2 Attachment(s)
I did the test using that picture.

To find the above picture on the main site is enough to find “EXR” string and to click in “Muestras: 12 MP” frame below the right thumbnail in the top row.

When I clicked the thumbnail on the mentioned above main site I saw such image:

Attachment 6319

Apart of the stripes on the photo there are some interferences on the third from top dockable application on the left side.

When I clicked that picture to zoom it and clicked it once again to fit it to the browser window the picture looked well but I noticed the other problems:

Attachment 6320

In the above case Firefox displays instead of it’s icons some brown or black-brown squares. There are also some interferences on the dockable application in the top row: the fifth, the seventh, the eight and the ninth as well as on the dockable application on the bottom on the right side.

These problems don’t disappear after the switching to the another console and coming back as I described it in the edited paragraph in the above post.

allend 03-05-2011 06:23 AM

All I can say is that I have no problems using Firefox 3.6.14 and flashplayer 10.2 r152. Youtube works fine and "that picture" displays correctly.
When I try to look at your Attachment 6313 and 6314 I get a message about invalid attachments.

w1k0 03-05-2011 11:14 AM

I cleared browser’s cache and my attachments disappeared so I uploaded them once again. Now everything should work well.

As for the picture I used for the test in my second post it’s regular JPG file so it isn’t strange it doesn’t cause problems in your case. It’s strange it causes problems in my case.

So I have two types of problems: first concerning Flash Player videos and second concerning displaying images in Mozilla Firefox.

Woodsman 03-05-2011 11:37 AM

I saw this today:

I don't know if the problem is related or will help. :)

w1k0 03-05-2011 04:17 PM

Thank you Woodsman for a valuable link. I tried described there possible fix 1 in Mozilla Firefox and Google Chrome. In both cases it solved the problem concerning YouTube videos. Unfortunately I can’t find similar option in Opera which works bad with YouTube videos too. As for Konqueror it works well with YouTube videos without fixing though I noticed strange problem concerning – when I open main page in Konqueror the application frequently refuses to response so I have to kill it and start once again.

The descriptions on the mentioned site aren’t precise so I proofread them:

Firefox: To block the YouTube cookies go to “Edit | Preferences” menu, on the “Privacy” tab in the “History” section set “Firefox will:” option to “Use custom settings for history”, then on the right of “Accept cookies from sites” click “Exceptions...” button, next in “Address of web site:” enter “” (or the YouTube domain for your country if you do not use, then click “Block” button and finally click twice “Close” button.

Chrome/Chromium: To block the YouTube cookies go to “Preferences” menu, on the “Under the Hood” tab in “Privacy” section click “Content settings...” button, select “Cookies” option and click “Exceptions...” button, then click “Add...” button, in “Pattern:” field enter “” (or the YouTube domain for your country if you do not use, on the right of “Action:” option select “Block” and click “OK” button, finally click three times “Close” button.

The problem concerning YouTube videos is solved for Firefox and Chrome but unsolved for Opera. The problem concerning Mozilla Firefox and JPG images persists.

w1k0 03-05-2011 05:07 PM

I upgraded Mozilla Firefox to the version 3.6.15 available here and Flash Player to the Incubator Debug Installer 022711 version available here.

Updated Flash Player works well with YouTube videos in Firefox and Opera. As for Chrome it still requires cookies blocking as I described it in the above post.

Updated Mozilla Firefox displays images bad after first click but after zoom in and zoom out the picture is all right. New Firefox still spoils its own icons but usually doesn’t spoil desktop’s elements.

The problems aren’t solved completely but I can live with that. Thank you guys once again for your assistance.

devnull10 03-10-2011 12:53 PM

I know this has been solved but I'll just post my experiences here too for future reference. I had issues in you-tube whereby I could play a video fine but then when I tried to play the next one, flash player crashed (came up saying send crash report etc). clicking refresh then allowed me to play the video but it would then crash again on the next video I tried playing.

Anyway, as per other thread suggestions I went to nvidia site and chose settings and disabled hardware acceleration. All working fine now! :)

w1k0 03-10-2011 03:04 PM

Thank you for that information. I encountered the same problem with Slackware 13.1 and former versions of Mozilla Firefox. It seems the problem disappeared with newer versions of that program including 3.6.15.

w1k0 03-14-2011 08:27 AM

I tested the pictures mentioned at the end of the first post and in the second post on the other ThinkPad X60s machine and I observed the same results as described above so it seems there is some problem concerning X60s' Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller and i915 Linux kernel module.

All times are GMT -5. The time now is 09:30 AM.