-   Slackware (
-   -   moving root / partition on Slack 10.0 (

mrhide 04-05-2005 12:45 PM

moving root / partition on Slack 10.0
Hi guys I'm having a strange problem on my slack...
I moved my root partition from /dev/hda1 to /dev/hda4
I fixed lilo, fstab ecc...
I've tried to boot from the new one and everything appeared to seem fine but...
that was the first impression!!!
Infact have a look to the output:
root@cerberus:~# fdisk /dev/hda
Disk /dev/hda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Device Boot Start End Blocks Id System
/dev/hda1 * 1 623 5004216 83 Linux
/dev/hda2 624 3114 20008957+ 83 Linux
/dev/hda3 3115 3177 506047+ 82 Linux swap
/dev/hda4 3178 4864 13550827+ 83 Linux

root@cerberus:~# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/hda4 4.7G 4.3G 117M 98% /
/dev/hda1 4.7G 4.3G 117M 98% /mnt/hda1

As you can see fdisk can detect properly the disk size (40G) while
df -h gives me the same size as the original partition where / was installed

I've tried to boot from a live cd and output of df -h was correct...
I do not know how to fix the problem... I' ve tried to reboot,use resize2fs,rewriting the partition table with the same values,dancing around the pc with one leg launching spells but nothing changed...
Any idea?!

To move the partition I used
tar cvzf slack10backup.tgz bin/ etc/ lib/ mnt/ opt/ root/ sys/ usr/ boot/ dev/ home/ ecc...
from a suselivecd...

Have a nice day, I' m really sorry for my english grammar and spelling mistakes but as you may guess I'm not english native speaker...
Thank you!

egag 04-05-2005 03:08 PM

maybe the --sync option can help here.

df --sync -h

just a thought.


mrhide 04-06-2005 08:15 AM

No way!!!
I cannot believe I have to reinstall all to fix the problem...
Maybe there is a file around /etc where slack recorded the values of the partition table during the installation process...but I do not find which one!
Moreover is very strange that the size is exactly the same as the original partition in which the /
was installed...


I can not even google to find an answer because I do not know how to call this problem! Disk geometry? Disk size?Drunk partitions ? Any idea ?

Thank You!

keefaz 04-06-2005 11:21 AM

Could you post the output with :

cat /proc/partitions
cat /proc/mounts

All times are GMT -5. The time now is 11:16 AM.