LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-13-2018, 08:40 AM   #1
ProzacR
LQ Newbie
 
Registered: Jan 2006
Distribution: Slackware, Fedora
Posts: 28

Rep: Reputation: 2
Moving from lilo to grub


I am very sad about my lilo it seems, broken and simply typing liloconf or lilo does not fix that. I see only L and buch of 99 during boot. How I can move to grub on existing system without reinstall?
Or maybe some ideas how can I fix that lilo issue?
 
Old 05-13-2018, 08:42 AM   #2
RandomTroll
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 891

Rep: Reputation: 145Reputation: 145
I use lilo on my computer, maintain a server that uses grub. I prefer lilo. Capture lilo & liloconf output then post here. You may have a problem that switching to grub won't fix.
 
1 members found this post helpful.
Old 05-13-2018, 08:52 AM   #3
ProzacR
LQ Newbie
 
Registered: Jan 2006
Distribution: Slackware, Fedora
Posts: 28

Original Poster
Rep: Reputation: 2
OK here it is, all output:
https://pastebin.com/vHAwmTCV
 
Old 05-13-2018, 09:26 AM   #4
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 1,867

Rep: Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765
I'm going to make what may seem a radical suggestion - Stop relying on automated configuration and actually learn to take manual control... and while I'm at it, trust me, grub's OSprober is even a bigger mess to foul you up. I'm not at all sure why "cat /etc/lilo.conf" shows two different results so what's up with that?

Unless the only OpSys you have is Windows your lilo config (/etc/lilo.conf <eitherone>) has no other OpSys listed at least for what I can see. Lilo is failing because of the following entry

Code:
 # Start LILO global section
boot = /dev/sda3
That installs lilo to that partition which will only boot IF you have some bootloader installed to MBR that will recognize and point to/hand off to /dev/sda3, or if you use UEFI boot and elilo or grub, though I avoid grub whenever possible so obviously I wouldn't do that and recommend you don't either unless there seems no other alternative. Grub, especially Grub2 will NOT make things easier for you. It can do a few things lilo cannot but it is a royal pain to get it to do exactly what you want and nothing you don't want.

To fix your lilo.conf manually edit it to install it to "/dev/sda" instead on sda3 as in the above quoted line, then use an "other" entry for Windows (I'm assuming /dev/sda3) and a full entry for partition and kernel , initrd if you use one, etc for your Slackware boot.

LILO is simple exactly because all it has to do is one thing - boot an active OpSys or several, including any variations one might have say for different kernels and/or other options with Linux. Simple is good.
 
2 members found this post helpful.
Old 05-13-2018, 09:58 AM   #5
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 2,973

Rep: Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346
It's easy to get grub and grub2 to do what you want since you can use the interactive ability to determine the proper entries for the configuration file.

You know, manual control.
 
Old 05-13-2018, 10:09 AM   #6
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 1,867

Rep: Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765
Quote:
Originally Posted by Richard Cranium View Post
It's easy to get grub and grub2 to do what you want since you can use the interactive ability to determine the proper entries for the configuration file.

You know, manual control.
Yeah on the few distros I've tried that all but demand Grub2 I disable OSprober and take control but it is substantially more complex at no significant advantage for me. If you have some benefit to mention that I'm possibly missing out on, please do share. Currently, for me and many others Grub2 just doesn't hold up in a cost/benefit comparison. Possibly this is because LILO was designed originally for manual control while Grub was designed from the start to "help out". I have no use for butlers that get underfoot.
 
1 members found this post helpful.
Old 05-13-2018, 10:38 AM   #7
ProzacR
LQ Newbie
 
Registered: Jan 2006
Distribution: Slackware, Fedora
Posts: 28

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by enorbet View Post
I'm going to make what may seem a radical suggestion - Stop relying on automated configuration and actually learn to take manual control... and while I'm at it, trust me, grub's OSprober is even a bigger mess to foul you up. I'm not at all sure why "cat /etc/lilo.conf" shows two different results so what's up with that?

Unless the only OpSys you have is Windows your lilo config (/etc/lilo.conf <eitherone>) has no other OpSys listed at least for what I can see. Lilo is failing because of the following entry

Code:
 # Start LILO global section
boot = /dev/sda3
That installs lilo to that partition which will only boot IF you have some bootloader installed to MBR that will recognize and point to/hand off to /dev/sda3, or if you use UEFI boot and elilo or grub, though I avoid grub whenever possible so obviously I wouldn't do that and recommend you don't either unless there seems no other alternative. Grub, especially Grub2 will NOT make things easier for you. It can do a few things lilo cannot but it is a royal pain to get it to do exactly what you want and nothing you don't want.

To fix your lilo.conf manually edit it to install it to "/dev/sda" instead on sda3 as in the above quoted line, then use an "other" entry for Windows (I'm assuming /dev/sda3) and a full entry for partition and kernel , initrd if you use one, etc for your Slackware boot.

LILO is simple exactly because all it has to do is one thing - boot an active OpSys or several, including any variations one might have say for different kernels and/or other options with Linux. Simple is good.
Still same error with:
Code:
boot = /dev/sda
 
Old 05-13-2018, 11:02 AM   #8
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 4,006
Blog Entries: 1

Rep: Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287
Then something is wrong.
As enorbet has ponted out, the first 5 lines of your /etc/lilo.conf file should read,

Quote:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/sda
That is, if you properly installed lilo to the master boot record.

The last section might read something like this, depending on your setup:

Quote:
# Linux bootable partition config begins
image = /boot/vmlinuz-generic-4.16.8
initrd = /boot/initrd.gz
root = /dev/sda1
label = kernel-4.16.8
read-only # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Linux Kernel 4.14.38 bootable config begins
image = /boot/vmlinuz-huge-4.14.38
root = /dev/sda1
label = kernel-4.14.38
read-only
# Linux Kernel 4.14.38 bootable config ends
# Windows bootable partition config begins
#other = /dev/sda1
# label = winXp3
# table = /dev/sda
# Windows bootable partition config ends
# PC-BSD bootable partition config begin
#other = /dev/sda4
# label = PC-BSD-10.1
# table = /dev/sda
# PC-BSD bootable partition config ends
I don't have winxp or pc-bsd installed anymore, but leave them there as templates. When needed, I run win-xp in VirtualBox.
BTW, I stopped using pc-bsd, now known as, true-os, when they forced users to switch to grub. I learned grub and had it working, but just didn't see the need to make things more complex than necessary and removed both grub and pc-bsd.

Last edited by cwizardone; 05-13-2018 at 11:24 AM.
 
Old 05-13-2018, 11:07 AM   #9
heyjann
Member
 
Registered: Dec 2015
Posts: 102

Rep: Reputation: Disabled
Quote:
Originally Posted by ProzacR View Post
Still same error with:
Code:
boot = /dev/sda
Did you also add a boot entry for linux to lilo.conf, for example:

Code:
# Linux bootable partition config begins
  image = /boot/vmlinuz
  root = /dev/sda3
  label = Linux
  read-only
# Linux bootable partition config ends
and run

Code:
/sbin/lilo
again?
 
Old 05-13-2018, 11:26 AM   #10
ProzacR
LQ Newbie
 
Registered: Jan 2006
Distribution: Slackware, Fedora
Posts: 28

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by heyjann View Post
Did you also add a boot entry for linux to lilo.conf, for example:

Code:
# Linux bootable partition config begins
  image = /boot/vmlinuz
  root = /dev/sda3
  label = Linux
  read-only
# Linux bootable partition config ends
and run

Code:
/sbin/lilo
again?
Yes, my new still not working conf based on old:
https://pastebin.com/Y8KQgENH
 
Old 05-13-2018, 11:27 AM   #11
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 2,973

Rep: Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346Reputation: 1346
Quote:
Originally Posted by enorbet View Post
Yeah on the few distros I've tried that all but demand Grub2 I disable OSprober and take control but it is substantially more complex at no significant advantage for me. If you have some benefit to mention that I'm possibly missing out on, please do share. Currently, for me and many others Grub2 just doesn't hold up in a cost/benefit comparison. Possibly this is because LILO was designed originally for manual control while Grub was designed from the start to "help out". I have no use for butlers that get underfoot.
Not having to run lilo prior to rebooting the system after a kernel upgrade as well being able to take control of the boot process interactively are benefits in my book. Perhaps not yours.
 
Old 05-13-2018, 12:23 PM   #12
ProzacR
LQ Newbie
 
Registered: Jan 2006
Distribution: Slackware, Fedora
Posts: 28

Original Poster
Rep: Reputation: 2
Solved by altering SATA drive list order in BIOS. Bootable was moved to first. I have 3 SATA drives.
 
Old 05-13-2018, 02:55 PM   #13
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 1,867

Rep: Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765Reputation: 1765
Quote:
Originally Posted by Richard Cranium View Post
Not having to run lilo prior to rebooting the system after a kernel upgrade as well being able to take control of the boot process interactively are benefits in my book. Perhaps not yours.
True for those that auto-update kernels. I build my own so yes... "not mine". I actually like the checking process of running /sbin/lilo so any typos or other errors get caught before actual booting and I have no use for interactive when properly configured and booting to runlevel 3. Probably a lot of just habit but I always have several OpSys installed and I like chainloading so each has a bootloader installed to root with only one main loader in MBR. That allows for customization and easy recovery in case of any problems. It's not for everybody but it works well for me and has for almost two decades. The Slackware Install disk has all the boot options I ever need in such cases.
 
2 members found this post helpful.
  


Reply

Tags
grub, lilo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Before Install: Slackware over Ubuntu (Grub to LILO), Dual w/Vista: LILO question Ubunoob001 Slackware - Installation 3 03-01-2010 03:01 PM
Changing GRUB-GRUB, GRUB-LILO and vice versa andreas_skw Linux - Newbie 1 06-05-2008 06:40 AM
Moving from GRUB to LILO. effigy Linux - General 4 02-15-2007 02:18 AM
Switching from grub to lilo, messed up Lilo.conf, rescuing via Knoppix. SonicGT Debian 2 08-21-2005 01:15 PM
Moving LILO Baldrick65 Linux - Newbie 3 07-24-2004 07:26 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration