LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-11-2004, 05:31 PM   #1
webshark
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 10.1
Posts: 23

Rep: Reputation: 15
Question Moving files from NTFS drive to a EXT3 drive??


I am a recent convert to Linux (Slackware 10) because I lost a big chunk of my files to windows and partition magic. So, to avoid this from happening again I want to put my apps, music, movies, games, e-books, etc. onto my new Slackware Server.

I was able to get most of these files off of the 160GB NTFS hard drive and put them on a 120GB NTFS hard drive.

I have also formatted the 160GB hard drive with EXT3 and partitioned it...so I think its ready to go again.

My problem is getting the files that are on the 120GB NTFS hard drive over to the 160GB EXT3 hard drive

I have tried to mount it ( # mount -aw -t NTFS /dev/hdd1 /backup )

but all i get is an error that reads, "fs type not supported by kernel"

My first thought was to put the 160GB EXT3 drive in the slackware computer...
and then put the 120GB NTFS drive in the Fedora/win2000 computer.......

BUT......I can't get the networking or file sharing or anything of the sort to work correctly.


All i want is the simplest and quickest wat to get my files onto the other hard drive. I've been racking my brain so much on this i think i'm missing something really simple and i will shoot myself when one of you mentions it (i won't really shoot myself).

Thank you.
Webshark

PS.....whoever helps me with this, I will give you access to my FTP when i get this all setup, but FTP server questions will be for another day. :-)
 
Old 09-11-2004, 05:38 PM   #2
Worstje
Member
 
Registered: Mar 2004
Distribution: Slackware-current
Posts: 93

Rep: Reputation: 15
Are you using the stock kernel of Slackware? I am not sure if it includes support for NTFS but it doesn't look like your kernel is. Try recompiling your kernel (which is alot easier than it sounds dont worry ) Just look for a howto on the web
 
Old 09-11-2004, 05:43 PM   #3
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Try mount -aw -t ntfs /dev/hdd1 /backup (without the caps in ntfs, remember linux is case sensitive )
 
Old 09-11-2004, 10:39 PM   #4
webshark
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 10.1
Posts: 23

Original Poster
Rep: Reputation: 15
I tried it again using lower case, and i got the same error.

I will look into recompiling the kernel, thanks!! :-)
 
Old 09-11-2004, 11:11 PM   #5
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Ok, just curious anyways, why are you using the -aw parameter? I've read what it does, and linux by default doesn't support writting to ntfs partitions (it's very experimental, limited and not recommended except you get some third party drivers). Also the -a command seems to mount all the stuff in fstab, I'm sure you don't want to do that...
Try: mount -t ntfs /dev/hdd1 /backup just in case...
Also, slackware by default supports reading ntfs filesystems.
 
Old 09-12-2004, 12:05 AM   #6
WMD
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware, Debian
Posts: 484

Rep: Reputation: 30
modprobe ntfs
That should load the driver. If it isn't compiled in for some reason...do a search for a Red Hat NTFS tutorial. Same issue, I don't remember the solution off hand.
 
Old 05-28-2006, 12:12 AM   #7
vimal
Red Hat India
 
Registered: Nov 2004
Location: Kerala/Pune,india
Distribution: RedHat, Fedora
Posts: 260

Rep: Reputation: 34
Hello webshark,

You could make the OS decide the type of the filesystem that is on the disk you are going to mount. You can use the 'auto' option instead of 'ntfs'. This would make the OS probe the disk for the filesystem and mount it correspondingly. Also use the 'read only' option with the '-o' switch. Writing to an NTFS partition is still in development, as you know. So you could use the command 'mount -t auto -o ro /dev/hdd1 /backup'. Usually the command works even if you specify the 'ntfs' option, has not faced a trouble all these time. So could you please just send in what are you getting when you try this command.. Also have you partitioned the hard drive and mounted it to /backup alright? That too may cause a problem.. Waiting for your reply..


Thanks,,,
 
Old 05-28-2006, 12:31 AM   #8
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 59
I would just use Windows to make a FAT32 partition somewhere, copy the files to it, where you'll easily be able to pick them up from Linux.
 
Old 05-28-2006, 12:28 PM   #9
Randux
Senior Member
 
Registered: Feb 2006
Location: Siberia
Distribution: Slackware & Slamd64. What else is there?
Posts: 1,705

Rep: Reputation: 54
Sorry that you lost your files, man. It's a little late now, but Linux tools seem to have a lot better record with resizing NTFS than Winbloze tools do. You can use the qtparted GUI (which invokes ntfsresize as needed) from Live CDs like Kanotix.

The "stock" Slackware 2.4.31 kernel (the one from the installation disk) does indeed include NTFS read support. I have my setup with Winbloze as my doc and music server and I can read everything from my Slackware and Debian machines. I used to mount it all the time and I didn't have to specify ntfs in the mount command.

Try a plain mount with no options, like this:

Code:
mount /dev/hdd1 /backup
I got tired of issuing the command so I just updated my fstab so that it gets mounted on startup.

I have an entry in my fstab like this:

Code:
/dev/hda9     /mnt/NTFS     ntfs     auto,owner,ro,umask=0222 0 0

Last edited by Randux; 05-28-2006 at 12:31 PM.
 
Old 05-28-2006, 02:38 PM   #10
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
If you do decide to recompile the kernel, I would recommend using the latest 2.6 kernel from kernel.org. NTFS is supported better in the 2.6 kernel. By the way, creating a fat32 drive and moving the files there is a great way to share the files between both OS. ext3 is not supported natively in windows and you will need to get 3rd part software to do it. (I'm not sure how reliable this is)

regards,
...drkstr
 
Old 05-28-2006, 03:02 PM   #11
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,112

Rep: Reputation: Disabled
The
Code:
modprobe ntfs
should do it, since the ntfs driver is not being loaded by default in Slackware. If you want to have the driver loaded on every boot, open the file
Code:
/etc/rc.d/rc.modules
in an editor and look for the line
Code:
#/sbin/modprobe ntfs
Remove the hash '#' and after reboot, the driver will be loaded automatically.

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Moving Hard Drive Files Zawi Linux - General 10 08-17-2005 11:08 AM
Moving/Writting files to 2nd hard drive LiquidFlame Linux - Newbie 2 04-25-2005 04:40 PM
Moving Kmail files to new drive linuxian Mandriva 0 08-13-2004 04:57 AM
ext3 formatted drive capacity smaller than ntfs gsupp Linux - General 12 07-25-2004 02:47 PM
Cannot Copy Files From Network FAT32/NTFS Drive to My Local Linux Drive michaelh Linux - Networking 3 10-29-2002 10:27 AM


All times are GMT -5. The time now is 08:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration