-   Slackware (
-   -   Moving files from NTFS drive to a EXT3 drive?? (

webshark 09-11-2004 05:31 PM

Moving files from NTFS drive to a EXT3 drive??
I am a recent convert to Linux (Slackware 10) because I lost a big chunk of my files to windows and partition magic. So, to avoid this from happening again I want to put my apps, music, movies, games, e-books, etc. onto my new Slackware Server.

I was able to get most of these files off of the 160GB NTFS hard drive and put them on a 120GB NTFS hard drive.

I have also formatted the 160GB hard drive with EXT3 and partitioned I think its ready to go again.

My problem is getting the files that are on the 120GB NTFS hard drive over to the 160GB EXT3 hard drive

I have tried to mount it ( # mount -aw -t NTFS /dev/hdd1 /backup )

but all i get is an error that reads, "fs type not supported by kernel"

My first thought was to put the 160GB EXT3 drive in the slackware computer...
and then put the 120GB NTFS drive in the Fedora/win2000 computer.......

BUT......I can't get the networking or file sharing or anything of the sort to work correctly.

All i want is the simplest and quickest wat to get my files onto the other hard drive. I've been racking my brain so much on this i think i'm missing something really simple and i will shoot myself when one of you mentions it (i won't really shoot myself).

Thank you.

PS.....whoever helps me with this, I will give you access to my FTP when i get this all setup, but FTP server questions will be for another day. :-)

Worstje 09-11-2004 05:38 PM

Are you using the stock kernel of Slackware? I am not sure if it includes support for NTFS but it doesn't look like your kernel is. Try recompiling your kernel (which is alot easier than it sounds dont worry :)) Just look for a howto on the web :)

gbonvehi 09-11-2004 05:43 PM

Try mount -aw -t ntfs /dev/hdd1 /backup (without the caps in ntfs, remember linux is case sensitive :) )

webshark 09-11-2004 10:39 PM

I tried it again using lower case, and i got the same error.

I will look into recompiling the kernel, thanks!! :-)

gbonvehi 09-11-2004 11:11 PM

Ok, just curious anyways, why are you using the -aw parameter? I've read what it does, and linux by default doesn't support writting to ntfs partitions (it's very experimental, limited and not recommended except you get some third party drivers). Also the -a command seems to mount all the stuff in fstab, I'm sure you don't want to do that...
Try: mount -t ntfs /dev/hdd1 /backup just in case...
Also, slackware by default supports reading ntfs filesystems.

WMD 09-12-2004 12:05 AM

modprobe ntfs
That should load the driver. If it isn't compiled in for some a search for a Red Hat NTFS tutorial. Same issue, I don't remember the solution off hand.

vimal 05-28-2006 12:12 AM

Hello webshark,

You could make the OS decide the type of the filesystem that is on the disk you are going to mount. You can use the 'auto' option instead of 'ntfs'. This would make the OS probe the disk for the filesystem and mount it correspondingly. Also use the 'read only' option with the '-o' switch. Writing to an NTFS partition is still in development, as you know. So you could use the command 'mount -t auto -o ro /dev/hdd1 /backup'. Usually the command works even if you specify the 'ntfs' option, has not faced a trouble all these time. So could you please just send in what are you getting when you try this command.. Also have you partitioned the hard drive and mounted it to /backup alright? That too may cause a problem.. Waiting for your reply..


rickh 05-28-2006 12:31 AM

I would just use Windows to make a FAT32 partition somewhere, copy the files to it, where you'll easily be able to pick them up from Linux.

Randux 05-28-2006 12:28 PM

Sorry that you lost your files, man. It's a little late now, but Linux tools seem to have a lot better record with resizing NTFS than Winbloze tools do. You can use the qtparted GUI (which invokes ntfsresize as needed) from Live CDs like Kanotix.

The "stock" Slackware 2.4.31 kernel (the one from the installation disk) does indeed include NTFS read support. I have my setup with Winbloze as my doc and music server and I can read everything from my Slackware and Debian machines. I used to mount it all the time and I didn't have to specify ntfs in the mount command.

Try a plain mount with no options, like this:


mount /dev/hdd1 /backup
I got tired of issuing the command so I just updated my fstab so that it gets mounted on startup.

I have an entry in my fstab like this:


/dev/hda9    /mnt/NTFS    ntfs    auto,owner,ro,umask=0222 0 0

drkstr 05-28-2006 02:38 PM

If you do decide to recompile the kernel, I would recommend using the latest 2.6 kernel from NTFS is supported better in the 2.6 kernel. By the way, creating a fat32 drive and moving the files there is a great way to share the files between both OS. ext3 is not supported natively in windows and you will need to get 3rd part software to do it. (I'm not sure how reliable this is)


Alien Bob 05-28-2006 03:02 PM


modprobe ntfs
should do it, since the ntfs driver is not being loaded by default in Slackware. If you want to have the driver loaded on every boot, open the file

in an editor and look for the line

#/sbin/modprobe ntfs
Remove the hash '#' and after reboot, the driver will be loaded automatically.


All times are GMT -5. The time now is 04:05 PM.