LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Mouse Problem (https://www.linuxquestions.org/questions/slackware-14/mouse-problem-480132/)

meinzorn 09-03-2006 08:49 PM

Mouse Problem
 
When I load KDE my mouse will only move up and down, and it's no matter which direction I move my mouse. It makes random clicks and just acts plain weird. Any idea's?

byte weaver 09-03-2006 09:34 PM

Do you have a USB or PS/2 mouse? If you have a USB mouse, you might want to use the PS/2 adapter, if one came with it; I noticed that on Linux generally that produces fewer problems.

Also, check the mouse settings in "/etc/X11/xorg.conf".

I had similar problems when installing Slackware 10.2 for the first time. After installing it again, I discovered what the problem was: You (apparently) have to select the right mouse driver for gdm. If you choose "Regular PS/2 mouse" or something, it's apparently the best choice.

For X Windows (and KDE), in /etc/X11/xorg.conf", try selecting the ImPS/2 protocol:

Code:

# ---8<--- lots of comment removed --->8---
Section "InputDevice"
    Identifier    "Mouse1"
    Driver        "mouse"
    Option        "Protocol" "ImPS/2"
    Option        "Device" "/dev/mouse"
    Option        "Buttons" "6"
    Option        "ZAxisMapping" "4 5"
EndSection


meinzorn 09-03-2006 10:30 PM

I tried using one of the adapters and it says that it can't find any device.

and I have all my settings the same as that, and it still doesn't work.. like, the mouse moves.. but it does all kinds of whacky stuff:

moving only up and down.
If I click on any of the buttons and hold and move the mouse, it will move only to the right, but it'll move diaganally (spl)
also when I click on the buttons the cursor will move slightly to the right.. a couple of pixels.
it also randomly middle clicks..even if I don't move it or anything



I tried using the protocol microsoft, and it was completly eratic.. It moved but in every direction no pattern or anything.


It's a wireless microsoft mouse, USB

lurko 09-04-2006 01:55 AM

I also had this issue, and setting the right protocol (imps/2) was not the solution. I solved this problem on my slack 10.2 install by uncommenting /sbin/modprobe/hid in /etc/rc.d/rc.modules. it's the first item under the heading "### USB Device Support"

if that's not enough, try uncommenting the next line too (usbmouse)

once I compiled a new kernel though, this problem was gone and I re-commented the hid line in rc.modules.

meinzorn 09-04-2006 06:52 PM

Will this allow it to work as a USB mouse or will I have to use it as PS/2?

lurko 09-04-2006 08:57 PM

my mouse is USB, M$ "comfort optical 3000", should be no need to use a ps/2 converter.

fabri_berloco 06-07-2009 08:10 AM

Option "CorePointer"
 
Quote:

Originally Posted by byte weaver (Post 2408099)
Do you have a USB or PS/2 mouse? If you have a USB mouse, you might want to use the PS/2 adapter, if one came with it; I noticed that on Linux generally that produces fewer problems.

Also, check the mouse settings in "/etc/X11/xorg.conf".

I had similar problems when installing Slackware 10.2 for the first time. After installing it again, I discovered what the problem was: You (apparently) have to select the right mouse driver for gdm. If you choose "Regular PS/2 mouse" or something, it's apparently the best choice.

For X Windows (and KDE), in /etc/X11/xorg.conf", try selecting the ImPS/2 protocol:

Code:

# ---8<--- lots of comment removed --->8---
Section "InputDevice"
    Identifier    "Mouse1"
    Driver        "mouse"
    Option        "Protocol" "ImPS/2"
    Option        "Device" "/dev/mouse"
    Option        "Buttons" "6"
    Option        "ZAxisMapping" "4 5"
EndSection


I removed the line
Options "AlwaysCore" and
added the line
Option "CorePointer"
to Synaptics Touchpad and USB Mouse Sections, and it worked greatly.
I hope it will be useful...

kingbeowulf 06-07-2009 10:19 PM

What does "X -configure" say?
 
For ages, I've used the following command as root, especially in the newer 2.6.24+ kernels,
Code:

root@gandalf:~# X -configure
and then examined xorg.conf.new in the root directory as a skeleton to tweak. I usually end up with
Code:

Section "InputDevice"
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

On some laptops, to allow use of a hotplugged USB mouse in addition to the built in touchpad or button I add a second "Mouse1" section with
Code:

Option        "Protocol" "evdev"
Since 12.0 (either Slackware of SLAMD64) I haven't had issues hot plugging USB mice. It is well worth the effort to see what X will autodetect before just throwing together whatever configuration file you think should work.


All times are GMT -5. The time now is 05:03 AM.