-   Slackware (
-   -   mouse problem (

jorgehr 01-30-2003 03:11 AM

mouse problem
hi ,

just a stupid question - i'm new to slack -

i installed slack 8.1 with xfs and nearly everything went well.

the mouse (i tried ps2, serial) is my big problem. this little beast didn't want to work- not at console neither in X11!
i'm absolut sure that there is no hardware-defekt, because it's working well in my other linux-installation(RH7.3-reiserfs) on the same machine.

i already checked some logfiles-but for me everything looked fine!?

please give me an advice where to look for the reason of my problem.

thanx for reading this

juergen h.

MasterC 01-30-2003 03:14 AM

:) How do you plug the mouse in?

Also, have you tried configuring your x server? Tried running mouse config? Also, check your /etc/X11/XF86Config file to ensure it has the correct protocol for your mouse (probably ps/2)


jorgehr 01-30-2003 03:53 AM

hi MasterC,
thanx for your reply-

i run mouseconfig, "x11config" and i checked the configfiles in /etc; they seemed to be ok (looking like files of working distros), i mean when i tried a ps2 then entry was like that and when i tried a serial one, the entries were set to serial.
after changing i stopped and start again the "mouseserver".

i connected in case of ps2-mouse to the ps2-port the one beside the keybord ;-)

in case of the serial one to the serial port.

i think the fact that the mouse worked well (without ANY changes) with another distro prove that the connection was ok!?


MasterC 01-30-2003 03:56 AM

Yeah, it's probably not a problem with your mouse, but rather your config. Can you post the pointer section from your /etc/X11/XF86Config file? And also let us know the type of mouse you prefer to use :)


born4linux 01-30-2003 03:59 AM

try this:

cat /dev/mouse

then move the mouse. it should generate ascii characters in response to the mouse movement. this way you can check that the mouse is indeed working.

btw, /dev/mouse is just a link to the device where the mouse is attached.

st0kk 01-30-2003 04:10 AM

I have the same problems... almost
The symtom is a flickering mouse that make gigant leaps .. not usable in X but ...
The mouse is working in console but not in X ...
gpm is started with
gpm -R raw -m /dev/psaux -t imps2

---Snip form XF86config----
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "true"
Option "Device" "/dev/gpmdata"

The mouse is a logitech cordles ps2 mouse with a webbwheel and buttons.

jorgehr 01-31-2003 02:33 AM

mouse problem

once again some comments about my lazy animals.

the idea with cat /dev/mouse was great!

it helped me to find out, that i'm becoming old- sorry i took the wrong ttyS ! :-(( STUPID me!!

the serial mouse is working now (console and X11)! so thanx to all.

the ps2 (i used a very cheap wireless-not opt.- one from the supermarket at the corner and a "classical" with cable made by DELL) didn't want to work.
btw before i tried the ps2 i changed the link ...mouse to psaux.
any further ideas how i could check the ps2-port under slack 8.1?


All times are GMT -5. The time now is 08:28 PM.