LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Mouse pointer - no movement (https://www.linuxquestions.org/questions/slackware-14/mouse-pointer-no-movement-447476/)

Twister512 05-22-2006 05:51 PM

Mouse pointer - no movement
 
ok I just installed fresh Slack current and installed kernel 2.6 from the 2nd cd. I can't for the life of me get the mouse to work at all, tried it on another computer, works great. I am still pretty new to this whole linux thing, is there a mouse setup utility that I can run from the command line?

Any help appreciated.

Thanks - Paul-

vonst 05-22-2006 07:07 PM

That is a lot of interesting information in the first sentence. Define "Slack current" evidently you didn't swaret from Slackware-10.2 to Slackware-current. What do you mean that you got the kernel from the 2nd CD?

I'm going to make the assumption that you just installed 10.2 and you used the "test26.s" kernel image. And evidently things are running well enough that you got the command line. When you ran "setup" did you opt to install the mouse? Do you have a regular mouse that plugs into the PS/2 port? Or is it a USB mouse? Did you tell it that you wanted a "ps2" mouse, which is the default? And finally, to change the question... did you run "startx" to start your X-windows graphics environment (or are you still on the black command line CLI environment)?

--vonSt

Twister512 05-22-2006 08:43 PM

Yes, used test 2.6, run startx and my mouse pointer sits in the middle of the screen, won't move. I ran mouseconfig, xorgconfig, and rebooted and still nothing.

Anonymo 05-22-2006 11:10 PM

you have to go to the second cd and install the kernel-modules. then your mouse will work

drkstr 05-23-2006 12:45 AM

If you have a usb mouse, you need to enable support in your kernel for:
Device Drivers --->
Input Device Support --->
<*> Event Interface
Otherwise the mouse will do random buggy things. (freezing being one of them)

regards,
...drkstr

vonst 05-23-2006 04:07 PM

They all speak the truth. Just what kind of mouse do you have? PS/2? USB? Something really old?

--vonSt


All times are GMT -5. The time now is 07:50 AM.