-   Slackware (
-   -   Mouse not working with -current (

rwcooper 01-01-2008 01:04 PM

Mouse not working with -current

I downloaded -current on 2007/12/31. I installed it today and my PS2 mouse no longer works (it still works fine under 12.0). /dev/mouse is a link to input/mice (same as on 12.0). I tried cat on /dev/mouse, /dev/psaux, /dev/input/mouse0 and /dev/input/mice but none of them worked. I tried changing the protocol to imps2 in /etc/modprobe.d/psmouse as that's what I use with gpm. I have tried both the huge and huge-smp kernels. I've checked dmesg and there are no messages from gpm.

This is my first attempt at using -current, I've always used the stock distribution before, with the newest kernel supplied on the CDs. Is there some place else I should be reporting this problem?

Thanks for any help you are able to provide.


Alien Bob 01-01-2008 01:32 PM

See if installing the kernel-modules package makes any difference.

The huge kernels are mainly meant for installing Slackware (they are stuffed with network and storage drivers) but not necessarily for daily work.
The Slackware CHANGES_AND_HINTS.TXT points out the same - you should switch to a generic kernel or build one yourself soon after installation.


Toods 01-01-2008 02:20 PM

Do you have a file: /etc/modprobe.d/psmouse containing the line options psmouse proto=imps in it?.

Also check that there is not an entry for psmouse in /etc/modprobe.d/blacklist (or blacklist~).


All times are GMT -5. The time now is 04:46 AM.