-   Slackware (
-   -   Mouse not working on xfce slackware 14 (

zrdc28 11-07-2012 02:30 PM

Mouse not working on xfce slackware 14
I have googled this for many hours and can not find an answer, I am using xfce slack 14. This is my wife's computer, when she logs into slack the mouse is very jumpy and the keyboard does not work at all. I have switched the mouse, kboard, etc and tried so many things found on the net that I can not even remember them all. I can log in as root or guest and everything works as normal. I have used slackware for many years but I have had very poor luck tracing this down. If anyone has a suggestion I would sure appreciate the help. Hp 51 pentium 4 at 2.53 768 meg memory Slackware 14

markush 11-07-2012 02:58 PM


does the computer boot to runlevel 3 or 4? Can your wife use the mouse with another windowmanager e.g. fluxbox? Which files are in /etc/X11/xorg.conf.d/?
Are there any mousesettings configured with XFCE?


zrdc28 11-07-2012 03:12 PM

Thanks for the quick reply! It boots into run level 3 and the mouse and kboard works fine as root xfce & guest xfce. I am not at home now but will check the other in a few minutes. I do not see any errors with dmesg or system log.

markush 11-07-2012 03:35 PM

When the computer boots to runlevel 4, there are different scripts sourced (by the login-manager). You could in runlevel 3 as root execute "telinit 4" and then start an XFCE-session. If it works this way, it is very likely that the configuration in your wife's homedirectory is messed up.


zrdc28 11-07-2012 04:24 PM

Which files are in /etc/X11/xorg.conf.d/?
It is empty

You could in runlevel 3 as root execute "telinit 4" and then start an XFCE-session.
When I do that and log in with her login it is just the same Jumpy mouse & no keyboard

markush 11-07-2012 04:30 PM

Well, one can copy the files from /usr/Share/X11/xorg.conf.d/ into /etc/X11/xorg.conf.d/
Normally this is useful if one needs another keyboard-layout, but there are also configfiles for the mouse and evdev. But note that if you have a /etc/X11/xorg.conf file, it will override the settings in /etc/X11/xorg.conf.d/

I'd try out another windowmanager, when logged in as your wife, use xwmconfig and select for example fluxbox or twm or what ever.


zrdc28 11-07-2012 06:00 PM

I set the wm to fluxbox and it works fine, no problems whatsoever. I copied all files from usr/share/x11/xorg.conf.d over
to /etc/X11/xorg.conf.d/ and renamed xorg.conf to xorg.conf.old and still had the same results. I believe it is something
to do with xfce.

markush 11-08-2012 01:06 AM

The configuration for XFCE resides in ~/.config/xfce4. One could delete (or rename) this folder and then (if hopefully the problems with keyboard and mouse are gone) configure XFCE from scratch.

If you've upgraded from earlier versions of XFCE (or Slackware) and use still the old configuration, couldn't it be possible, that the configuration is no longer working?


zrdc28 11-08-2012 08:30 AM

I sure appreciate your help on this, I will try that when I get home this afternoon . My wife is using it with fluxbox so everything will be ok until it is repaired.

zrdc28 11-09-2012 08:10 PM

I did as Marcus suggested except I went to /home/wife/.config/xfce4 and erased xfce4 and copied the xfce4 from guest over to
/home/wife/.config/. As of now the thing is working fine, but I am not ready to consider in solved. The first thing I tried was just renaming the /home/wife/.config/xfce4 to xfce.old and letting it write a new one, but that failed to work any better.
I sure appreciate the help on this, I will try it a day or two and see if it is ok.

zrdc28 11-11-2012 11:05 PM

Everything seems to be working, so I will mark this one solved, thanks for the help!

All times are GMT -5. The time now is 08:00 PM.