-   Slackware (
-   -   Mouse & internet problem (

scompa 05-13-2006 05:22 AM

Mouse & internet problem
Ok, after about 6 hours trying to get Slackware running I finally succedded. My problem is this: My mouse is working for cca. 30 sec then don't work some time, then again work etc... On Windows is working fine. Protocol is set to 'auto'. I tried to put it and to microsoft, but then it work really strange - we could say that id don't work. Mouse is Azona OP-2008, USB. I am working on laptop so I have and a touch pad or how is it called (replacement for mouse) and this don't work at all. I would really like to get this working too.

Next question is about internet. How do I connect to internet over PPPoE? I am new to linux (1 day) so I have no idea.

Jerre Cope 05-14-2006 01:29 AM

Be sure that you have the /etc/rc.d/rc.hotplug script permissions set to chmod 755. You need hotplug to recognize USB devices. It should recognize the touchpad as well.

You can use dmesg to debug hardware problems.

See if you have this file on your system:


introuble 05-14-2006 06:06 AM

What crazynes made you chose Slackware as your first distribution?

scompa 05-14-2006 01:00 PM

Dont work...

scompa 05-14-2006 01:06 PM

Ok, I reinstalled Slackware and I got internet and touchpad working, but usb mouse not.

Here are my xorg.conf:

Section "InputDevice"
Identifier "USBMouse"
Driver "mouse"
Option "Device" "/dev/mouse"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"

Section "InputDevice"
Identifier "Touchpad"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"

InputDevice "Touchpad" "CorePointer"
InputDevice "USBMouse" "AlwaysCore"
I tried to change ImPS/2 to auto and usb, /dev/mouse to /dev/input/mice but nothing works. When I try # cat /dev/mouse or # cat /dev/input/mice, I got 'No such device' error. I also chmoded rc.hotplug but dont work... Mouse work fine with WinXP so it's not broken...

I am doing this for 2 days, I searched whole internet and I don't know what to do anymore...

Jerre Cope 05-14-2006 09:28 PM

As root, type tail -f /var/log/messages from a terminal window. This will let you watch the hotplug action real time.

Plug in the mouse, remove the mouse, plug in the mouse and watch what happens on the messages log.

Press control-d to exit the tail program when you're finished looking.

Also, I think you need to use /dev/usbmouse, rather than /dev/mouse, but I don't have a usb mouse to test for sure.

Make sure you have Input Devices "/dev/usbmouse" in your "Section Files"

Slackware is my favorite distribution. If in fact, I don't think I've ever found any open source project that didn't just compile correctly the first time on slackware. Compiling a new kernel is also easy compared to some canned distributions.

However, I've found OpenSUSE to be more laptop friendly as far as loading all the hardware right the first time. The xorg internals you've learned so far still apply, but there's a greater chance that YaST will take care of the configuration for you. I'm guessing you'll be using your laptop as a client and personal productivity tool rather than a developer station. If you're mostly into development and compiling, stick it out with Slackware.

If you have a broadband connection, go to the and download the Internet Installation CD. You just boot this CD, feed in the ip address of a mirror, and the whole installation takes place over the wire. Next, let the YaST online update upload all the security patches, and away you go.

Old_Fogie 05-15-2006 02:13 AM

FWIW I couldnt get USB mice to work on Slackware 10.2 w/the default 2.4 kernel on 2 of my boxes. Putting in the testing kernel took care of it.

Nylex 05-21-2006 12:25 PM

My USB mouse works fine with the default 2.4.31 kernel on my laptop.


Originally Posted by Jerre Cope
Also, I think you need to use /dev/usbmouse, rather than /dev/mouse, but I don't have a usb mouse to test for sure.

I don't think you do, well at least, mine works with /dev/mouse. Actually, IIRC when you run xorgconfig, it asks you what device you want to refer to your mouse as (I think, I can't remember and I installed Slack on this machine on Friday!). If you just hit Enter, the default (/dev/mouse) is used.

scompa, maybe try adding the line

Option "SendCoreEvents" "true"

to your the section for your USB mouse and then removing the "AlwaysCore" bit from the line in the ServerLayout section.

This works for me and I'm able to use both my touchpad and USB mouse.

simcox1 05-21-2006 12:55 PM

Option "Protocol" "ImPS/2"

Shouldn't this line be "IMPS/2" ?

I use "ExplorerPS/2" as the protocol.

Old_Fogie 05-22-2006 12:30 AM


Originally Posted by introuble
What crazynes made you chose Slackware as your first distribution?

LOL, I"m a little slow and just saw this. hahahah.

cwwilson721 05-22-2006 01:03 AM

Here is my xorg.conf. Compare yours to mine, and see what needs to change (My touchpad is a Synaptics, so you can ignore driver specific stuff for that).

I have both usb mouse and touchpad working fine. Even in 2.4.xx kernels (I always use the same xorg.conf)

**Cat** 12-12-2006 06:27 PM

wilson, link to xorg.conf not working... can we have a glimpse of your conf? :P

cwwilson721 12-13-2006 04:30 AM

Sorry....wrong link

Use this one (Also fixed above)

All times are GMT -5. The time now is 08:55 AM.