LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Mounting NTFS for users other than root (https://www.linuxquestions.org/questions/slackware-14/mounting-ntfs-for-users-other-than-root-182905/)

Tarwedge 05-18-2004 10:56 AM

Mounting NTFS for users other than root
 
Im having trouble getting Slackware to let normal user accounts access my NTFS partition. Root can access fine, but thats not incredibly practical for everyday usage since id be more or less opening files from my NTFS partition the whole time im using the computer.

Here is my fstab:

Code:

/dev/hda2        /                reiserfs    defaults        1  1
/dev/cdrom      /mnt/cdrom      iso9660    noauto,owner,users,ro  0  0
/dev/fd0        /mnt/floppy      auto        noauto,owner    0  0
devpts          /dev/pts        devpts      gid=5,mode=620  0  0
proc            /proc            proc        defaults        0  0
/dev/hda1        /mnt/windows    ntfs        noauto,defaults,users,ro,  0  0

it mounts for all users, but if your not logged in as root you get "failed to read directory" on /mnt/windows

Any ideas?

shilo 05-18-2004 11:01 AM

I had a similar problem wit hmy fat32 partition. I changed my /etc/fstab to
Code:

/dev/hda1        /fat-c          vfat        auto,rw,umask=000        1  0
It works great now. Try adding the umask=000 to your's and see if it works.

Tarwedge 05-18-2004 11:07 AM

Tried it, no change. Damn. thanks for the suggestion though

Stuartb21 05-18-2004 11:23 AM

try removing defaults and replacing it with the individual options.

I will post back when i find where ive wrote them down!

muah 05-18-2004 12:09 PM

Code:

/dev/hda1        /mnt/windows    ntfs        ro,umask=000,user  0  0
works for me.
'user' gives a normal user privilige to mount/umount partition.
'umask=000' gives him full access to all files

shilo 05-18-2004 12:12 PM

Probably sounds dumb, but did you reboot after the changes?

nukkel 05-18-2004 03:51 PM

No need to reboot! Just type 'umount /mnt/windows && mount /mnt/windows'

shilo 05-18-2004 04:22 PM

Doh!!! I've got a lot to learn. I reboot for just about everything. It's a bad habit you pick up when your first computer is Windows ME. :)

bashrc2 05-18-2004 11:16 PM

how can you mount as "user"??? in my slackware it says.. you are not root/ only root can do that... stuff....

so how can I mount as user???????

shilo 05-19-2004 12:07 AM

bashrc2-

Add the proper entry to /etc/fstab . That's what this thread is all about. Here's a copy of my entire /etc/fstab file. Maybe it will give you an idea. I would help more, but you didn't give any information about what you were trying to mount. Anyways, here's my /etc/fstab file:
Code:

/dev/hda3        swap            swap        defaults                        0  0
/dev/hda2        /                reiserfs    defaults                      1  1
/dev/hda1        /fat-c          vfat        auto,rw,umask=000        1  0
/dev/cd-rw      /mnt/cd-rw      iso9660    noauto,user,ro                  0  0
/dev/dvd-rom    /mnt/dvd-rom    iso9660    noauto,user,ro                  0  0
/dev/fd0        /mnt/floppy      auto        noauto,user                    0  0
devpts          /dev/pts        devpts      gid=5,mode=620                  0  0
none            /proc            proc        defaults                        0  0
#none                /sys                  sysfs              defaults                        0  0
#none                /sys/bus/usb    usbfs      defaults                        0  0

As you're reading through this file, note that "#" means "ignore this line", and also note that any of my users can mount any of the devices that they wish. (Big hint: "user")

nukkel 05-19-2004 12:34 AM

Quote:

Originally posted by shilo
I reboot for just about everything. It's a bad habit you pick up when your first computer is Windows ME. :)
LoL :) Tell me about it...
* Changed your IP address? Reboot.
* Installed a prog? Reboot.
* Up more than a week? Reboot.
* Changed the wallpaper? Reboot --- uh... not sure about this one :D

shilo 05-19-2004 12:55 AM

Dude, if you had Windows ME running for a whole week before having to reboot, you might just be my new computer hero. I made a habit of rebooting that thing every day!!!

bashrc2 05-19-2004 02:11 AM

thanks guys.. ill try that at home later.. anyway how come your using iso9660 for dvd-rom? isnt it suppose to be udf?


thanks,
bash

bashrc2 05-19-2004 02:26 AM

i sshed to my home computer from work and changed /etc/fstab here is what it looks like now:


Code:

/dev/hdc9        swap        swap        defaults          0  0
/dev/hdc1        /                  reiserfs    defaults          1  1
/dev/hdc5        /usr            reiserfs    defaults          1  2
/dev/hdc6        /home      reiserfs    defaults          1  2
/dev/hdc7        /var            reiserfs    defaults          1  2
/dev/hdc8        /tmp          reiserfs    defaults          1  2
/dev/hda5        /mnt/fat-d      vfat      auto,rw,umask=000 1  0
/dev/hda6        /mnt/fat-e      vfat      auto,rw,umask=000 1  0
/dev/hda7        /mnt/fat-f        vfat      auto,rw,umask=000 1  0
/dev/cdrom      /mnt/cdrom  udf,iso9660 noauto,user,ro    0  0
/dev/cdrom1    /mnt/cdrom1  so9660    noauto,user,ro    0  0
/dev/fd0            /mnt/floppy      auto          noauto,owner      0  0
devpts              /dev/pts        devpts      gid=5,mode=620    0  0
proc                  /proc            proc        defaults          0  0

and i still get this error

[bash_penguin@slackware1 ~]$ mount /mnt/fat-f
mount: only root can mount /dev/hda7 on /mnt/fat-f

[bash_penguin@slackware1 ~]$ umount /mnt/fat-f
umount: /mnt/fat-f is not mounted (according to mtab)

[bash_penguin@slackware1 ~]$ mount /dev/hda7 /mnt/fat-f
mount: only root can do that


thanks for any suggestions

nukkel 05-19-2004 04:22 AM

you need to add the 'user' option like you did with the CD drive. 'umask' determines who can read the files on the partition <--> 'user' determines who can mount the partition. Those are two very different things...

I think UDF is only found on some very recent DVD's... 99,...% of all CDROMs and DVDroms use iso9660. BTW, if in doubt you can always set the filesytem type for /dev/cdrom to 'auto', then the kernel will auto-detect the type.


All times are GMT -5. The time now is 04:45 AM.